Problème d'enregistrement de musique d'attente

Joined
Mar 27, 2009
Messages
45
Points
0
Bonjour.

J'ai un petit soucis avec l'enregistrement des musique d'attente.

Quand je crée ma catégorie, je parcours mes fichiers, j'upload et la j'ai ce message:


Error Processing: "sh: lame: command not found" for Tribal Thin Beat 79761.mp3!

This is not a fatal error, your Music on Hold may still work.


Et ma musique ne fonctionne pas? J'ai essayé avec plusieurs format de musique (wav, mp3...) mais ca veut pas. Même avec des fichiers son qui fonctionne dans l'enregistrement des message d'annonce, ca ne semble pas être un problème de codecs.

Un avis?
 
Joined
Dec 3, 2007
Messages
8,069
Points
88
Salut.

Pour ma part j'enregistre les musiques en format gsm. Comme indiqué dans la page:
Alternatively, upload a recording in any supported asterisk format. Note that if you're using .wav, (eg, recorded with Microsoft Recorder) the file must be PCM Encoded, 16 Bits, at 8000Hz:
Soit donc... 16 bits 8khz format gsm ou wav.

J'utilise l'utilitaire sous Windows WavePad version Free (et non pas la version Trial)

Perso, ça fonctionne bien.

Pour ton problème il est possible que l'encodage que tu as choisi ne convienne pas et que l'application ne puisse pas réencoder dans un format qu'Asterisk supporterait.

Je n'ai pas essayé le format 16 bits 64khz en wav qui se rapprocherait plus de la qualité G711.
 
Joined
Dec 3, 2007
Messages
8,069
Points
88
C'est de cette manière que je fais mes annonces et musiques d'attente.
J'utilise TextAloud avec des voix naturelles Acapela. ... Génial. :woohoo:
 
Joined
Dec 3, 2007
Messages
8,069
Points
88
Je connais, j'ai une voix de AT&T, mais de moins bonne qualité que Acapela.
 
Joined
Mar 27, 2009
Messages
45
Points
0
Bon eh bien ca marche plus.
J'ai voulu changer de musique d'attente, j'ai donc créer une nouvelle categorie, j'ai uploader, etc , j'ai modifier dans mas extension (la même demarche que précedemment) et la rien. J'ai toujours la même musique.

J'ai lu le chapitre d'ElastixWithoutTears sur musiconhold, j'ai essaye de faire pareil et la plus rien (je sais je suis une quiche...). Mais le pire, c'est que comme un c.., j'ai modifié le fichier musiconhold.conf (mal modifié je crois) mais sans sauvegarder le fichier d'origine (eh oui je suis un noub)

Quelqu'un pourrait me renvoyer la config d'origine de ce fichier?

Merci
 
Joined
Dec 3, 2007
Messages
8,069
Points
88
musiconhold.conf
;
; Music on hold class definitions
; This is using the new 1.2 config file format, and will not work with 1.0
; based Asterisk systems
;
#include musiconhold_custom.conf
#include musiconhold_additional.conf

Comme dans le film
: la 7em compagnie.... "Touches pas à çà p'ti c_n" :p

En fait, si tu veux refaire une musique d'attente, tu n'es pas obligé de refaire une catégorie, il suffit simplement d'écraser le fichier de la musique d'attente dans le répertoire /var/lib/asterisk/sounds/custom

Utilises WinSCP pour le transfert de fichier. ;)
 
Joined
Oct 25, 2010
Messages
131
Points
16
Salut Danardf,

j'ai également un soucis avec la musique d'attente j'ai créer une nouvelle catégorie j'ai uploader mon fichier .wav sans problème pas de message d'erreur, après sur les routes entrantes j'ai choisi ma catégorie de musique, mais lorsque je mets en attente aucun son rien du tout.

Aurais tu une idée ou qu'est ce que j'ai oublié de faire faut il modifier le fichier musiconhold.conf ?

Merci
 
Joined
Dec 3, 2007
Messages
8,069
Points
88
Hmmm, je sais qu'en V2.0 il y a eu des problèmes de moh.
Regardes du côté du site Elastix bug. (http://bugs.elastix.org/)

Sinon, essayes de regarder les log et voir ou Asterisk essaye de pointer pour lire ton fichier.
Sinon, tu as des commandes de maintenance en mode CLI autour de moh.

Regardes également si ton fichier a bien été créer et si ce n'est pas un problème de privilège au niveau du répertoire.
Il est possible que ta musique soit bien créée mais le fichier n'existe pas à cause d'un mauvais privilège.

Voilà pour les pistes à exploiter.s
 
Joined
May 20, 2009
Messages
309
Points
0
Bonjour yann_c
tes musique d'attentes sont dans /var/lib/asterisk/mohmp3
Peux tu faire un clique droit "ouvrir" sur la musique d'attente et me dire si tu entend quelque chose ? (en t'aidant de WinSCP)

Tu dis aussi que tu mets ta musique d'attente sur ta route entrante ; ce qui veux dire que si l'on t'appelle de l'exterieur et que tu effectue un transfert, ton correspondant (exterieur) entend ta musique d'attente.
Par contre, en interne il est normal que tu n'ai pas de musique d'attente !
 
Joined
Oct 25, 2010
Messages
131
Points
16
Danardf ,

mon fichier est bien créer les droit sont les même que sur les autres fichier ou répertoire à ce niveau.

Je vais regarder coté bug sur la verson 2.0

Buzzy,

J'ai ouvert mon fichier situé dans le répertoire mohmp3 et oui j'entends bien ma musique d'attente.

oui j'ai bien compris la notion niveau appel entrant sortant et interne, j'avais vu cela.

Je vais donc regardé niveau bug car la je vois pas d'où cela peut venir.
 
Joined
Dec 3, 2007
Messages
8,069
Points
88
Tu peux toujours essayer la config sur une machine virtuelle et essayer ta manip.
il est possible que ce soit un bug
 
Joined
Oct 25, 2010
Messages
131
Points
16
Bonjour,

Je pense que c'est un bug car j'ai essayé sur plusieur machine virtuelle et je n'arrive toujours pas a faire fonctionner ma musique d'attente.

C'est assez ennuyeux :-(

Merci
 
Joined
Dec 3, 2007
Messages
8,069
Points
88
Attention au format d'enregistrement des fichiers wav!!
Échantillon 8Khz 16bits mono.

J'ai une v2 à porté de main, je vais essayer.
 
Joined
Oct 25, 2010
Messages
131
Points
16
Bonjour,

Pour moi sa à marcher suite à une modification du fichier .wav avec l'aide de la commande sox du coup cela fonctionne sans problème.

Merci

A plus tard
 
Joined
Dec 3, 2007
Messages
8,069
Points
88
Pour info, il semblerait que Dahdi puisse avoir un effet sur le fonctionnement de la musique d'attente aussi.

Perso, j'utilise pour la conversion, un logiciel windows WavePad (version Free et non commerciale).

Converti au format gsm, wav...Etc

Jamais eu de problème avec.
Si ça intéresse quelqu'un, envoyez moi un mail perso.
 
Joined
May 20, 2009
Messages
309
Points
0
yann_c said:
Bonjour,

Pour moi sa à marcher suite à une modification du fichier .wav avec l'aide de la commande sox du coup cela fonctionne sans problème.

Merci

A plus tard
Bonjour yann_c
Peux tu m'indiquer exactement la ligne de commande que tu as utilisé avec sox stp.

merci à toi
 

Members online

No members online now.

Forum statistics

Threads
30,992
Messages
131,106
Members
17,716
Latest member
Orbit114
Top