PRI B-channel always restart

Discussion in 'General' started by ericng, Sep 2, 2009.

  1. ericng

    Joined:
    May 14, 2008
    Messages:
    78
    Likes Received:
    0
    I am having 2 PRI cards installed (one TE121, one TE120P) as follows:

    ; Span 1: WCT1/0 "Wildcard TE121 Card 0" (MASTER) HDB3/CCS/CRC4
    group=0,11
    context=dnid-custom2
    switchtype = euroisdn
    signalling = pri_cpe
    channel => 1-15,17-31
    context = default
    group = 63

    ; Span 2: WCT1/1 "Wildcard TE120P Card 1" HDB3/CCS/CRC4
    group=0,12
    context=dnid-custom
    switchtype = euroisdn
    signalling = pri_cpe
    channel => 32-46,48-62
    context = default
    group = 63

    I noted the B-channel for span 1 restarted every hour (when this happen, I will have calls drop or blank voice), is there anything that I can do to resolve this?

    Thanks and Regards,

    Eric
     
  2. hylan

    Joined:
    Aug 30, 2009
    Messages:
    3
    Likes Received:
    0
    By default the pri's will reset every hour. To disable it just add resetinterval=never to your current config.
     
  3. ericng

    Joined:
    May 14, 2008
    Messages:
    78
    Likes Received:
    0
    Hi Hylan,

    Thanks for the help. It works. BTW, what is the purpose of having pri's restarted.

    After settinf resetinterval=never, I still get the message 'B-channel restarted on span 1' but is not often, do you think this is a carrier provider's problem?
     
  4. hylan

    Joined:
    Aug 30, 2009
    Messages:
    3
    Likes Received:
    0
    I'm not sure why they restart the PRI channels but some service providers and PABX's have this issue. Glad it's working now.
     
  5. ramoncio

    Joined:
    May 12, 2010
    Messages:
    1,663
    Likes Received:
    0
    Hi Eric,

    If you want to remove these messages, add
    bri_l1_check=0
    to your chan_dahdi.conf

    The thing about restarting the channels is because here in Spain, Telefonica shuts down ISDN BRI layer 2 for power saving purposes. And if you don't set the resentinterval=never, you can't make outgoing calls until you receive a call that turns layer 2 on. Restarting the channels solves this problem.
     

Share This Page