Prevent g729 transcoding on outgoing calls

Discussion in 'General' started by tony722, Jan 20, 2011.

  1. tony722

    Joined:
    Sep 23, 2010
    Messages:
    30
    Likes Received:
    0
    Note: Running Elastix 2.0.3., and I have licensed g729 codec from Digium. :) Using Polycom 601 phones that support g729 natively.


    My goal is the following:
    ulaw for extension->extension (works)
    ulaw for extension->voicemail (works)
    ulaw for extension -> PSTN FXO (works)
    ulaw for PSTN FXO -> extensions/voicemail/IVR (works)

    g729 for extension->SIP Trunk (transcodes :( )
    g729 for SIP Trunk->extensions/voicemail/IVR (works)

    So far everything is working, except outgoing calls from the extensions--they are showing being transcoded rather than going g729 end to end (pass-through). Right now in sip show channels they show up as ulaw at the extension and g729 on the trunk so they're being transcoded--which wastes my g729 licenses (and I can hear a difference...even in a blind test between g729->ulaw and g729->g729).

    How can I get outgoing calls on my SIP trunk to run native g729 from end to end while keeping ulaw for internal calls and calls oven the PSTN?
     
  2. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    If you carrier accepts g729 prefer that codec over others in your trunk peer config (allow=g729,ulaw,etc)

    If you want to restrict your trunks to only g729

    disallow=all
    allow=g729

    p.s.

    PSTN connections CANNOT use g729 they are restricted by their nature to g711
     
  3. tony722

    Joined:
    Sep 23, 2010
    Messages:
    30
    Likes Received:
    0
    That's set already.

    Sorry, I'd tried to be specific originally:

    This only affects outgoing calls. The phone is placing the call as ulaw, and Asterisk is transcoding it to g729 to go out over the trunk. I want to prevent that transcoding. (Incoming calls are not being transcoded--g729 all the way).

    Thanks!

    Tony
     
  4. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    It's a preferential ladder, prefer g729 in the endpoint, allow g711, prefer g711 in the extension, but allow allow g729, prefer g729 in the trunk but allow g711
     
  5. tony722

    Joined:
    Sep 23, 2010
    Messages:
    30
    Likes Received:
    0
    I'm not sure I understand how what you are saying can fix this for me. :p

    Phone has been set (in Polycom sip.cfg) to prefer g711 over g729. (Also as a test the reverse: prefer g729 over g711 with identical results).

    Trunk is set to ONLY allow g729.

    For some reason Asterisk always transcodes outgoing calls, rather than telling the phone to use native g729 for the call.

    If I force the phone to only allow g729, then of course the outgoing call via the SIP trunk goes g729. But even if I tell the phone in the Polycom sip.cfg to *prefer g729* over g711, the phone uses g711 anyway, and then Ansterisk transcodes it to g729.

    Any other settings I should be looking for?

    Thanks!

    Tony
     
  6. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    I can't/won't fix anything for you, that is your job.


    but perhaps a few hours at http://voip-info.org will help :)
     
  7. tony722

    Joined:
    Sep 23, 2010
    Messages:
    30
    Likes Received:
    0
    Aww... is that because you don't know, or won't tell? :eek:

    LOL--I've spent countless hours there already--great site! :) And on this topic I've already spent too many hours searching google, elastix.org, freepbx.org, etc. on this topic before posting. (Most of the time that does answer my questions!)

    But if a few words from someone to help steer me in the general direction that would be much appreciated. :)

    Why is it that a phone that prefers ulaw but allows g729 will force Asterisk to transcode the call, rather than using native g729 like it expressly allows? :dry:

    Thanks!

    Tony
     
  8. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    You are obviously right, I know nothing, please wait for someone else's answer.
     
  9. tony722

    Joined:
    Sep 23, 2010
    Messages:
    30
    Likes Received:
    0
    Please pardon me... I wasn't aware you knew everything! It was an honest question, not an implication of your ignorance. :eek:
     
  10. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    Then please attend to the answers from others.

    We are not a good fit.
     
  11. tony722

    Joined:
    Sep 23, 2010
    Messages:
    30
    Likes Received:
    0
  12. tony722

    Joined:
    Sep 23, 2010
    Messages:
    30
    Likes Received:
    0

Share This Page