Polycom IP330 Time and Date problem

Discussion in 'IP Phones' started by Joshoua, Sep 9, 2009.

  1. Joshoua

    Joined:
    Jul 14, 2009
    Messages:
    15
    Likes Received:
    0
    Hello everyone.
    I have recently purchased some Polycom IP330 phones and set up Elastix.
    Everything workd OK and Elastix is awesome.
    There is a problem though that is driving me nuts.
    For starters, please note that endpoint manager detects and configures the phones with no problem.
    The phones refuse to set their time and date correctly. The phone screen keeps flashing the wrong date which means it cannot contact the ntp server.
    I have tried all I could find online, I changed the settings in the sip.conf, in the server.conf, in the <macaddress>.conf, in the dhcpd.conf but I managed nothing.
    I haven't found much help elsewhere.
    Please if there is anyone that knows how to troubleshoot or fix this let me know.
    I am starting to get desperate...:blink:
     
  2. Joshoua

    Joined:
    Jul 14, 2009
    Messages:
    15
    Likes Received:
    0
    Well I managed to solve the problem..
    The setting is in DHCP configuration on the server.
    Fortunately it works now.
    Contact me if you have similar problems.
     
  3. snowmelt

    Joined:
    Dec 18, 2009
    Messages:
    2
    Likes Received:
    0
    Hey Joshua,

    What did you do to fix the time problem.

    I have a similar situation and the only fix I found was to manually assign IP addresses to each phone. (A real pain)

    Thanks

    Wayne Gordon
    snowmelt@yahoo.com
     
  4. dstrattn

    Joined:
    Jan 6, 2010
    Messages:
    1
    Likes Received:
    0
    Yes I am also having the same problem. Could you let me in on the solution too please.
     
  5. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    I find that

    option time-offset -28860; # Pacific Non-Standard time ;)
    option ntp-servers 192.168.1.8; # ntp server on your network


    in /etc/dhcpd.conf

    and

    restrict 192.168.1.0 mask 255.255.255.0 nomodify notrap

    in /etc/ntp.conf (if you use the elastix server as a ntpd server)


    works for me, obviously season to taste.
     

Share This Page