polycom IP 320 and two lines

Discussion in 'IP Phones' started by cmrahman, Jul 31, 2008.

  1. cmrahman

    Joined:
    Jul 21, 2008
    Messages:
    47
    Likes Received:
    0
    Anybody know how to configure from elastix so the phone automaticly gets two line (extention) active?
    Right now, the configuration only sets one line.

    Thanks
    CM
     
  2. bmacias

    Joined:
    Sep 27, 2007
    Messages:
    205
    Likes Received:
    0
    Hello, actually, elastix from endpoint configuration only can configure one line, in the future this action y other can be implements.

    Regards
    Elastix Team
     
  3. cmrahman

    Joined:
    Jul 21, 2008
    Messages:
    47
    Likes Received:
    0
    anybody know where I can find the script that I can modify to add the 2nd line for every phone?

    Thanks
     
  4. edk

    edk

    Joined:
    Sep 11, 2008
    Messages:
    6
    Likes Received:
    0

    /tftpboot/MAC_of_your_Polycom_reg.cfg
     
  5. cmrahman

    Joined:
    Jul 21, 2008
    Messages:
    47
    Likes Received:
    0
    I was asking about the endpoint detect module, where I can choose polycom 330. If I modify the script, I should be able to add the second extentions in it. Where do I find that?

    Thanks
     
  6. edk

    edk

    Joined:
    Sep 11, 2008
    Messages:
    6
    Likes Received:
    0
    /var/www/html/modules/endpoint_configuration/index.php - its standart for all kinds of phones u must change them for input one more line
    and
    change /var/www/html/modules/endpoint_configuration/libs/vendors/Polycom.cfg.php for output configure file.
     
  7. pucky900

    Joined:
    Feb 9, 2009
    Messages:
    51
    Likes Received:
    0
    I've been trying to get the 2 lines working on my 330s with no luck at all. Even with editing the MacAddress_reg.cfg file... still can't get it to work. Has anyone else gotten it to work? I have 2 lines working but calls will not kick over to line 2 if line 1 is busy. I'm afraid I have to back to Trixbox since I can't get it working correctly.
     
  8. Joshoua

    Joined:
    Jul 14, 2009
    Messages:
    15
    Likes Received:
    0
    Well I don't know if you corrected your problem but the solution is this.
    Assuming you are using the default configuration for your phones and didn't donwload the distribution files from Polycom.
    When you configure your phone through the endpoing manager, each phones creates two files.
    One is <mac_address>.cfg and the other is <mac_address>reg.cfg.
    The setting you want is inside the <macaddress>reg.cfg file. It is the reg.1.lineKeys setting.
    You should change that to read "2" instead of "1".
    Now restart your phone and you should have two lines.
    Now..you want to do that automatically.
    This takes a bit more effort.
    Log in to your elastix server (through winscp or putty whatever suites you). Navigate to /var/www/html/modules/endpoint_configuration/libs/vendors and open the Polycom.cfg.php file (remember to back it up before editing it).
    This is the default configuration file that Elastix uses to configure your Polycom phones.
    Find the line that says reg.1.linekeys =\"1\" and change it to 2.
    Save your file.
    Any new phone, will automatically take that setting when configured.
    The existing phones, you should delete all the configuration files inside tftpboot folder, unset your phones from elastix endpoint manager, reboot your phones, re-set the phones from elastix endpoint manager and then reboot your phones again so that they can take the new setting.
    I believe this should work, don't hesitate to contact me for any help.
    Regards.
     
  9. pucky900

    Joined:
    Feb 9, 2009
    Messages:
    51
    Likes Received:
    0
    Thank you so much for the update. I haven't had a chance to dig back into it again since I'm busy putting out other fires and my main Trixbox sys seems to be behaving lately. Once I get the time, will implement. Thanks!!!!
     
  10. hinzinho

    Joined:
    Sep 18, 2009
    Messages:
    461
    Likes Received:
    0
    This is how I got provisioning working on my Elastix:


    1) On the Polycom phone, make sure it's set to TFTP instead of FTP. I'm not sure if FTP was set as the default or I changed this during my initial setup. You can check by going to Menu > Settings > Advanced > Password is 456 > Admin Settings > Network Configuration > Server Menu > Server type, set it to Trivial FTP.

    2) On the domain controller > DHCP > Scope options. Configure option "066 Boot Server Host Name" to point to your Elastix server

    3) These two steps are optional. This is to enable all the lines on your phone with the same extension. Otherwise you'll only have 1 line on your phone.
    a) SSH into the Elastix server. Go to /var/www/html/modules/endpoint_configuration/libs/vendors. Edit the Polycom.cfg.php file and comment out the line "reg.1.lineKeys=\'1\'".
    b) Open a web interface of the polycom phone. Go to Lines > Under Num Line Keys, put 4 if you have IP 550 phones or 6 if you have IP 650 phones.

    4) SSH into Elastix and go to /tftpboot/. Edit the sip.cfg file and edit the digitmap dialplan. Also edit the server.cfg and adjust the GMT offset.

    5) On Elastix, go to the Endpoint Configuration > select the phone and set it to an extension. Reboot the phone.

    Also if you want your second line to ring, make sure to enabled 'Call Waiting' under your Extension.
     

Share This Page