Polycom bmp stopped working after firmware upgrade

Discussion in 'General' started by cassioac, Feb 3, 2010.

  1. cassioac

    Nov 14, 2009
    Likes Received:
    If you have upgraded your polycom firmware and your background logo have stopped working, just edit the sip.cfg on the tftpboot folder and change the following lines:

    <IDLE_DISPLAY ind.anim.IP_400.38.frame.1.bitmap="ip400" ind.anim.IP_400.38.frame.1.duration="0"/>

    <IDLE_DISPLAY ind.anim.IP_500.38.frame.1.bitmap="ip500" ind.anim.IP_500.38.frame.1.duration="0"/>
    <IDLE_DISPLAY_WIDE ind.anim.IP_500.39.frame.1.bitmap="ip500" ind.anim.IP_500.39.frame.1.duration="0"/>

    <IDLE_DISPLAY ind.anim.IP_600.38.frame.1.bitmap="ip600" ind.anim.IP_600.38.frame.1.duration="0"/>
    <IDLE_DISPLAY_WIDE ind.anim.IP_600.39.frame.1.bitmap="ip600" ind.anim.IP_600.39.frame.1.duration="0"/>

    <IDLE_DISPLAY ind.anim.IP_4000.38.frame.1.bitmap="ip4000" ind.anim.IP_4000.38.frame.1.duration="0"/>
    <IDLE_DISPLAY_WIDE ind.anim.IP_4000.39.frame.1.bitmap="ip4000" ind.anim.IP_4000.39.frame.1.duration="0"/>

    The trick is to remove the path polycom/bmp/ from the beginning of each quoted file name.
    Also make sure those files exists in /tftpboot/polycom/bmp/

    You may also want to change this information in /var/www/html/modules/endpoint_configuration/libs/vendors/Polycom.cfg.php so when you set the phones in the web gui "endpoint configuration" you don't loose those settings.

    I read a lot of threads on other forums about this subject but this is the easiest way to fix this.

    Best Regards,

    Cassio Simões

Share This Page