PHP 5.2.X on Elastix?

shibarr

Joined
Aug 9, 2010
Messages
1
Likes
0
Points
0
#1
It seems that a2billing versions greater than 1.3.4 requires php 5.2.X but Elastix comes with php version 5.1.X. I'm afraid of upgrading to php 5.2.X to install the latest a2billing since it might break something on the Elastix.

Has anybody have issues with Elastix with php 5.2.X?

Also, if we go the other way, has anybody have issues with the latest a2billing 1.7.1 with php 5.1.X?
 

johnme

Joined
Nov 28, 2008
Messages
148
Likes
0
Points
0
#2
Hi

It works fine for me for elastix 2. The reason was that i need to install latest sugar crm.
I didnt upgrade a2billing so i cant help on this, but i need some help on howto make billing work with dahdi channels (isdn).

So:

yum install yum-priorities
cd /etc/yum.repos.d/
wget http://dev.centos.org/centos/5/CentOS-Testing.repo
yum --enablerepo=c5-testing install php
/etc/init.d/httpd restart

after upgrade php and enable repo testing have to run:
pecl upgrade Fileinfo

and

yum upgrade php-mcrypt.i383

Thanks
John
 

RustBoy

Joined
Apr 13, 2011
Messages
97
Likes
0
Points
16
#3
I installed PHP 5.216 and I am having all sorts of permission problems. When can we expect to see a version of Elastix that officially supports PHP 5.2x? I am new to Elastix and since none of the downloads have release dates it's hard for me to have any idea how often it is updated.

Thanks.
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,900
Messages
130,884
Members
17,561
Latest member
marouen
Top