Phone still ringing after I hang up

Discussion in 'General' started by kalderista, Oct 22, 2008.

  1. kalderista

    Joined:
    Oct 21, 2008
    Messages:
    179
    Likes Received:
    0
    Hello,

    I've realized that when I phone outside (for example to a traditional phone number)and if I hang up because no one stablish the call, the phone in the other side is steel ringing during a cup of seconds (13 seconds more or less).

    Its a pity, because even I finish, the call could be stablished and billed without talk to anyone.

    Is it possible to configure this? What is the way?

    Thanx
     
  2. Buks

    Joined:
    Oct 15, 2008
    Messages:
    18
    Likes Received:
    0
    This sounds a lot like a zaptel hangup detection problem I am experiencing in one of my Elastix production machines. I decided to convert to Elastix from trixbox as Elastix is said to be the "Reliable PBX". I now am very doubtfull having lots of hangup detection problems as well as other zaptel / outbound call problems on machines that were perectly stable with trixbox...
     
  3. jgutierrez

    Joined:
    Feb 28, 2008
    Messages:
    5,737
    Likes Received:
    0
    kalderista/buks:

    which version of zaptel you guys are using?
    rpm -qa | grep zaptel
    which version of elastix are you using?

    on /etc/asterisk/zapata.conf
    have you tried to use busydetect, busycount, busypattern???
    If you haven't, try 'em, don't forget to reload asterisk
     
  4. Buks

    Joined:
    Oct 15, 2008
    Messages:
    18
    Likes Received:
    0
    I have all the busydetect etc settings in my zapata.conf.

    The problem I am experiencing on my own system is that I get a "all circuits are busy...." message when they are not busy. Unplugging the RJ11 connector from the TDM400 card and replugging immediately fixes this. Before you think is is being caused by lines not hanging up - I can receive incoming calls when this happens on the same lines.

    kernel-module-zaptel-xen-1.4.11-6_2.6.18_53.1.19.el5
    kernel-module-zaptel-1.4.11-6_2.6.18_53.1.19.el5
    zaptel-devel-1.4.11-6
    zaptel-1.4.11-6

    Elastix 1.3-2 (After yum update)
     
  5. tsopis

    Joined:
    Sep 2, 2008
    Messages:
    3
    Likes Received:
    0
    try to edit zapata.conf and uncomment the following lines at the bottom of your file:

    ;Uncomment these lines if you have problems with the disconection of your analog lines
    ;busydetect=yes
    ;busycount=3

    It should work. I have an Atcom TDM400p and i had similar problem.
     
  6. Buks

    Joined:
    Oct 15, 2008
    Messages:
    18
    Likes Received:
    0
    I have done that. I have many Asterisk installations and I am therefore well aware of those options.

    My problem is that I get the "All circuits are busy..." only on outbound calls (inbound still works) and when the lines are NOT busy. Unplugging and re-plugging the lines fixes this. If I don't unplug & replug the RJ45 connectors, I still receive incoming calls on all the lines.

    This happens once or maybe twice per day. It started after I did a yum update.

    I have had some suggestions that the problem is with current zaptel and even Asterisk versions. I am patiently waiting to try an update when newer zaptel versions are available. (I have upgraded to the current released version)
     
  7. jgutierrez

    Joined:
    Feb 28, 2008
    Messages:
    5,737
    Likes Received:
    0
    yep, I have heard the same, it is a zaptel related problem.

    In other posts, I have seen that other users have conpiled zaptel 1.4.12 from soucer, and it has solved their problems.
     
  8. Gwayne

    Joined:
    Jul 31, 2008
    Messages:
    19
    Likes Received:
    0
    I have seen it in Elastix 1.2-4. It seems to be fixed in 1,3
     
  9. kalderista

    Joined:
    Oct 21, 2008
    Messages:
    179
    Likes Received:
    0
    I have Elastix 1.3-2 and it happens as well. I don't think it's solved.

    :(
     
  10. Gwayne

    Joined:
    Jul 31, 2008
    Messages:
    19
    Likes Received:
    0
    Mmmmm, you did enable the

    ;Uncomment these lines if you have problems with the disconnection of your analog lines
    busydetect=yes
    busycount=3

    as tsopis allready said ?
     
  11. Buks

    Joined:
    Oct 15, 2008
    Messages:
    18
    Likes Received:
    0
    See my reply several post ago...

    My problem is an analog hangup detection problem. As stated above, I have / am using busydetect, busycount, busypattern with no success. This happens with TDM2400 as well as Xorcom hardware. Very frustrating..
     
  12. jgutierrez

    Joined:
    Feb 28, 2008
    Messages:
    5,737
    Likes Received:
    0
    What I would do is to record the busy pattern that my Elastix detects, and with a wave analyzer, get the amount of miliseconds that it takes for a tone and for a silence, then with that info, write down the exact vlues for the busypattern option on zapta.conf
     
  13. Bob

    Bob

    Joined:
    Nov 4, 2007
    Messages:
    2,400
    Likes Received:
    1
    Buks, unless you have seen it already, I came across this issue as well after a YUM update on the 1.4-1 Beta. Even though I was working on the 1.4-1 beta, the issue still applies to 1.3 versions as well.

    It is not an Elastix issue but a bug in Dahdi_chan.so (part of Asterisk).

    The workaround which works (confirmed by several sources, including non ELastix users) is to switch to FXSLS instead of FXSKS.

    You can have a further read here which goes a little more indepth.
    http://www.elastix.org/index.php?option ... 0&catid=29

    Hope this helps....

    Bob
     
  14. Buks

    Joined:
    Oct 15, 2008
    Messages:
    18
    Likes Received:
    0
    Thanks Bob. I have a TDM400 in my Elastix 1.3-2 server and I have followed the loopstart workaround. Now I am waiting to see if it works!!

    Thanks again.
     

Share This Page