pb with forwarding call

Discussion in 'General' started by bc@sipco.fr, Sep 22, 2008.

  1. bc@sipco.fr

    Joined:
    Sep 22, 2008
    Messages:
    1
    Likes Received:
    0
    hello

    i have a probleme with forwarding call. i have made a extension with folow me and when no answer, it is going thru misc destination. when i test, it is not working (say busy for congeston) and then we can not make call during 2 or 3 minutes.

    is anyone to have a idea ?

    here is the trace of the sequence:


    -- Executing [s@macro-dialout-trunk:11] Macro("SIP/10049-b7704660", "outbound-callerid|2") in new stack
    -- Executing [s@macro-outbound-callerid:1] ExecIf("SIP/10049-b7704660", "1|SetCallerPres|allowed_not_screened") in new stack
    -- Executing [s@macro-outbound-callerid:2] GotoIf("SIP/10049-b7704660", "1?start") in new stack
    -- Goto (macro-outbound-callerid,s,4)
    -- Executing [s@macro-outbound-callerid:4] NoOp("SIP/10049-b7704660", "REALCALLERIDNUM is 00979944029") in new stack
    -- Executing [s@macro-outbound-callerid:5] GotoIf("SIP/10049-b7704660", "0?normcid") in new stack
    -- Executing [s@macro-outbound-callerid:6] GotoIf("SIP/10049-b7704660", "0?normcid") in new stack
    -- Executing [s@macro-outbound-callerid:7] GotoIf("SIP/10049-b7704660", "0?normcid") in new stack
    -- Executing [s@macro-outbound-callerid:8] Set("SIP/10049-b7704660", "USEROUTCID=00979944029") in new stack
    -- Executing [s@macro-outbound-callerid:9] GotoIf("SIP/10049-b7704660", "1?bypass:normcid") in new stack
    -- Goto (macro-outbound-callerid,s,11)
    -- Executing [s@macro-outbound-callerid:11] Set("SIP/10049-b7704660", "EMERGENCYCID=") in new stack
    -- Executing [s@macro-outbound-callerid:12] Set("SIP/10049-b7704660", "TRUNKOUTCID=") in new stack
    -- Executing [s@macro-outbound-callerid:13] GotoIf("SIP/10049-b7704660", "1?trunkcid") in new stack
    -- Goto (macro-outbound-callerid,s,17)
    -- Executing [s@macro-outbound-callerid:17] GotoIf("SIP/10049-b7704660", "1?usercid") in new stack
    -- Goto (macro-outbound-callerid,s,19)
    -- Executing [s@macro-outbound-callerid:19] GotoIf("SIP/10049-b7704660", "0?report") in new stack
    -- Executing [s@macro-outbound-callerid:20] Set("SIP/10049-b7704660", "CALLERID(all)=00979944029") in new stack
    -- Executing [s@macro-outbound-callerid:21] GotoIf("SIP/10049-b7704660", "1?report:hidecid") in new stack
    -- Goto (macro-outbound-callerid,s,23)
    -- Executing [s@macro-outbound-callerid:23] NoOp("SIP/10049-b7704660", "CallerID set to "" <00979944029>") in new stack
    -- Executing [s@macro-dialout-trunk:12] AGI("SIP/10049-b7704660", "fixlocalprefix") in new stack
    -- Launched AGI Script /var/lib/asterisk/agi-bin/fixlocalprefix
    -- AGI Script fixlocalprefix completed, returning 0
    -- Executing [s@macro-dialout-trunk:13] Set("SIP/10049-b7704660", "OUTNUM=0630183916") in new stack
    -- Executing [s@macro-dialout-trunk:14] Set("SIP/10049-b7704660", "custom=SIP/openip") in new stack
    -- Executing [s@macro-dialout-trunk:15] GotoIf("SIP/10049-b7704660", "1?gocall") in new stack
    -- Goto (macro-dialout-trunk,s,17)
    -- Executing [s@macro-dialout-trunk:17] Macro("SIP/10049-b7704660", "dialout-trunk-predial-hook|") in new stack
    -- Executing [s@macro-dialout-trunk:18] GotoIf("SIP/10049-b7704660", "0?bypass|1") in new stack
    -- Executing [s@macro-dialout-trunk:19] GotoIf("SIP/10049-b7704660", "0?customtrunk") in new stack
    -- Executing [s@macro-dialout-trunk:20] Dial("SIP/10049-b7704660", "SIP/openip/0630183916|300|") in new stack
    -- Called openip/0630183916
    -- SIP/openip-093c67d8 is circuit-busy
    == Everyone is busy/congested at this time (1:0/1/0)
    -- Executing [s@macro-dialout-trunk:21] Goto("SIP/10049-b7704660", "s-CONGESTION|1") in new stack
    -- Goto (macro-dialout-trunk,s-CONGESTION,1)
    -- Executing [s-CONGESTION@macro-dialout-trunk:1] GotoIf("SIP/10049-b7704660", "1?noreport") in new stack
    -- Goto (macro-dialout-trunk,s-CONGESTION,3)
    -- Executing [s-CONGESTION@macro-dialout-trunk:3] NoOp("SIP/10049-b7704660", "TRUNK Dial failed due to CONGESTION - failing through to other trunks") in new stack
    -- Executing [00630183916@from-internal:5] Macro("SIP/10049-b7704660", "outisbusy|") in new stack
    -- Executing [s@macro-outisbusy:1] Playback("SIP/10049-b7704660", "all-circuits-busy-now|noanswer") in new stack
    -- <SIP/10049-b7704660> Playing 'all-circuits-busy-now' (language 'fr')
    == Parsing '/etc/asterisk/manager.conf': Found
    == Parsing '/etc/asterisk/manager_additional.conf': Found
    == Parsing '/etc/asterisk/manager_custom.conf': Found
    == Manager 'admin' logged on from 127.0.0.1
    -- Executing [s@macro-outisbusy:2] Playback("SIP/10049-b7704660", "pls-try-call-later|noanswer") in new stack
    -- <SIP/10049-b7704660> Playing 'pls-try-call-later' (language 'fr')

     
  2. Chilling_Silence

    Joined:
    Sep 23, 2008
    Messages:
    488
    Likes Received:
    0
    What number have you put in the FollowMe box? Did you include the #?
    What does your dial-plan look like?
     
  3. jgutierrez

    Joined:
    Feb 28, 2008
    Messages:
    5,737
    Likes Received:
    0
    yep, that is right, did you add the # after 0630183916
    is 0630183916 included with your outbound route?

    Another tip, there are some voip providers, that blocks outgoing calls if the CID is different from the one that they have assigned you.

    Because you are using a follow me setting, the CID that is sent through your provider will be the one that called to the extension that has the follow me setting

    For example if A calls B, and B dosn't answer, it will try to dial C (follow me setting of B), so your asterisk box will try to dial C with the CID of A instead with the CID that your provider assigned you.

    Within your trunk configuration check "Never Override CallerID", of course, you will need to setup correctly your "Outbound CallerID"
     

Share This Page