Password for connecting to hylafax

Discussion in 'General' started by Holg, Jun 27, 2007.

  1. Holg

    Joined:
    Jun 26, 2007
    Messages:
    10
    Likes Received:
    0
    When I try to connect my Windowsclient to the Hylafax Server of elastix it asks me for a password?

    Can anyone tell me what the password is, or how I can set it?

    thanks & regards
    Holger
     
  2. jr_oblika

    Joined:
    Mar 16, 2007
    Messages:
    67
    Likes Received:
    0
    username is root with NO password

    You must edit
    /var/spool/hylafax/etc/hosts.hfaxd

    add
    .*@192\.168\.11\.*
     
  3. eboza

    Joined:
    Mar 27, 2007
    Messages:
    45
    Likes Received:
    0
    In Elastix 0.8-4 you will be able to add this from Elastix web interface.

    - Edwin
     
  4. Holg

    Joined:
    Jun 26, 2007
    Messages:
    10
    Likes Received:
    0
    Thanks,

    somehow hylafax doesn't send the fax... Is there anything else I have to look for?

    Or is it the windows client - can you recommend annother client for windows which I can use as a printer?

    regards
    Holger
     
  5. jr_oblika

    Joined:
    Mar 16, 2007
    Messages:
    67
    Likes Received:
    0
    Yes, on the net you find many client for HylaFax !

    Please explain a litle more your configuration and setings.<br><br>Post edited by: jr_oblika, at: 2007/06/27 11:31
     
  6. ramoncio

    Joined:
    May 12, 2010
    Messages:
    1,663
    Likes Received:
    0
    I have 0.8.4-beta2 installed and this does not work for me.
    In 0.8.4-beta2 you have a new tab in Faxes called Fax Clients, where you add users and modify /var/spool/hylafax/etc/hosts.hfaxd
    When I try to add
    .*@192.168.111.*
    or
    *@192.168.111.*
    I get an error: Incorrect Format

    I have tried with JHylaFAX, but user root with no password doesn't work, and keeps asking me for a password.
    In my production system I have Elastix 0.8.3 and JHylaFAX works fine. I have created some users with "faxadduser -a admin -p password -u 100 faxuser" and it works, but here in 0.8.4-beta2 it does not work either.
    Can someone help?
    Other question: which permissions and owner should have /var/spool/hylafax??
    Thank you!
     
  7. jr_oblika

    Joined:
    Mar 16, 2007
    Messages:
    67
    Likes Received:
    0
    sory -- file : /var/spool/hylafax/etc/hosts.hfaxd

    127.0.0.1
    .*@192\.168\.111\.*


    localhost
    ^root@


    I foud mistake !!! Look a file !!!<br><br>Post edited by: jr_oblika, at: 2007/06/28 14:29
     
  8. jr_oblika

    Joined:
    Mar 16, 2007
    Messages:
    67
    Likes Received:
    0
  9. Holg

    Joined:
    Jun 26, 2007
    Messages:
    10
    Likes Received:
    0
    hm... the settings should be standard. I just added the .*@192.168.115.* line in /var/spool/hylafax/etc/hosts.hfaxd

    I've setup an iax2 extension for recieving fax but the rest should be as it was after installation...

    Like I said I'm connected to the hylafax server - so no more password authorisation - but when I send the fax nothing happens on the cli of asterisk and the fax is not sent... any ideas? What config files could I post?

    [edit]
    now I found an error message:

    /usr/bin/gs: error while loading shared libraries: libcupsimage.so.2: cannot open shared object file: No such file or directory

    [edit 2]
    I installed cups-libs and am hopping that this will solve the problem...


    can anyone provide me the name of the rmp which is missing - shouldn't it be already installed??
    regards Holger<br><br>Post edited by: Holg, at: 2007/06/29 19:41
     
  10. Holg

    Joined:
    Jun 26, 2007
    Messages:
    10
    Likes Received:
    0
    ok step by step...

    now I get an error message through mail:

    seems as if a font is nor installed?

    regards Holger
     
  11. Holg

    Joined:
    Jun 26, 2007
    Messages:
    10
    Likes Received:
    0
    by using another printer driver (HP Laserjet 4050) I could solve the font problem and asterisk is now calling through the iax2 extension.... but the call get's canceled...

    Code:
        -- mISDN/1-u226 is ringing
        -- mISDN/1-u226 answered IAX2/42-2
      == Spawn extension (macro-dialout-trunk, s, 27) exited non-zero on 'IAX2/42-2' in macro 'dialout-trunk'
      == Spawn extension (macro-dialout-trunk, s, 27) exited non-zero on 'IAX2/42-2'
        -- Executing [h@macro-dialout-trunk:1] Macro("IAX2/42-2", "hangupcall"«») in new stack
        -- Executing [s@macro-hangupcall:1] ResetCDR("IAX2/42-2", "w"«») in new stack
        -- Executing [s@macro-hangupcall:2] NoCDR("IAX2/42-2", ""«») in new stack
        -- Executing [s@macro-hangupcall:3] GotoIf("IAX2/42-2", "1?skiprg"«») in new stack
        -- Goto (macro-hangupcall,s,6)
        -- Executing [s@macro-hangupcall:6] GotoIf("IAX2/42-2", "1?theend"«») in new stack
        -- Goto (macro-hangupcall,s,9)
        -- Executing [s@macro-hangupcall:9] Wait("IAX2/42-2", "5"«») in new stack
      == Spawn extension (macro-hangupcall, s, 9) exited non-zero on 'IAX2/42-2' in macro 'hangupcall'
      == Spawn extension (macro-hangupcall, s, 9) exited non-zero on 'IAX2/42-2'
        -- Hungup 'IAX2/42-2'
    
    and I get this via mail:

    Code:
    Jun 30 09:44:18.74: [29715]: SESSION BEGIN 000000044 59304031013332
    Jun 30 09:44:18.74: [29715]: HylaFAX (tm) Version 4.3.3
    Jun 30 09:44:18.74: [29715]: SEND FAX: JOB 16 DEST 031013332 COMMID 000000044 DEVICE '/dev/ttyIAX1' FROM 'root <XX@domain.com>' USER root
    Jun 30 09:44:18.74: [29715]: STATE CHANGE: RUNNING -> SENDING
    Jun 30 09:44:18.75: [29715]: <-- [12:AT+FCLASS=1\r]
    Jun 30 09:44:18.75: [29715]: --> [2]
    Jun 30 09:44:18.75: [29715]: MODEM set XON/XOFF/FLUSH: input ignored, output disabled
    Jun 30 09:44:18.76: [29715]: DIAL 031013332
    Jun 30 09:44:18.76: [29715]: <-- [14:ATDT031013332\r]
    Jun 30 09:44:24.99: [29715]: --> [7]
    Jun 30 09:44:26.83: [29715]: --> HDLC<34:FF C0 04 B5 00 AA 12 9E 36 86 62 82 1A 04 14 2E B6 94 04 6A A6 4E CE 96 F6 76 04 2C 74 CC 74 CC DA 7F>
    Jun 30 09:44:26.83: [29715]: --> [2]
    Jun 30 09:44:26.83: [29715]: REMOTE NSF "AD 00 55 48 79 6C 61 46 41 58 20 28 74 6D 29 20 56 65 72 73 69 6F 6E 20 34 2E 33 2E 33"
    Jun 30 09:44:26.83: [29715]: NSF remote fax equipment: HylaFAX 
    Jun 30 09:44:26.83: [29715]: NSF remote station ID: "HylaFAX (tm) Version 4.3.3"
    Jun 30 09:44:26.83: [29715]: <-- [9:AT+FRH=3\r]
    Jun 30 09:44:26.85: [29715]: --> [7]
    Jun 30 09:44:27.65: [29715]: --> HDLC<25:FF C0 02 04 04 04 04 04 04 04 04 04 04 04 04 04 04 04 04 04 04 04 04 A4 F3>
    Jun 30 09:44:27.65: [29715]: --> [2]
    Jun 30 09:44:27.65: [29715]: REMOTE CSI ""
    Jun 30 09:44:27.65: [29715]: <-- [9:AT+FRH=3\r]
    Jun 30 09:44:27.69: [29715]: --> [7]
    Jun 30 09:44:28.23: [29715]: --> HDLC<15:FF C8 01 00 73 5F 23 01 FB C1 01 01 18 90 61>
    Jun 30 09:44:28.29: [29715]: --> [2]
    Jun 30 09:44:28.29: [29715]: REMOTE best rate 9600 bit/s
    Jun 30 09:44:28.29: [29715]: REMOTE max A3 page width (303 mm)
    Jun 30 09:44:28.29: [29715]: REMOTE max unlimited page length
    Jun 30 09:44:28.29: [29715]: REMOTE best vres R16 x 15.4 line/mm
    Jun 30 09:44:28.29: [29715]: REMOTE format support: MH, MR, MMR
    Jun 30 09:44:28.29: [29715]: REMOTE supports T.30 Annex A, 256-byte ECM
    Jun 30 09:44:28.29: [29715]: REMOTE best 0 ms/scanline
    Jun 30 09:44:28.29: [29715]: USE 9600 bit/s
    Jun 30 09:44:28.29: [29715]: USE error correction mode
    Jun 30 09:44:28.29: [29715]: <-- [9:AT+FTH=3\r]
    Jun 30 09:44:28.31: [29715]: --> [7]
    Jun 30 09:44:28.31: [29715]: <-- HDLC<3:FF C8 DF>
    Jun 30 09:44:29.49: [29715]: --> [2]
    Jun 30 09:44:29.49: [29715]: MODEM input buffering enabled
    Jun 30 09:44:29.49: [29715]: <-- [5:ATH0\r]
    Jun 30 09:44:29.59: [29715]: --> [2]
    Jun 30 09:44:29.59: [29715]: MODEM set DTR OFF
    Jun 30 09:44:29.59: [29715]: MODEM set baud rate: 0 baud (flow control unchanged)
    Jun 30 09:44:29.59: [29715]: STATE CHANGE: SENDING -> MODEMWAIT (timeout 5)
    Jun 30 09:44:29.59: [29715]: SESSION END
    
    
    the other fax is also an iax2 elastix fax..

    [edit]

    with a regular analog fax I get almost the same error log:

    Code:
    Jun 30 09:54:22.06: [29879]: SESSION BEGIN 000000045 59304031013633
    Jun 30 09:54:22.06: [29879]: HylaFAX (tm) Version 4.3.3
    Jun 30 09:54:22.06: [29879]: SEND FAX: JOB 17 DEST 031013633 COMMID 000000045 DEVICE '/dev/ttyIAX1' FROM 'root <xxx>' USER root
    Jun 30 09:54:22.06: [29879]: STATE CHANGE: RUNNING -> SENDING
    Jun 30 09:54:22.06: [29879]: <-- [12:AT+FCLASS=1\r]
    Jun 30 09:54:22.06: [29879]: --> [2]
    Jun 30 09:54:22.06: [29879]: MODEM set XON/XOFF/FLUSH: input ignored, output disabled
    Jun 30 09:54:22.06: [29879]: DIAL 031013633
    Jun 30 09:54:22.06: [29879]: <-- [14:ATDT031013633\r]
    Jun 30 09:54:58.16: [29879]: --> [7]
    Jun 30 09:55:00.26: [29879]: --> HDLC<45:FF C0 04 00 00 98 24 03 05 FB A5 BF 1B F7 03 0D 05 7D 20 80 E0 E0 C0 B0 80 80 10 F0 0F 40 A0 40 98 00 60 80 20 E0 80 80 90 80 E0 07 F8>
    Jun 30 09:55:00.26: [29879]: --> [2]
    Jun 30 09:55:00.26: [29879]: REMOTE NSF "00 00 19 24 C0 A0 DF A5 FD D8 EF C0 B0 A0 BE 04 01 07 07 03 0D 01 01 08 0F F0 02 05 02 19 00 06 01 04 07 01 01 09 01 07"
    Jun 30 09:55:00.26: [29879]: NSF remote fax equipment: Xerox 
    Jun 30 09:55:00.26: [29879]: <-- [9:AT+FRH=3\r]
    Jun 30 09:55:00.97: [29879]: --> [7]
    Jun 30 09:55:00.97: [29879]: --> HDLC<25:FF C0 02 04 04 04 04 04 04 04 04 04 04 04 04 04 04 04 04 04 04 04 04 A4 F3>
    Jun 30 09:55:00.97: [29879]: --> [2]
    Jun 30 09:55:00.97: [29879]: REMOTE CSI ""
    Jun 30 09:55:00.97: [29879]: <-- [9:AT+FRH=3\r]
    Jun 30 09:55:01.53: [29879]: --> [7]
    Jun 30 09:55:01.53: [29879]: --> HDLC<19:FF C8 01 04 F7 1F 23 01 FB C1 01 01 05 01 01 01 80 47 0E>
    Jun 30 09:55:01.60: [29879]: --> [2]
    Jun 30 09:55:01.60: [29879]: REMOTE best rate 33600 bit/s
    Jun 30 09:55:01.60: [29879]: REMOTE max A4 page width (215 mm)
    Jun 30 09:55:01.60: [29879]: REMOTE max unlimited page length
    Jun 30 09:55:01.60: [29879]: REMOTE best vres R16 x 15.4 line/mm
    Jun 30 09:55:01.60: [29879]: REMOTE format support: MH, MR, MMR, JBIG
    Jun 30 09:55:01.60: [29879]: REMOTE supports T.30 Annex A, 256-byte ECM
    Jun 30 09:55:01.60: [29879]: REMOTE best 0 ms/scanline
    Jun 30 09:55:01.61: [29879]: USE 14400 bit/s
    Jun 30 09:55:01.61: [29879]: USE error correction mode
    Jun 30 09:55:01.61: [29879]: <-- [9:AT+FTH=3\r]
    Jun 30 09:55:01.61: [29879]: --> [7]
    Jun 30 09:55:01.61: [29879]: <-- HDLC<3:FF C8 DF>
    Jun 30 09:55:02.78: [29879]: --> [2]
    Jun 30 09:55:02.78: [29879]: MODEM input buffering enabled
    Jun 30 09:55:02.78: [29879]: <-- [5:ATH0\r]
    Jun 30 09:55:02.88: [29879]: --> [2]
    Jun 30 09:55:02.88: [29879]: MODEM set DTR OFF
    Jun 30 09:55:02.88: [29879]: MODEM set baud rate: 0 baud (flow control unchanged)
    Jun 30 09:55:02.88: [29879]: STATE CHANGE: SENDING -> MODEMWAIT (timeout 5)
    Jun 30 09:55:02.88: [29879]: SESSION END
    
    <br><br>Post edited by: Holg, at: 2007/06/30 10:10
     
  12. cashoefman

    Joined:
    Jul 8, 2007
    Messages:
    4
    Likes Received:
    0
    Did you get this resolved? I am having the same issue and have not found a solution yet!

    Let me know...

    Thanks

    Got it working. This issue seems to happen when you use the HP laserprinter PS driver, it doesn't create the PS file correctly. Hylafax doesn't realize it and set's up a fax connection, when the time comes to actually transmit the file it fails and the connection ends "normally"

    To solve it I did this:

    yum install urw-fonts ( to install missing font files, not sure if it needed)
    in winprinthylafax I used the Apple 16/600 PS

    after that it worked like a charm!<br><br>Post edited by: cashoefman, at: 2007/07/09 06:58
     
  13. lek

    lek Guest

    Thanks cashoefman,

    The urw-fonts package will be included in the next Elastix version (0.8.5).
     
  14. tensk8

    Joined:
    Aug 8, 2007
    Messages:
    20
    Likes Received:
    0
    Hi Holg.

    I'm using Gfax to try to connect to Hylafax, but when I open such application ask me for a password.
    How do you resolve this issue?

    Thanks:dry:
     
  15. Holg

    Joined:
    Jun 26, 2007
    Messages:
    10
    Likes Received:
    0
    Hi
    actually the only thing you need to to is to add your hosts in /var/spool/hylafax/etc/hosts.hfaxd

    That worked at least for me.
    As login for your fax application you can use root without password.

    regards
    Holger
     

Share This Page