Pager Email Address

Discussion in 'General' started by Telco, Jan 24, 2008.

  1. Telco

    Joined:
    Oct 4, 2007
    Messages:
    275
    Likes Received:
    0
    Any one know how to change the from address on notifications from the system.

    When you get a notification on your cell that there is a message in your vm. It comes from asterisk@com.com. This poses a problem when you have mailboxes on multiple systems. You don't know which system notified you. Anyone know how to change that?
     
  2. styelz

    Joined:
    Sep 11, 2007
    Messages:
    17
    Likes Received:
    0
    Check your settings here:
    https://your-asterisk-box.com/?menu=network

    Make sure your "Host" is set to the domain name you want. You may need to restart the mail server after changing, although I am not sure.

    ------------

    You can also force this value for each extension.
    by adding serveremail=somename@somehost.com in each extensions VM Options box.


    Good Luck.<br><br>Post edited by: styelz, at: 2008/01/24 11:35
     
  3. Telco

    Joined:
    Oct 4, 2007
    Messages:
    275
    Likes Received:
    0
    Nope neither of those options worked. What you are referring to is the reply message from the email that is sent to your email address.( that I have changed ) What I am asking the the text message that is sent to your cell phone telling you that you have a message.

    It always comes from asterisk.com.com

    EDIT

    I should have typed asterisk@com.com<br><br>Post edited by: Telco, at: 2008/01/25 03:37
     
  4. Telco

    Joined:
    Oct 4, 2007
    Messages:
    275
    Likes Received:
    0
    OK some what resolved>>>>>

    In the older version of elastix (0.9.1) under /etc/ there is a mail folder for sendmail however in the latest version 0.9.2 there sendmail is not activated or not installed because there is no mail folder there.

    In 0.9.1 I was able to change the from addy from asterisk@com.com by editing the sendmail.cf file and enable the "my official domain" option. Then I would get an txt message from asterisk@(whatever domain I put in).

    However in 0.9.2 that is not an option so I have not figured it out in 0.9.2 yet. I still get txt messages from asterisk@com.com.
     
  5. Bob

    Bob

    Joined:
    Nov 4, 2007
    Messages:
    2,400
    Likes Received:
    1
    Telco,

    The Email address you refer to is found at

    /etc/asterisk/vm_general.inc

    The lines you are after are

    serveremail=vm@elastix.yourdomain.com
    fromstring=Voicemail System ; Real name of email sender

    The text of the message can be found at

    /etc/asterisk/vm_email.inc

    Just be careful with using "nano" editor with this file as it has long lines in it. VI is a better option or make a backup file, in case it blows up.

    Hope it helps

    Regards

    Bob<br><br>Post edited by: Bob, at: 2008/01/26 15:35
     
  6. Usuarioforum

    Joined:
    Nov 15, 2007
    Messages:
    93
    Likes Received:
    0
    If you refer to de system mails, no voicemail, you must to change last lines in
    /etc/postfix/main.cf

    mydomain = yourdomain.com
    myhostname = pbx.yourdomain.com

    Elastix don't user sendmail.
     
  7. Telco

    Joined:
    Oct 4, 2007
    Messages:
    275
    Likes Received:
    0
    Thanks for the responses.

    Bob, that just changes the email reply-to addy. NOT the pager reply-to addy.

    Usuarioforum, Thanks I will try that.
     
  8. Telco

    Joined:
    Oct 4, 2007
    Messages:
    275
    Likes Received:
    0
    That did it Thank you!!!
     
  9. styelz

    Joined:
    Sep 11, 2007
    Messages:
    17
    Likes Received:
    0

Share This Page