Outgoing fax problem IAX2 jitter - last_ts:

Discussion in 'General' started by marlo, Dec 11, 2009.

  1. marlo

    Joined:
    Apr 2, 2008
    Messages:
    9
    Likes Received:
    0
    Hi. I have a big problem with Elastix in Version 1.6-12 and 1.5.2-2.3 with outgoing IAX2 / Hylafax fax with fax over pc (YajHFC fax client). I have installed Elastix on two machines with 2 HFC-S ISDN / mISDN Cards. 1 Machine in PTP and 1 Machine in PTMP. All functions are functional (in and outgoing phonecalls are stable). Our old Elastix machine version 1.1-2 are running about 2 years and there no problems with outgoing fax. When i send a fax the log in "/var/log/iaxmodem/iaxmodem-cfg.ttyIAX1" running out with:
    ----------------------
    [2009-12-11 21:40:31] IAX2 jitter - last_ts: 115830, ts: 115846
    [2009-12-11 21:40:31] IAX2 jitter - last_ts: 115846, ts: 115862
    [2009-12-11 21:40:31] IAX2 jitter - last_ts: 115862, ts: 115878
    [2009-12-11 21:40:31] IAX2 jitter - last_ts: 115878, ts: 115894
    [2009-12-11 21:40:31] IAX2 jitter - last_ts: 115894, ts: 115910
    [2009-12-11 21:40:31] IAX2 jitter - last_ts: 115910, ts: 115926
    [2009-12-11 21:40:31] IAX2 jitter - last_ts: 115926, ts: 115942
    [2009-12-11 21:40:31] IAX2 jitter - last_ts: 115942, ts: 115958
    [2009-12-11 21:40:31] IAX2 jitter - last_ts: 115958, ts: 115974
    [2009-12-11 21:40:31] IAX2 jitter - last_ts: 115974, ts: 115990
    [2009-12-11 21:40:31] IAX2 jitter - last_ts: 115990, ts: 116006
    [2009-12-11 21:40:31] IAX2 jitter - last_ts: 116006, ts: 116022
    ----------------------
    I send a DIN A4 Fax, the remote fax decreases - Send fax terminates after the half - and in the Elastix webinterface "Fax => Fax Visor" the fax is marked as sent.

    Please help me - Many greetings from Germany
     
  2. marlo

    Joined:
    Apr 2, 2008
    Messages:
    9
    Likes Received:
    0
    Hi, I have the version 1.3-stable 29sep2008.iso reinstalled. incoming and outgoing faxes work. Now a yum-update to version 1.5.2-2 => incoming and outgoing faxes are working. Once again yum-update to version 1.5.2-2.3 => problem with IAX2 jitter as described. Apparently, only I have the problem that in version 1.5.2-2.3 no outbound faxes work? Many greetings from Germany.
     
  3. markb1439

    Joined:
    Dec 11, 2009
    Messages:
    4
    Likes Received:
    0
    Hi,

    I am unable to get outgoing faxes (IAX2) to work at all. There is always a "Busy Signal" error (even though the receiving fax is not busy) or a "No Carrier" error. Would you be kind enough to describe the settings you used to get outgoing fax to work at all (even with the jitter issue)? I have set up an IAX fax extension, set up the virtual fax, installed AvantFax, etc. Incoming works, but outgoing refuses to work.

    What part of Germany are you in? I used to visit Aachen often on business. I love Germany.

    Mark
     
  4. marlo

    Joined:
    Apr 2, 2008
    Messages:
    9
    Likes Received:
    0
    Hi mark, whitch version of Elastix do you have? - Step 1: In Elastix go to the Extensions => Select IAX2 extension and attach to it. Put-in extension number, extension name, extension-Secret, and click Save. In Elastix go to fax => New viertual fax and fill out the fields => important extension IAX => "The extension number that was previously created" secret Extension-Secret => 'The extension that was previously created. then click on save. Click again to fax. The status must be by fax => "Running and idle on ttyIAX1." I think you should create a second faxextension and then test the internal fax, for example: you have faxextension 300 and 301 then send a fax from 300 to 301, it works now, then test an external fax and watch the asterisk CLI. (asterisk -vvvvvvvvvvvvvc) is the right outgoing trunk selected, send a fax to your phone - you hear the fax tones? I hope you have success. I live in stuttgart. have you ever eaten sauerkraut? ;-)
     
  5. mjschmidt

    Joined:
    Jan 4, 2010
    Messages:
    1
    Likes Received:
    0
    Hi
    I found Your posts because I have the same problem.
    Lee Howard ( from IAXmodem) wrote me today, I think that's interesting to You also:
    #####
    There have been only a very, very few number of people who have reported
    fax success with mISDN. If you can find them in the mail archives then
    I suggest you contact them to discover what version of mISDN and what
    version of Asterisk they are using... then maybe try to use those versions.

    I would also contact the mISDN developers to see what help you can get
    from them.

    Lastly, I would consider using a different connectivity to the Alcatel
    PBX that is not BRI. Can you use PRI? (Yes, this would require a
    different hardware, I think.)
    #####
    S...
     
  6. maikcat

    Joined:
    Apr 24, 2009
    Messages:
    38
    Likes Received:
    0
    i am digging old thread up but....

    one customer of ours has elastix 1.6 with misdn and he
    decided to use the fax service and ,well, he cant send
    complete fax....

    in iax logs i get alot of

    IAX2 jitter - last_ts: 8944, ts: 8960

    errors...

    also read that i must disable for IAX jitter buffer,
    i upgraded freepbx from ver 2.5 to 2.6 and disabled under IAX settings
    the jitter buffer but still no luck..

    any known workarounds on that? or i will have to upgrade his installation?

    Thanks in advance

    Michael.
     

Share This Page