outgoing DTMF problems

Joined
Jun 30, 2007
Messages
30
Points
0
I have ht-486, PAP2 and x-lite connected to elastix 1.3 (upgraded last night from 1.1-6 for this problem but still no result, it got worse). I have two Dahdi (formerly known as prince opps zap ;-) lines on x100p and multiple outgoing SIP trunks. I have only ulaw and alaw codecs enabled. SIP trunks are exclusively used for outgoing calls. Dahdi is for incoming. All the incoming/outgoing calls, faxes are fine but when I call a number that has IVR and press buttons on my phone, the recipient IVR gets multiple instances of same number. I press 2 they get 2 2 or even 2 2 2. This also happens on outgoing Dahdi! line. I have tried peer setting dtmfmode= to inband, sip info, rfc2833 and auto individually and in combination. I have also tested individual trunks. All fail in same manner. I tried xten connected directly to SIP prover and that seems to work fine. I have also made changes to ht-486 and extension in freepbx to match above setting everytime but that did not help either.

1.1-6 was little better as one sip trunk would work most of times but now dahdi or sip nothing works.

Any suggestions?
 
Joined
Jun 30, 2007
Messages
30
Points
0
I forgot to mention that I have also tried relaxdtmf=yes and rfc2833compensate=yes without any success.

What do these parameters do?
 
Joined
Jun 30, 2007
Messages
30
Points
0
I appreciate your offer to access my server but due to sensitive data on the network, the management does not allow anybody from outside coming in to network.

Any other suggestions?
 
Joined
Feb 28, 2008
Messages
5,737
Points
0
the first thing that I would double check is that I'm using the appropiate dtmf setting, I would contact my provider and ask for that info, then I would set the same dtmf setting into my trunk and into my ATA
 
Joined
Jun 30, 2007
Messages
30
Points
0
I am in contact with the provider. As per their suggestion I tried x-lite softphone directly with the provider and do not see this problem. It only occurs when I am using elastix.
 
Joined
Feb 28, 2008
Messages
5,737
Points
0
have you tried seting up the dtmfmode option within your trunk definition? also include it within your sip configuration file.

for example:
dtmfmode=rfc2833
 
Joined
Oct 30, 2008
Messages
56
Points
0
I had some problems with DTMF, too. Mine consisted of those multiple tones when, for example, activating call recording.

I have tried multiple (if not all) settings of dtmfmode, the only one working correctly for me *with SNOM phones), is "inband".
 

Members online

No members online now.

Forum statistics

Threads
30,992
Messages
131,106
Members
17,716
Latest member
Orbit114
Top