Outgoing Calls - No Sound

Discussion in 'General' started by newboy, Nov 24, 2010.

  1. newboy

    Joined:
    Mar 11, 2009
    Messages:
    60
    Likes Received:
    0
    I am using elastix 2.0.3 and FreePBX 2.8.0.4

    I can make calls into my PBX but i cannot get any sound on the outbound calls. The incoming call goes on IVR and i can hear it but the outgoing call is total silence.

    it rings on the other side and i can hear ringing on call as well but after that it is silent.

    Here are the trunk details:

    PEER Details:
    disallow=all
    allow=alaw&ulaw&gsm&g729
    host=sip.pennytel.com
    port=5060
    username=
    fromuser=
    fromusername=
    fromdomain=sip.pennytel.com
    secret=
    canreinvite=no
    dtmfmode=rfc2833
    type=peer
    defaultexpirey=300
    insecure=very
    qualify=yes


    USER Details:
    type=user
    host=sip.pennytel.com
    username=
    fromdomain=sip.pennytel.com
    fromusername=
    secret=
    context=from-trunk

    I have tried to play around with the settings by changing the use settings to:

    type=user
    secret=
    context=from-trunk

    it still did the same thing.


    Can anyone suggest what could be the problem and what can be done to fix it.
     
  2. newboy

    Joined:
    Mar 11, 2009
    Messages:
    60
    Likes Received:
    0
    Ok here is an update. i tried the following:

    1. when i tried to dial in to the IVR and dial an extension from there, it the call goes to the extension then you can talk or hear but with call forwarding or follow me it does not work. It doesn't matter if i set call forwarding on the IP phone (Linksys SPA-942) or in system using my extension, it does the same thing. no voice/ sound.

    2. It did let me dial out from an extension and i was able to talk/ hear.

    3. If i dial in to the extension (with DID forwarded to it), it rings and i can talk.

    4. If i set call forwarding on the extension, once again i hear the ringing but after that it is silent.

    5. If i dial the extension from the IVR, it forwards the call and i can hear/ talk.

    Can someone please suggest what could be wrong here and what can i do to fix it.
     

Share This Page