Outgoing call to PSTN line hangs after 4 rings

Discussion in 'General' started by Acidizer, Mar 31, 2010.

  1. Acidizer

    Joined:
    Mar 11, 2010
    Messages:
    6
    Likes Received:
    0
    Hello. When i place a call to PSTN line, i`m getting disconnected after 4 rings , how do i increase the wait time?
     
  2. fraggle4

    Joined:
    Apr 22, 2009
    Messages:
    98
    Likes Received:
    0
    I found this happening because I use busydetect to hang up the line.
    Logically, this shouldn't affect the initiation of outgoing calls, but I found that it did.
    Check in chan_dahdi.conf to see if you have busydetect=yes.
    If you have, try increasing the busycount number.
    Btw, You need to reload chan_dahdi for any changes you make to take effect.
     
  3. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    Logical or not (and personally I think it's normally a good thing if you don't have "far end disconnect supervision" and don't live in a forklift factory) it will monitor all ZAP/DAHDI channels for a repetitive tone that is not within the North American "Indications", and hangup after <busycount> of them. Make sure you set your configs to use the appropriate "Indications" to suit your locale.

    dicko
     
  4. james.zhu

    Joined:
    Feb 13, 2008
    Messages:
    99
    Likes Received:
    0
    hi:
    yes, make sure all the setting are right to meet your country:
    1) modprobe driver opermode=YOUR country
    2) make sure the country in indication.conf is correct
    3) make sure the zaptel/system.conf meets your country.
    4) Or play busydetec/busycount or answer/hanguppolarity in zapata.conf/chan_dahdi.conf
     
  5. Acidizer

    Joined:
    Mar 11, 2010
    Messages:
    6
    Likes Received:
    0
    Thank you very much for an answer!! Yes i use busydetect cause polarity switch is not used in my country (or another far end hung supervision), and yes, it`s exactly the case. Thanks to all, solved :woohoo:
     

Share This Page