outbound trunk not working with TDM400

Discussion in 'Gateways' started by mcyclegar, Oct 18, 2009.

  1. mcyclegar

    Joined:
    Nov 13, 2008
    Messages:
    9
    Likes Received:
    0
    I have a working elastix with SIP trunk and i would like to add a dahdi/zap trunk.

    I installed a TDM400 card with 3 FXO port and created a Dahdi trunk with trunk name 1 and changed the triunk for all outgoing calls. Analog phone line is conencted to port2

    When i make calls the trunk is giving the following error.

    [Oct 18 16:53:59] WARNING[4179] app_dial.c: Unable to create channel of type 'DAHDI' (cause 0 - Unknown)
    [Oct 18 16:53:59] VERBOSE[4179] logger.c: == Everyone is busy/congested at this time (1:0/0/1)
    [Oct 18 16:53:59] DEBUG[4179] app_macro.c: Executed application: Dial
    [Oct 18 16:53:59] VERBOSE[4179] logger.c: -- Executing [s@macro-dialout-trunk:20] Goto("SIP/101-098bf018", "s-CHANUNAVAIL|1") in new stack
    [Oct 18 16:53:59] VERBOSE[4179] logger.c: -- Goto (macro-dialout-trunk,s-CHANUNAVAIL,1)
    [Oct 18 16:53:59] DEBUG[4179] app_macro.c: Executed application: Goto
    [Oct 18 16:53:59] VERBOSE[4179] logger.c: -- Executing [s-CHANUNAVAIL@macro-dialout-trunk:1] GotoIf("SIP/101-098bf018", "1?noreport") in new stack
    [Oct 18 16:53:59] VERBOSE[4179] logger.c: -- Goto (macro-dialout-trunk,s-CHANUNAVAIL,3)
    [Oct 18 16:53:59] DEBUG[4179] app_macro.c: Executed application: GotoIf
    [Oct 18 16:53:59] VERBOSE[4179] logger.c: -- Executing [s-CHANUNAVAIL@macro-dialout-trunk:3] NoOp("SIP/101-098bf018", "TRUNK Dial failed due to CHANUNAVAIL (hangupcause: 0) - failing through to other trunks") in new stack


    Here is the configuration for the card.

    1) [root@asterisk]# dahdi_hardware
    pci:0000:02:01.0 wctdm24xxp+ d161:8005 Wildcard TDM410P

    2)[root@asterisk]# dahdi_scan
    [1]
    active=yes
    alarms=OK
    description=Wildcard TDM410P Board 1
    name=WCTDM/0
    manufacturer=Digium
    devicetype=Wildcard TDM410P
    location=PCI Bus 02 Slot 02
    basechan=1
    totchans=4
    irq=209
    type=analog
    port=1,FXO
    port=2,FXO
    port=3,FXO
    port=4,FXS FAILED
    [root@eidea asterisk]#


    3) dahdi_channles.conf

    ; Span 1: WCTDM/0 "Wildcard TDM410P Board 1" (MASTER)
    ;;; line="1 WCTDM/0/0 FXSKS"
    signalling=fxs_ks
    callerid=asreceived
    group=0
    context=from-pstn
    channel => 1
    callerid=
    group=
    context=default

    ;;; line="2 WCTDM/0/1 FXSKS"
    signalling=fxs_ks
    callerid=asreceived
    group=0
    context=from-pstn
    channel => 2
    callerid=
    group=
    context=default

    ;;; line="3 WCTDM/0/2 FXSKS"
    signalling=fxs_ks
    callerid=asreceived
    group=0
    context=from-pstn
    channel => 3
    callerid=
    group=
    context=default

    Please help to resolve this issue.

    Thanks in advance

    Thanks
    Mohammed Cyclegar
     

Share This Page