Outbound CID problem

Discussion in 'General' started by MageMinds, Jul 14, 2008.

  1. MageMinds

    Joined:
    Jun 26, 2008
    Messages:
    55
    Likes Received:
    0
    Hi,

    I'm having problem to change the outbound number of my callerid, I'm able to change the name to whatever I want but the number always get back to the default number of my account.

    I called my SIP provider and they confirm that I should be able to set it the whatever I want, I'm not sure how to debug that, in the Asterick CLI I can clearly see that the caller id get set to what it should be.

    If I set sip debug, I don't know when and how that information is transmitted, to verify that the caller id get sent to my provider as I want it and then blame them for the problem instead of searching for hours in FreePBX.

    Anybody know when and how SIP packets should be formatted when I send a call for the CallerID part?

    In SIP headers I see that
    From: "John Doe"<sip:1819xxxyyyy@sip.babytel.ca>

    If I change the fromuser= in the peer details of that trunk the SIP Header get changed to what I enter in the from user but that doesn't have any effect of the callerid my callee gets.

    Does anybody have a clue?
     
  2. MageMinds

    Joined:
    Jun 26, 2008
    Messages:
    55
    Likes Received:
    0
    Never mind, I figured it out ... It's working now!

    In fact the problem was the trunk configuration, when the PEER Detail state a type=peer the outbound callerid if formed using the username setting. You have to put type=friend, and you have to put insecure=very to be able to receive calls.

    Here is my config PEER Detail, my provider is babyTEL and since I cound inbound and outbound calls I send inbound calls to the special context created by FreePBX

    Code:
    type=friend
    secret=yyyyyyyyyyy
    username=xxxxxxxxxxxxxx
    host=sip.babytel.ca
    dtmfmode=rfc2833
    nat=yes
    context=from-trunk-sip-babyTEL
    disallow=all
    allow=g729&ulaw
    insecure=very
    
    <br><br>Post edited by: MageMinds, at: 2008/07/14 17:47
     
  3. chrj

    Joined:
    Apr 17, 2008
    Messages:
    2
    Likes Received:
    0
    I did the same thing type=friend, set outbound caller id in freepbx trunk settings, but only nunber get displayed, caller id name says "unknown".
    babytel has confirmed that I can display any number & any name, also tried to remove fromuser, then I can't make any out going calls.
    did you make any changes in context? I see you have a custom context in your sip setting.

    Code:
    [babytel]
    context=from-trunk
    host=sip.babytel.ca
    type=friend
    secret=xxxx
    username=1xxxxxxxxxx
    fromuser=1xxxxxxxxxx
    port=5065
    fromdomain=sip.babytel.ca
    nat=yes
    disallow=all
    allow=ulaw
    insecure=very
    
     
  4. MageMinds

    Joined:
    Jun 26, 2008
    Messages:
    55
    Likes Received:
    0
    Here is my actual config to the babyTEL trunk

    Code:
    type=friend
    insecure=very
    context=from-trunk-sip-babyTEL
    username=1xxxxxxxxxx
    secret=*************
    host=sip.babytel.ca
    port=5065
    nat=yes
    dtmfmode=rfc2833
    disallow=all
    allow=g729&ulaw
    The custom context is automatically created by FreePBX v2.4 it allow to count inbound and outbound channels used, so Asterisk won't try to dial that trunk if the "Maximum Channels" is reached.

    A friend of mine does have babyTEL too and I had also problem with type=friend not being able to place a call, I though it was because he doesn't have the right to change it's CID number.

    Also here is my Dial Rules for that trunk if it helps... With babyTEL sometimes when you doesn't dial the 1 they can't terminate the call, I don't know why, so now I always send them the 1 and every calls to everywhere does work. They doesn't charge you a LD just because you dialled the 1, they will charge LD only if you get out of your "local" configuration, if you got local province, then they check if you get out of the allocated area code for your province. Myself I live in Quebec and we have 6 different area codes. Don't forget to make sure you can dial 310 numbers ... They don't require area code or country codes. If you want to test a 310, call 310BELL, for the police you can dial 3104141 so if your provider doesn't provide 911, you can trick your outbound dial pattern to send 3104141 instead and you'll get something like 911 service... 911|3104141

    Anyways here is the Dial Rules of my babyTEL trunk.

    Code:
    310XXXX
    1819+NXXXXXX
    1+NXXNXXXXXX
    Note: I don't know if that changes anything, but I have the original ATA that babyTEL sold me 2 years ago still registered and still working on my network... SO they have two register to the same IP address, that may be why I can make my configuration work ... I will try tonight to disconnect the ATA to see what will happed.

    Meanwhile you can try to add fromuser=1xxxxxxxxxx and fromdomain=sip.babytel.ca to see if it works.
     
  5. MageMinds

    Joined:
    Jun 26, 2008
    Messages:
    55
    Likes Received:
    0
    Here is a little update ... I disable the line on my ATA and tried different settings on my trunk ... It turn out that type=friend and type=peer both work the same ... But as soon as I add the setting fromuser to the trunk configuration it doesn't work ... I can place and receive calls, but my caller id number is the one I put in fromuser.

    For you specific problem, you say that the name doesn't get displayed, only the number, can you make the number change? Are you sur you're using the right format for the outbound caller id then format is the following ALL characters included:
    "John Doe" <5555555555>

    The problem I was having was that the number didn't got changed only the name was changing, by default babyTEL sends the number with the 1 at the begining and usually callerid string doesn't include the 1. When you test write something odd as callerid and try call yourself.

    MageMinds
     
  6. chrj

    Joined:
    Apr 17, 2008
    Messages:
    2
    Likes Received:
    0
    problem solved! both name and number can be properly displayed now.
    here is what I have, fromuser=905xxxxxxx (my rogers number), put the name display in Outbound CID field in freepbx.

    why did it not working for my previous test? it was the iax2 softphone, once I switch to a sip client, I got both on outbound call display.

    hope this helps for anyone else using babytel service.
     

Share This Page