Outbound Calls

p_heath

Joined
Feb 23, 2011
Messages
7
Likes
0
Points
0
#1
Hi,

I'm relatively new to Elastix so please bear with me and I apologise now for my ignorance!

We have a Xorcom XR1000 box - currently with only 1 line connected but no LED's on the box.

I have setup a trunk with 11 X's in the Dial Rules

I have also setup an outbound rule with 11 X's in with the trunk assigned.

Whenever I try and dial out I just get an automated message. I don't want to have to dial a 9 to get an outside line.

Thanks
Paul. :)
 

fmvillares

Joined
Sep 8, 2007
Messages
1,785
Likes
0
Points
0
#2
if you have 11 X´s you need to dial 18003333333 (11 numbers only) for example and only that type of numbers will get out
 

p_heath

Joined
Feb 23, 2011
Messages
7
Likes
0
Points
0
#3
I'm only entering 11 numbers - UK numbers are 11 digits but it still doesn't appear to make a difference. I have also tried X. but this produces the same error
 

fmvillares

Joined
Sep 8, 2007
Messages
1,785
Likes
0
Points
0
#4
Re: Re:Outbound Calls

and in line down down in the page of your outbound route you have selected the correct trunk?
 

p_heath

Joined
Feb 23, 2011
Messages
7
Likes
0
Points
0
#5
I have setup 8 trunks (for the 8 ports on the box) and these are selected in order 1-8 in the trunk sequence.
 

fmvillares

Joined
Sep 8, 2007
Messages
1,785
Likes
0
Points
0
#6
Re: Re:Outbound Calls

mmm with that info not a single clue...what does the asterisk cli said to you when dialing out?
 

alambro1

Joined
Aug 6, 2009
Messages
5
Likes
0
Points
0
#7
Re: Re:Outbound Calls

Launch your SSH client and login to your server.

Type "asterisk -r" as seen below
[root@srv-a ~]# asterisk -r

Type "dahdi show channels" as seen below, this will output a list of all of your channels. Channels 1-23 are my T1 Pri with 24 being the b-channel. I have 4 T1's (only 1 is active) hence the reason the next number in the list is 97. Channels 97-112 are my FXS and 113-120 are my FXO.

srv-a*CLI> dahdi show channels
Chan Extension Context Language MOH Interpret
pseudo default default
1 from-pstn default
2 from-pstn default
3 from-pstn default
4 from-pstn default
5 from-pstn default
6 from-pstn default
7 from-pstn default
8 from-pstn default
9 from-pstn default
10 from-pstn default
11 from-pstn default
12 from-pstn default
13 from-pstn default
14 from-pstn default
15 from-pstn default
16 from-pstn default
17 from-pstn default
18 from-pstn default
19 from-pstn default
20 from-pstn default
21 from-pstn default
22 from-pstn default
23 from-pstn default
97 from-internal default
98 from-internal default
99 from-internal default
100 from-internal default
101 from-internal default
102 from-internal default
103 from-internal default
104 from-internal default
105 from-internal default
106 from-internal default
107 from-internal default
108 from-internal default
109 from-internal default
110 from-internal default
111 from-internal default
112 from-internal default
113 from-pstn default
114 from-pstn default
115 from-pstn default
116 from-pstn default
117 from-pstn default
118 from-pstn default
119 from-pstn default
120 from-pstn default
srv-a*CLI>


Next type "dahdi show status", this will tell you if your devices are active or not as seen below. Ok means that the devices are active.

srv-a*CLI> dahdi show status
Description Alarms IRQ bpviol CRC4
Xorcom XPD #00/00: T1 OK 0 0 0
Xorcom XPD #00/01: T1 RED 0 0 0
Xorcom XPD #00/02: T1 RED 0 0 0
Xorcom XPD #00/03: T1 RED 0 0 0
Xorcom XPD #00/10: FXS OK 0 0 0
Xorcom XPD #00/20: FXS OK 0 0 0
Xorcom XPD #00/30: FXO OK 0 0 0

Next, See Attachment. Create a new trunk called Test FXO Trunk, set max channels at 1 and set the Zap Identifier as the first open FXO port from the output above (mine is 113, yours will be different), save settings. Now create an outbound route called Test-Route, enter in the dial patterns you see in the attachment. These dial patterns will allow calls to any 800, 866, 877, 888, 10-digit or 7-digit numbers you dial. Next, in the trunk sequence box select the trunk you created in the previous step (mine was ZAP/113, yours will be different).

Now, make sure you have an active line plugged into the proper port for which you setup your trunk. Test this line by plugging in a standard analog telephone and place a call, if the call goes through you know the line is active, plug the line back into the proper port on the PBX.

Now, test a phone connected to the PBX to make sure it is setup properly by dialing *98 (voicemail), if you get voicemail then you have a phone that is properly communicating with the PBX. Now go back to "Outbound Routes" in the PBX and make sure that "Test-Route" is at the top of the list if you have multilple outbound routes. Apply and save all changes. You should be able to make a call now.

NOTE: If you are dialing from an analog phone attached to one of the PBX's FXS ports you CANNOT use the # key to send the call, you must wait for the timeout period and the call will be placed automatically. If you press the # key the call will fail everytime.
 

alambro1

Joined
Aug 6, 2009
Messages
5
Likes
0
Points
0
#8
Re: Re:Outbound Calls

The attachment appears to not be working so....Dial plan below.

If your service provider requires you dial a 1 before ten digit numbers then use this:
1800NXXXXXX
1866NXXXXXX
1877NXXXXXX
1888NXXXXXX
1NXXNXXXXXX
NXXXXXX


If your service proivder does not require a 1 before ten digit number then use this:
800NXXXXXX
866NXXXXXX
877NXXXXXX
888NXXXXXX
NXXNXXXXXX
NXXXXXX
 

p_heath

Joined
Feb 23, 2011
Messages
7
Likes
0
Points
0
#9
Thanks very much for all the useful information!

I'll give it a try and let you know how I get on.
 

p_heath

Joined
Feb 23, 2011
Messages
7
Likes
0
Points
0
#10
Thanks for your advice. I am not able to make outbound calls and internall between extensions
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,901
Messages
130,885
Members
17,561
Latest member
marouen
Top