Outbound calls not working

Discussion in 'General' started by justconnect, Jun 18, 2009.

  1. justconnect

    Joined:
    Jun 17, 2009
    Messages:
    11
    Likes Received:
    0
    Hi

    Ok - I am slowly making progress but am still unable to make calls outbound using a SIP trunk. So far we have:

    * Elastix server on IP address 192.168.0.57
    * 2 Softphones - BOL & X-Lite on extensions 220 and 210 respectively. These 2 phones can call one another without problems so internal calls are working.
    * SIP account is registered - shows as registered on VSP server.

    I have set up my SIP trunk as follows:
    * No dial rules
    * Peer details:
    type=user
    secret=%%%%%
    qualify=yes
    nat=yes
    host=196.30.127.180
    fromuser=278780%%%%%
    dtmfmode=rfc2833
    disallow=all
    context=from-trunk
    canreinvite=no
    allow=g729&alaw&ulaw

    * User details are currently blank - I just want to get outgoing working first before worrying about incoming.
    * Register string is 2787806%%%%:password@196.30.127.180

    Something that seems strange to me is the results of 2 Cli commands:
    * SIP SHOW PEERS gives
    Name/username Host Dyn Nat ACL Port Status
    220 192.168.0.47 D N 2257 OK (2 ms)
    210/210 192.168.0.47 D N 22282 OK (103 ms)
    2 sip peers [Monitored: 2 online, 0 offline Unmonitored: 0 online, 0 offline]

    * SIP SHOW REGISTRY gives
    Host Username Refresh State Reg.Time
    196.30.127.180:5060 278780%%%% 585 Registered Thu, 18 Jun 2009 13:35:04

    At one stage I thought I was getting the SIP trunk showing under peers. Now it doesn't appear there.

    Outbound routes uses the SIP trunk and the dial patterns are as follows:
    .
    NXXNXXXXXX
    NXXXXXX
    XXXXXXXXXX
    (I am trying to catch all numbers and route them via the SIP trunk just to test).

    Every time I try to dial an external number I get that woman with the infuriating message saying, "All circuits are busy now. Please try your call again later." Can anyone assist me with a reason why?

    Many thanks
     
  2. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    Re hi.
    I think that your trunk must be peer type and not user type.
    the username is missing.
    Add :
    username=278780..Etc

    So

    Code:
    type=peer
    username=278780%%%%%
    secret=%%%%%
    qualify=yes
    nat=yes
    host=196.30.127.180
    fromuser=278780%%%%%
    dtmfmode=rfc2833
    disallow=all
    context=from-trunk
    canreinvite=no
    allow=g729&alaw&ulaw

    Try it.
     
  3. justconnect

    Joined:
    Jun 17, 2009
    Messages:
    11
    Likes Received:
    0
    Ok - I have updated my trunk:

    SIP TRUNK
    No dial rules
    No Outgoing Dial prefix

    Peer Details are:
    type=peer
    username=278780%%%%%
    secret=PASSWORD
    qualify=yes
    nat=yes
    host=196.30.127.180
    fromuser=278780%%%%%
    dtmfmode=rfc2833
    disallow=all
    context=from-trunk
    canreinvite=no
    allow=g729&alaw&ulaw
    insecure=very

    Incoming settings I have left blank as I am just trying to get outgoing working for now.

    Finally my register string is 278780%%%%%:pASSWORD@196.30.127.180/278780%%%%%

    On my outbound routes, I have selected the above trunk. My dial patterns are
    .
    NXXNXXXXXX
    NXXXXXX
    XXXXXXXXXX

    The rest I have left standard.

    When I try to dial a local number I get the message saying "All circuits are busy now. Please try your call again later."

    Any guidance is appreciated.
     
  4. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    Try to verify if you have the good result with.
    CLI> sip show peers
    CLI> sip show registry

    Else, enable your débug mode like this:
    CLI> sip debug peer your-trunk-name

    Make your call
    Exit your debug mode by (sip no debug).
    Select only dump before your "all circuits are busy now".

    So I want only this style:

    Code:
    <------------->
    --- (11 headers 0 lines) ---
    Transmitting (NAT) to 91.---.---.---:5060:
    ACK sip:02409--------@sip.ovh.net SIP/2.0
    Via: SIP/2.0/UDP 62.---.---.---:5060;branch=z9hG4bK31facd31;rport
    From: "Franck Distant" <sip:102@62.---.---.--->;tag=as39e940c3
    To: <sip:0240--------@sip.ovh.net>;tag=00-08189-03a9c4dd-2a09e1d87
    Contact: <sip:102@62.---.---.--->
    Call-ID: 3a7b9c8d3e2e97ec5a8f1fea3e9a5e95@62.---.---.---
    CSeq: 102 ACK
    User-Agent: Asterisk PBX
    Max-Forwards: 70
    Content-Length: 0
    And give me the result for to put it in the file and attach it (from down post : Select file to attach section) with a txt file.
     

Share This Page