Openbox B400P and Elastix 1.5.2-2

Discussion in 'Gateways' started by tbote, May 28, 2009.

  1. tbote

    Joined:
    Feb 17, 2009
    Messages:
    98
    Likes Received:
    0
    Hi

    I've recently installed a Elasitx 1.5.2-2 in a PC with a B400P but really don't know hoy to use Elastix with that card.

    I try to detect ISDN hardware, detects four ISDN channels but I can use them, Elastix says that the channels are in use for another PBX.

    I have a production machine with Elastix 1.1 and also a B400P but I want to migrate it to 1.5.2-2, in the first one appears a custom trunk (misdn) but same configuration in the second one does nothing. I have not idea about Elastix (or not too much idea) so I'm just cloning all options in both machines.

    Also when I try to make a internal call (between two extensions) also does not work (but the extensions are well registered), I can detect any difference between both machines.

    Any idea?
     
  2. raytwigg

    Joined:
    Feb 14, 2009
    Messages:
    8
    Likes Received:
    0
    Hi,

    I have a working installation with 1.5.2 and a B100P card so this might help.

    The first thing I would say is that you really ought to get the problem with the internal extensions solved first. How can you be sure that the problem is with the ISDN circuit when there is a doubt about the extensions. Calling between extensions has always just worked for me so I have no idea what may be wrong. Try submitting a separate post in a more appropriate part of the forum.

    Regarding the B400P, do you know whether your Telco is providing "point to point" or "point to multi-point" service? You can probably figure this out from the config files on your old system. The files have changed between versions and I have no experience of the older version so you will have to look through any misdn config file until you find it.

    When you detect the hardware it installs the file /etc/mISDN.conf but it always seems to set it as "ptmp" irrespective of the actual service provided. This might be correct for you but I had to edit my system to "ptp" as below:

    <mISDNconf>
    <module poll="128" debug="0" timer="no">hfcmulti</module>
    <module debug="0" options="0">mISDN_dsp</module>
    <devnode user="asterisk" group="asterisk" mode="660">mISDN</devnode>
    <card type="hfcpci">
    <port mode="te" link="ptp">1</port>
    </card>
    </mISDNconf>

    Don't be tempted to edit other stuff in this file to mirror my settings; your card needs different values. Just edit the ptp/ptmp value if necessary.

    The file /etc/asterisk/misdn.conf is a sample config file. Most of it is fine for me but after the line "max_outgoing=-1" I removed everything and replaced it with:

    [misdnchannels]
    ports=1
    msns=*
    context=from-pstn
    echocancel=yes

    Bear in mind that you have 4 ports so your ports line will be "ports=1,2,3,4" unless you choose to create separate contexts.

    When you create your custom trunk you should use a custom dial string that references the context you used in /etc/asterisk/misdn.conf. Here is mine:

    mISDN/g:misdnchannels/$OUTNUM$

    Please make a backup copy of any file before you edit it and don't forget to restart Asterisk to pick up the changes.

    Hope this helps.

    Ray.
     
  3. raytwigg

    Joined:
    Feb 14, 2009
    Messages:
    8
    Likes Received:
    0
    Hi,

    One thing I forgot to mention. In /etc/asterisk/misdn.conf you should edit the line which sets the path to the old style config file. Like this:

    [general]
    ;
    ; Sets the Path to the misdn-init.conf (for nt_ptp mode checking)
    ;
    ; misdn_init=/etc/misdn-init.conf
    misdn_init=/etc/mISDN.conf


    Ray.
     
  4. icecbr

    Joined:
    Sep 23, 2009
    Messages:
    2
    Likes Received:
    0
    raytwigg thank you very much...!!!

    I was searching for hours and nothing was really working! thanks to your guide I think its ok now.

    From Elastix Detect hardware now I get (from b100p):
    Code:
    Misdn Card
    
    Port 1: TE-mode BRI S/T interface line (for phone lines)
    -> Protocol: DSS1 (Euro ISDN)
    -> childcnt: 2
    --------
    

    I want to add that after I did what you say I had to do these:
    - misdn-init scan
    - misdn-init config
    - misdn-init start
     

Share This Page