ooh323 & elastix 0.9.2

cowboy47

Joined
Jun 14, 2007
Messages
276
Likes
0
Points
0
#1
I recently (as in the last two days) ran into a major issue with elastix 0.9.2 where I had installed ooh323 from asterisk-addons-1.4.5. The problem with ooh323 is that for some reason in this release of ooh323 it does not open the audio codecs or H2250. This is a reported bug and it is supposed to be corrected in the asterisk-addons-1.4.6 HOWEVER, when I tried to install and compile the addons, it did not like the version of asterisk (1.4.17-1) and wanted to have version 1.4.18. I found that there is the src rpm file in the repos but doing an rpm -Uvh did NOT update asterisk, would not let me compile the addons and so I pulled down the latest asterisk-1.4.18.tar.gz, untarred it and started compiling.

Result, is that now, no matter what I do, asterisk is dead in the water. The compile did not like some of the modules that have been included in elastix (such as vorbiz, fax, mysql, and a few others) and it did not create asterisk.ctl or asterisk.pid.

I have tried several things, recompiling, reinstalling older versions, overwriting with the rpms in repos but nothing. So as it stands right now, I am looking at a reinstall from the iso or move up to 1.0-beta9.

I have several questions and issues:

1. Does 1.0-beta9 natively support Sangoma A200 cards?
2. If not, what kernel do I need to pull down so that I can install the Sangoma drivers?
3. How and what is the process of updating the asterisk-addons?
4. Is there another solution to the h323 issue?

Thanks for any comments in advance
C
 

ramoncio

Joined
May 12, 2010
Messages
1,663
Likes
0
Points
0
#2
Hi cowboy47!
Good to see you!
You must not be very happy with Elastix right now.
So ooh323 doesn't work ok in 0.9.2, and you had trouble too with a sangoma in 1.0.9beta.
I did install asterisk-addons some time ago in order to try chan_mobile, but didn't even compile ooh323 support.
You have to patch zaptel with oslec echo canceler. You can download the svn with svn co http://svn.rowetel.com/software/oslec/trunk/ oslec
And you can make menuselect in asterisk-addons, so you can choose what to compile.

Good luck!
 

cowboy47

Joined
Jun 14, 2007
Messages
276
Likes
0
Points
0
#3
Well, I am not unhappy with Elastix but I would appreciate some more conversations from Edgar & team as far as what they are doing.

Could you outline more the process of patching the zaptel with the oslec drivers? The bug that I found (which is documented at Digium) is the the 1.4.5 version of asterisk-addons has a bug in that it is not opening the audio codecs and this is defined by not knowing what to do with an H2250 call. Supposedly this is corrected in the 1.4.6 version of asterisk-addons but I could not get it to compile.

As far as 1.0 release. I REALLY liked the way the interface looks BUT things like Sangoma not working are a show stopper and I cannot understand how someone would make a statement that the stable version will be released on the 26th of March when there has not been any response to the issues of the things that are broken.

Come on, let's get serious here, Sangoma is not some knock off card, they have a large market share and they offer some things that others do not. On top of that, their support is really great. But make general assumptions on the configuration of an A102 card, thinking that everyone will be using B8ZS & CRC is a bad assumption. Not to mention there are a ton of other items to configure.

I also tried the online configurator but that did not seem to work either.

Which brings me to another issue. FreePBX is not on 2.4 , they have released modules to upgrade to 2.4 and Digium is working on Asterisk 1.6 . If you are going to issue a major release, why not go with the new forks too?

Again, I would love some additional guideance on the zaptel - oslec patching process & any other input you might have regarding the asterisk-addons.

C
 

cowboy47

Joined
Jun 14, 2007
Messages
276
Likes
0
Points
0
#4
That link does not seem to work.
 

cowboy47

Joined
Jun 14, 2007
Messages
276
Likes
0
Points
0
#5
bump
 

ramoncio

Joined
May 12, 2010
Messages
1,663
Likes
0
Points
0
#6

lek

Guest
#7
Re:eek:oh323 & elastix 0.9.2

Sorry for the silence guys, a lot of work here ;(

1. Does 1.0-beta9 natively support Sangoma A200 cards?
At least in theory yes. Anyway we don't built the Sangoma drivers for Elastix but the Sangoma people. Please follow this link: http://wiki.sangoma.com/elastix-rpms

2. If not, what kernel do I need to pull down so that I can install the Sangoma drivers?
2.6.18-8

3. How and what is the process of updating the asterisk-addons?
You'll need to download the src rpms and update the asterisk-addons source code. However, we hope to release asterisk-addons 1.4.6 this Thursday.

4. Is there another solution to the h323 issue?
Honestly, I don't know :(

Hope this helps.<br><br>Post edited by: edgar, at: 2008/03/19 13:46
 

saleh

Joined
Apr 18, 2007
Messages
249
Likes
0
Points
0
#8

cowboy47

Joined
Jun 14, 2007
Messages
276
Likes
0
Points
0
#9
Thanks for the reply. This is very frustrating. I cannot wait until the 23rd for the new addon rpm my client will kill me.

Also, regarding the proposed release of 1.0, until these things are check, I would not venture to install 1.0, the lastest beta was a nightmare for me.

Additional input also, if A2Billing is important to you, DO NOT update freepbx to 2.4 there are some major issues and a major rework of the conf files and the manner in which they do things (contrary to what one of the developers says).

C

P.S. This thank you goes all to all who responded.
 

lek

Guest
#10
We hope to have the addons rpm this Thursday 20th, not the 23rd. Hope it helps :)

We won't update the freePBX to 2.4 until the next release (1.1) and after doing some tests. At this moment we're very comfortable with 2.3.

By the way, what are the issues with A2B?
 

cowboy47

Joined
Jun 14, 2007
Messages
276
Likes
0
Points
0
#11
Issues with A2B are as follows (this specifically applies to freepbx 2.4):

1. custom applications disappears - while it shows as a module that is up to date, the option for custom apps does not appear in any of the menus.

2. Miscellaneous applications does not work for a2billing

3. freepbx show bad destinations if you have upgraded a working 2.3 system to 2.4.

4. makeing inbound & outbound routes directly in a2billing does not seem to work without having something done in freepbx. I was under the impression that a2billing did not require freepbx.

There are some other issues but I will have to speak to the customer.
 

lek

Guest
#12
Hey cowboy47. We have worked on a new RPM for asterisk-addons-1.4.6 today. Hope it helps!

Please download it from here http://www.elastix.org/downloads/asteri ... 1.i386.rpm

Honestly, this rpm is not well tested. So, better if you use the "rollback" feature of the RPM command.

Please, report any issue with this RPM.

Good luck.
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,902
Messages
130,886
Members
17,563
Latest member
dineshr
Top