Only One Side of Voice Heard with External Sips!

Discussion in 'General' started by tarnok, Apr 29, 2009.

  1. tarnok

    Joined:
    Apr 20, 2009
    Messages:
    16
    Likes Received:
    0
    Hey!

    This is my first time here and I am learning about elastix for an office I am working at.
    So far I seem to have configured and set up most things correctly, I have 5 Sip extensions, 4 internal and 1 external at my home, using linksys SPA941 handsets.

    The 4 internal can call each other with no issues, clear sound both sides, They can also send and receive calls to the normal PSTN / outside world. I am happy with how it is set up. However my one external extension can receive and send calls (It registers with the server) but the external extension can only HEAR voice but not send it (one-way). I thought it was the elastix server and the NAT/router conflicting so I put the elastix server on the DMZ and still nobody was able to hear me from the external extension even though I could hear everyone I called.

    Here is my sip.conf:
    Code:
    [general]
    ;
    ; jbenable=yes
    ; jbforce=yes
    
    disallow=all
    allow=ulaw
    allow=alaw
    context=from-sip-external
    bindport = 5060           ; Port to bind to (SIP is 5060)
    bindaddr = 0.0.0.0    ;all addresses on machine)
    callerid = Unknown
    tos=0x68
    qualify=yes
    and my sip_NAT.conf
    Code:
    nat=yes
    externip=xx.xx.xx.xx
    externrefresh=120
    Can anybody help me please?
     
  2. mattrh

    Joined:
    Jul 15, 2008
    Messages:
    175
    Likes Received:
    0
    check your router at home? do you have any type of content filtering?
     
  3. Lou1z

    Joined:
    Aug 20, 2008
    Messages:
    57
    Likes Received:
    0
    that sounds like a nat issue.
    you need to put your localnet into sip_nat.conf

    for example

    nat=yes
    externip=111.111.111.111
    localnet=192.168.1.0/255.255.255.0
     
  4. tarnok

    Joined:
    Apr 20, 2009
    Messages:
    16
    Likes Received:
    0
    The localnet= seems to have done the trick! Thank you!
    people can now hear me when I speak to them from my external extension!

    In the morning I need to remove the server from the DMZ and hopefully have the port forwarding working correctly!

    Thank you again! Can one of the mods rename the thread with [Solved] ?
     
  5. tarnok

    Joined:
    Apr 20, 2009
    Messages:
    16
    Likes Received:
    0

Share This Page