Not working

Telco

Joined
Oct 4, 2007
Messages
275
Likes
0
Points
0
#1
I installed it. Followed step by step. Everything installed fine. I boot up my 57i and it finds DHCP then just finishes loading and that is it, nothing. Just a default phone. Not logged into anything just as I took it out of the box. Any ideas?
 

Telco

Joined
Oct 4, 2007
Messages
275
Likes
0
Points
0
#2
Oh I can manually program the phone and it works fine.
 

dicko

Joined
Oct 24, 2008
Messages
4,099
Likes
0
Points
0
#3
add -vv -c to /etc/xinet.d/tftp server arguments. restart tftpd,
tail -f /var/log/messages and see if the phone is a) getting it's address from your server, (only one dhcp server per network until you're a big boy), b)the phone is finding your tftpd, c) the tftpd is serving aastra.cfg on request.
 

Telco

Joined
Oct 4, 2007
Messages
275
Likes
0
Points
0
#4
Thanks dicko you are a huge asset to the elastix's forums.

I however am not quite at your level on the linux. So can you explain how to add -vv -c to /etc/xinet.d/tftp server arguments. restart tftpd, tail -f /var/log/messages.

I do get an ip from my DHCP server however I am not using the one that comes with elasitx. Do I have to use that DHCP server?

Thanks.
 

donhwyo

Joined
Aug 8, 2008
Messages
293
Likes
0
Points
0
#5
Is your dhcp giving out option 66 as your elastix box's ip? What kind of server is it?

Don
 

dicko

Joined
Oct 24, 2008
Messages
4,099
Likes
0
Points
0
#6
Telco said:
Thanks dicko you are a huge asset to the elastix's forums.

I however am not quite at your level on the linux. So can you explain how to add -vv -c to /etc/xinet.d/tftp server arguments. restart tftpd, tail -f /var/log/messages.

I do get an ip from my DHCP server however I am not using the one that comes with elastix. Do I have to use that DHCP server?

Thanks.
No no, thank you,


For a newbie there can only be one dhcp server on a network, for tftpd to work, it must be set up to offer the machine that serves tftp files, when option 66 (tftp server) is asked of it, if the dhcp server is not your Elastix box, (which will do that if used), then you must add that option to the the dhcp server you are using (if it capable of so doing).

If you choose to use Elastix as your dhcp server:

then back to you first questions, you need to use a text editor, by default in Elastix you have vi, I suggest a more newbie friendly alternative:

yum -y install mc; mcedit /etc/xinetd.d/tftp; /etc/init.d/tftpd restart

(This will down-load and install without question "midnight commander", and then invoke the editor part of it, mcedit, (try mc on it's own some time, for an easy way to browse and familiarize yourself with a real OS's file system, almost EVERYTHING in "the linux" sic. is a file or in a file of some sort, ) to edit the text file that controls the tftp server behavior that is handled by xinet, I suggest you add -vv ( a reasonable amount of verbosity) and -c (to allow files to be created by the client phones, useful for aastra, polycom and probably others, that would like to store their local phone books, call history etc. on the tftp server) , and then restart the the tftp daemon (server) with the new behavior (which is possible unnecessary, as this service is handled by xinet, (that however is another story, so just for giggles do it anyway))

tail -f tells a program called tail to (-f) follow a file as it grows and display new lines on the console. messages in /var/log (where most logs are written) is a logfile that many relatively quiet daemons choose to send there output (if any) to

Watch with wonder as the DHCP and TFTP services are requested and handled (or not!)
 

Telco

Joined
Oct 4, 2007
Messages
275
Likes
0
Points
0
#7
ok I found my problem, My DHCP does not support option 66. Now I need to find one that does.
 

donhwyo

Joined
Aug 8, 2008
Messages
293
Likes
0
Points
0
#8
You should be able to set it on the phone to go to your elastix and get the tftp.

Also mdnsresponder should work too.

Also you don't need to look to far. Try the one in Elastix.

Don
 

dicko

Joined
Oct 24, 2008
Messages
4,099
Likes
0
Points
0
#9
Telco said:
ok I found my problem, My DHCP does not support option 66. Now I need to find one that does.
look no further , the elastix one DOES, as you have been previously informed (it's already installed and available to you, please at least read the responses to your posts, if all else fails for you then try the RTFM route like most other folk, it seems to work for them)
 

Telco

Joined
Oct 4, 2007
Messages
275
Likes
0
Points
0
#10
Ok I am missing something. Where is the tftp option in the elastix. I can't find it under the DHCP option. Is it not in the gui?
I have done everything that dicko said to do except when I enter /etc/init.d/tftpd restart it says

[root@crwatts ~]# /etc/init.d/tftpd restart
-bash: /etc/init.d/tftpd: No such file or directory
[root@crwatts ~]# -bash: /etc/init.d/tftpd: No such file or directory
-bash: -bash:: command not found
[root@crwatts ~]# tail -f /var/log/messages
Oct 19 18:43:18 crwatts in.tftpd[8118]: tftpd: read(ack): Connection refused
Oct 19 18:43:22 crwatts in.tftpd[8120]: tftpd: read(ack): Connection refused
Oct 19 18:43:26 crwatts in.tftpd[8122]: tftpd: read(ack): Connection refused
Oct 19 18:43:31 crwatts in.tftpd[8124]: tftpd: read(ack): Connection refused
Oct 19 18:43:35 crwatts in.tftpd[8126]: tftpd: read(ack): Connection refused
Oct 19 18:43:39 crwatts in.tftpd[8128]: tftpd: read(ack): Connection refused
Oct 19 18:43:43 crwatts in.tftpd[8130]: tftpd: read(ack): Connection refused
Oct 19 18:43:47 crwatts in.tftpd[8132]: tftpd: read(ack): Connection refused
Oct 19 18:58:49 crwatts xinetd[1825]: EXIT: tftp status=0 pid=8048 duration=1627(sec)
Oct 20 18:33:32 crwatts yum: Installed: 1:mc-4.6.1a-35.el5.i386

please help if you can ... I might just be a lost cause. I would love to use the Aastra XML scripts rather than having to configure all 120 phones by hand.
 

dicko

Joined
Oct 24, 2008
Messages
4,099
Likes
0
Points
0
#11
My apologies, I misposted the concatenated line that included restarting tftpd that would not be necessary in a standard Elastix Installation as the tftpd daemon is running under xinetd. It was a harmless error no harm no foul. (it should have been /etc/init.d/xinetd restart)


If you look in /etc/dhcpd.conf AFTER you enable DHCP in the Network page, it will automatically include option tftp-server-name "<ip address of your box>", so if you use the Elastix DHCP server everything will just work, if you use some other DHCP server it would have to be done by that server, .

The Aastra script also install mdns as an alternative to dhcp but I don't use it so I can't comment on it's effectiveness.

I suggest if it is feasable, turn off all DHCP servers except the Elastix box, and try the aastra phone login button. It normally just works.

BTW you're not lost, you just need to find the path.
 

Telco

Joined
Oct 4, 2007
Messages
275
Likes
0
Points
0
#12
dicko thanks for the help. That did it.

P.S. It sure would be nice if they added that option into the DHCP GUI in the system.
 

Telco

Joined
Oct 4, 2007
Messages
275
Likes
0
Points
0
#13
dicko thanks for the help. That did it.
 

dicko

Joined
Oct 24, 2008
Messages
4,099
Likes
0
Points
0
#14
You're welcome,

But as the tftp option is assumptive that you will use the builtin DHCP server and it is already configured "out of the box", surely it would be more confusing for most people to option an unnecessary option. If you want to go "off the beaten track" would that not be your responsibility?, any way I'm glad you got it working, and found the start of the path.

dicko
 

donhwyo

Joined
Aug 8, 2008
Messages
293
Likes
0
Points
0
#15
It is a rare occasion for Dicko to be wrong but read this. The section about tftp.

Code:
yum list tftp*
Should see something like this.
Code:
tftp-server.i386                  0.42-3.1.el5.centos                  installed
Available Packages
tftp.i386                         0.42-3.1.el5.centos                  base
If not the link will tell you what to do. Hint I found this in 2 seconds with google. Sorry I am starting to sound like Dicko.:woohoo:
http://wiki.centos.org/EdHeron/PXESetup#head-e597b554c6e5c3157ac4f6a013a034d03daafd7f

Don

You guys type too fastB) Glad you got it working.
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,902
Messages
130,887
Members
17,565
Latest member
omarmenichetti
Top