Not receiving faxes on elastix 2.2

Discussion in 'General' started by li2, Oct 4, 2010.

  1. li2

    li2

    Joined:
    Sep 6, 2009
    Messages:
    13
    Likes Received:
    0
    Hi
    I did fax settings elastix
    Apparently everything is correct
    Fax is sent correctly but will not receive faxes
    Several types of fax machine but also tried to send faxes from their systems fail is elastix.
    I'm using the card openvox.
    Please advise me on.
     
  2. li2

    li2

    Joined:
    Sep 6, 2009
    Messages:
    13
    Likes Received:
    0
    I installed the latest version Elastix 2.2
    Fax settings also did . (Running and idle on ttyIAX1)
    Fax is sent correctly, but will not receive fax
    Where is the problem ?
     
  3. trymes

    Joined:
    Aug 19, 2009
    Messages:
    228
    Likes Received:
    0
    Let's start with this: What happens when you try to send a fax?

    - Does the line ring and ring, but HylaFAX never answers?
    - Does HylaFAX pick up the phone, but the fax does not go through?

    The easiest way tto start any fax troubleshooting is to pick up a phone and dial the fax number. If the modem answers, then you know you need to look at the fax software. If it does not, you need to look at the telephony bits that route the call to the fax modem.

    Please post back what you find.

    Tom
     
  4. li2

    li2

    Joined:
    Sep 6, 2009
    Messages:
    13
    Likes Received:
    0
    When a city or a local line with the internal fax calls, I'm faced with a fax beep
    But do not be received
     
  5. li2

    li2

    Joined:
    Sep 6, 2009
    Messages:
    13
    Likes Received:
    0
    When a city or a local line with the internal fax calls, I'm faced with a fax beep
    But do not be received



    Options:
    config.ttyIAX1
    CountryCode: 98
    AreaCode: 21
    FAXNumber: 88456738
    LongDistancePrefix: 1
    InternationalPrefix: 011
    DialStringRules: etc/dialrules
    ServerTracing: 0xFFF
    SessionTracing: 0xFFF
    RecvFileMode: 0600
    LogFileMode: 0600
    DeviceMode: 0600
    RingsBeforeAnswer: 1
    SpeakerVolume: off
    GettyArgs: "-h %l dx_%s"
    LocalIdentifier: "Virtual Idea Network"
    TagLineFont: etc/lutRS18.pcf
    TagLineFormat: "From %%l|%c|Page %%P of %%T"
    MaxRecvPages: 200
    #
    #
    # Modem-related stuff: should reflect modem command interface
    # and hardware connection/cabling (e.g. flow control).
    #
    ModemType: Class1 # use this to supply a hint

    #
    # Enabling this will use the hfaxd-protocol to set Caller*ID
    #
    #ModemSetOriginCmd: AT+VSID="%s","%d"

    #
    # If "glare" during initialization becomes a problem then take
    # the modem off-hook during initialization, and then place it
    # back on-hook when done.
    #
    #ModemResetCmds: "ATH1\nAT+VCID=1" # enables CallID display
    #ModemReadyCmds: ATH0


    Class1AdaptRecvCmd: AT+FAR=1
    Class1TMConnectDelay: 400 # counteract quick CONNECT response

    Class1RMQueryCmd: "!24,48,72,96" # enable this to disable V.17

    #
    # You'll likely want Caller*ID display (also displays DID) enabled.
    #
    ModemResetCmds: AT+VCID=1 # enables CallID display

    #
    # If you are "missing" Caller*ID data on some calls (but not all)
    # and if you do not have adequate glare protection you may want to
    # not answer based on RINGs, but rather enable the CallIDAnswerLength
    # for NDID, disable AT+VCID=1 and do this:
    #
    #RingsBeforeAnswer: 0
    #ModemRingResponse: AT+VRID=1

    CallIDPattern: "NMBR="
    CallIDPattern: "NAME="
    CallIDPattern: "ANID="
    CallIDPattern: "NDID="
    #CallIDAnswerLength: 4
    # Uncomment these if you really want them, but you probably don't.
    #CallIDPattern: "DATE="
    #CallIDPattern: "TIME="
    FaxRcvdCmd: bin/faxrcvd.php
    UseJobTSI: true


    --------------------------------


    Log:
    Oct 07 11:51:02.54: [ 3758]: SESSION BEGIN 000000004 982188456738
    Oct 07 11:51:02.54: [ 3758]: HylaFAX (tm) Version 4.3.9
    Oct 07 11:51:02.54: [ 3758]: CallID: "111" "Secretary" "<NONE>" "s"
    Oct 07 11:51:02.54: [ 3758]: MODEM set XON/XOFF/FLUSH: input ignored, output disabled
    Oct 07 11:51:02.54: [ 3758]: <-- [4:ATA\r]
    Oct 07 11:51:06.26: [ 3758]: --> [7]
    Oct 07 11:51:06.28: [ 3758]: ANSWER: FAX CONNECTION DEVICE '/dev/ttyIAX1'
    Oct 07 11:51:06.28: [ 3758]: STATE CHANGE: ANSWERING -> RECEIVING
    Oct 07 11:51:06.28: [ 3758]: RECV FAX: begin
    Oct 07 11:51:06.32: [ 3758]: <-- HDLC<32:FF C0 04 B5 00 AA 12 9E 36 86 62 82 1A 04 14 2E B6 94 04 6A A6 4E CE 96 F6 76 04 2C 74 CC 74 9C>
    Oct 07 11:51:06.32: [ 3758]: <-- data [32]
    Oct 07 11:51:06.32: [ 3758]: <-- data [2]
    Oct 07 11:51:07.24: [ 3758]: --> [7]
    Oct 07 11:51:07.24: [ 3758]: <-- HDLC<23:FF C0 02 D6 4E F6 EE 2E A6 72 04 86 A6 26 92 04 36 86 AE 2E 4E 96 6A>
    Oct 07 11:51:07.24: [ 3758]: <-- data [23]
    Oct 07 11:51:07.24: [ 3758]: <-- data [2]
    Oct 07 11:51:07.56: [ 3758]: --> [10:NO CARRIER]
    Oct 07 11:51:07.56: [ 3758]: MODEM No carrier
    Oct 07 11:51:07.56: [ 3758]: DELAY 1500 ms
    Oct 07 11:51:09.06: [ 3758]: <-- [9:AT+FTH=3\r]
    Oct 07 11:51:09.06: [ 3758]: --> [5]
    Oct 07 11:51:09.06: [ 3758]: RECV FAX: RSPREC error/got EOT
    Oct 07 11:51:09.06: [ 3758]: RECV FAX: end
    Oct 07 11:51:09.06: [ 3758]: SESSION END
     
  6. li2

    li2

    Joined:
    Sep 6, 2009
    Messages:
    13
    Likes Received:
    0
    Does not give anyone the answer ?
     
  7. Lee Sharp

    Joined:
    Sep 28, 2010
    Messages:
    332
    Likes Received:
    0
    It looks like the fax is failing due to line quality. Try setting a sending fax machine to a very low baud rate and try again.
     
  8. trymes

    Joined:
    Aug 19, 2009
    Messages:
    228
    Likes Received:
    0
    Are you trying to receive faxes over SIP or another VOIP protocol?

    Tom
     
  9. li2

    li2

    Joined:
    Sep 6, 2009
    Messages:
    13
    Likes Received:
    0
    Currently trying to get my fax line is urban (pstn)
    I used the card port is openvox 8 (FXO).
    Fax is sent correctly, but had not received any fax
     
  10. DaveD

    Joined:
    Nov 12, 2007
    Messages:
    597
    Likes Received:
    0
    Try increasing the RX / TX gains on your card ,start at maybe 5.0 for RX and 2.0 for TX
    File is in /etc/asterisk

    chan_dahdi.conf

    faxdetect=incoming
    echotraining=800
    rxgain=5.0
    txgain=2.0
    callgroup=1
    pickupgroup=1
     
  11. li2

    li2

    Joined:
    Sep 6, 2009
    Messages:
    13
    Likes Received:
    0
    Unfortunately failed.


    Log >>>


    Oct 07 11:51:02.54: [ 3758]: SESSION BEGIN 000000004 9821--------
    Oct 07 11:51:02.54: [ 3758]: HylaFAX (tm) Version 4.3.9
    Oct 07 11:51:02.54: [ 3758]: CallID: "111" "Secretary" "<NONE>" "s"
    Oct 07 11:51:02.54: [ 3758]: MODEM set XON/XOFF/FLUSH: input ignored, output disabled
    Oct 07 11:51:02.54: [ 3758]: <-- [4:ATA\r]
    Oct 07 11:51:06.26: [ 3758]: --> [7]
    Oct 07 11:51:06.28: [ 3758]: ANSWER: FAX CONNECTION DEVICE '/dev/ttyIAX1'
    Oct 07 11:51:06.28: [ 3758]: STATE CHANGE: ANSWERING -> RECEIVING
    Oct 07 11:51:06.28: [ 3758]: RECV FAX: begin
    Oct 07 11:51:06.32: [ 3758]: <-- HDLC<32:FF C0 04 B5 00 AA 12 9E 36 86 62 82 1A 04 14 2E B6 94 04 6A A6 4E CE 96 F6 76 04 2C 74 CC 74 9C>
    Oct 07 11:51:06.32: [ 3758]: <-- data [32]
    Oct 07 11:51:06.32: [ 3758]: <-- data [2]
    Oct 07 11:51:07.24: [ 3758]: --> [7]
    Oct 07 11:51:07.24: [ 3758]: <-- HDLC<23:FF C0 02 D6 4E F6 EE 2E A6 72 04 86 A6 26 92 04 36 86 AE 2E 4E 96 6A>
    Oct 07 11:51:07.24: [ 3758]: <-- data [23]
    Oct 07 11:51:07.24: [ 3758]: <-- data [2]
    Oct 07 11:51:07.56: [ 3758]: --> [10:NO CARRIER]
    Oct 07 11:51:07.56: [ 3758]: MODEM No carrier
    Oct 07 11:51:07.56: [ 3758]: DELAY 1500 ms
    Oct 07 11:51:09.06: [ 3758]: <-- [9:AT+FTH=3\r]
    Oct 07 11:51:09.06: [ 3758]: --> [5]
    Oct 07 11:51:09.06: [ 3758]: RECV FAX: RSPREC error/got EOT
    Oct 07 11:51:09.06: [ 3758]: RECV FAX: end
    Oct 07 11:51:09.06: [ 3758]: SESSION END
     
  12. DaveD

    Joined:
    Nov 12, 2007
    Messages:
    597
    Likes Received:
    0
    Do you have the fax add on module for freepbx installed ?

    If not try installing it and configure it
     
  13. li2

    li2

    Joined:
    Sep 6, 2009
    Messages:
    13
    Likes Received:
    0
    All the steps for making fax did in previous versions I'd done and worked
    IAX2 made it a fax, I introduced
    It also built a virtual fax, and it made use of my IAX
    As I said is receiving faxes but not send.
    If certain settings freepbx or elastix please please announce
     
  14. li2

    li2

    Joined:
    Sep 6, 2009
    Messages:
    13
    Likes Received:
    0
  15. DaveD

    Joined:
    Nov 12, 2007
    Messages:
    597
    Likes Received:
    0
    If you are trying to fax with a fax plugged into FXS ,you will need to turn remove "echotraining" and echo cancel set to no on the extension.
     

Share This Page