Not only G711 codecs for extensions?

Discussion in 'General' started by sergeda, Jun 18, 2009.

  1. sergeda

    Joined:
    Jun 17, 2009
    Messages:
    2
    Likes Received:
    0
    Hi everybody.
    Can somebody help me with my problem.
    I've download and installed Elastix, created 2 internal sip extentions.
    I'm using eyeBeam and Zoiper to make a call between them and everything works. But only with G711 codec. If I select any other codecs in softphone configuration I've got error while making a call and in Asterisk logs "No compatible codecs, not accepting this offer!" line appeared.
    What should I do to allow other codecs for sip extentions?
    I was looking for this setting in web management part, but couldn't.
    If I should edit config files, please tell me wich.
     
  2. Mirko87

    Joined:
    Oct 20, 2008
    Messages:
    128
    Likes Received:
    0
    In the "Device Options" of the Extension, you'll see disallow and allow.
    For "disallow" write "all", and for "allow" write all the codecs split by a comma (alaw,g729,gsm).


    Regards,

    Mirko
     
  3. sergeda

    Joined:
    Jun 17, 2009
    Messages:
    2
    Likes Received:
    0
    Thank you a lot.
    This works for me.
     

Share This Page