Non PRI T1 groundstart not answering calls

Discussion in 'General' started by Baez, Jul 28, 2009.

  1. Baez

    Joined:
    Aug 9, 2008
    Messages:
    50
    Likes Received:
    0
    Hello,

    I installed Elastix 1.5.2 with Digium TE120 and configured for T1 d4,ami with groundstart signalling. As was configured with existing Panasonic PBX.

    I can make outgoing calls without any problem but, incoming calls are not recognized by TE120 or elastix.

    When I call to my T1 phone number it start to ring normally and in the asterisk CLI looks like no call is ringing and if I try to make an outgoing call from Elastix while the call is ringing on my phone (not from pbx) then it open channel and answer my incoming call.

    I was searching and I think maybe recompiling dahdi with CONFIG_CAC_GROUNDSTART can solve my problem, but I don't know how to recompile dahdi in elastix 1.5.2

    Can somebody help me with this?

    Thanks in advance.
     
  2. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    For a ground-start "supertrunk" you might need :

    immediate=yes

    in

    /etc/asterisk/chan_dahdi.conf

    you need to stop asterisk reload dahdi and restart asterisk for it to take effect.

    (you might want to check with your provider if it is indeed a GS trunk, that is not so common,loop-start is almost always a better way to go , (the provider can change the signalling, but look to CallerID provisioning (feat-d or bell) if you change, and far end disconnect supervision)

    Unfortunately there are far too many ways to skin a cat with traditional T1's.

    dicko
     
  3. Baez

    Joined:
    Aug 9, 2008
    Messages:
    50
    Likes Received:
    0
    Thanks Dicko,

    I tried with inmediate=yes and nothing.

    Customer don't want to change signalling because they want to have their current panasonic PBX as backup just in case. While they feel comfortable with Elastix. With Panasonic PBX the T1 works perfect.

    Panasonic is configured for ami, d4, groundstart. I can connect to panasonic using d4,ami and groundstart and I can talk to and from Elastix to and from Panasonic. (both ways) is just with telco T1 my problem.
     
  4. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    Do you have callerID on this trunk?, if so how is it sent?
     
  5. Baez

    Joined:
    Aug 9, 2008
    Messages:
    50
    Likes Received:
    0
    No callerID, No DID
     
  6. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    Then make sure those features are turned off (in the same file) . No DID. no spilled dtmf, so you need an anonymous inbound route defined. No CID, again no CID spill so asterisk might wait for it indefinitely.

    It is further possible that if you have sEcho Cancellation on, under your circumstances, it might break as the pulse will never get to the GS line until answered, (esoteric maybe, but there are some strange beasts in the TDM world)
     
  7. Baez

    Joined:
    Aug 9, 2008
    Messages:
    50
    Likes Received:
    0
    The problem is Asterisk don't recognize when T1 channel is ringing.
    I tried changing to signnaling fxsks and started to recognize incoming calls but then not outgoing calls work.

    I found how to recompile dahdi. I'll try with CONFIG_CAC_GROUNDSTART option.

    Thanks anyway.
     
  8. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    Let me know please, I'm intrigued!, good luck!
     

Share This Page