NO URL FOR ACCESS ELASTIX WEB GUI

FSInetworks

Joined
Jun 13, 2007
Messages
7
Likes
0
Points
0
#1
HI,

I have a blank in place of ip address after the message "FOR ACCESS TO THE ELASTIX WEB GUI USE THIS URL.
I installed Elastix 0.8.3 on two computers and I have same the problem on both.
the elastix's computer have an address ip and the ping to the other computer of my network functions.
But no WEB GUI with this address ip, may be the elastix's firewall ?
Have you an idea ?

Thanks
Fabien.
 

FSInetworks

Joined
Jun 13, 2007
Messages
7
Likes
0
Points
0
#2
I have the same problem with Elastix 0.8.2 ???
 

adminad

Joined
Apr 29, 2010
Messages
150
Likes
0
Points
0
#3
This is because you have not setted an IP.
 

FSInetworks

Joined
Jun 13, 2007
Messages
7
Likes
0
Points
0
#4
How to setted web gui ?

I can connect by putty on the elastix server.

A ifconfig command displays :

[root@localhost ~]# ifconfig
eth0 Link encap:Ethernet HWaddr 00:00:B4:BA:9A:D1
inet adr:192.168.1.102 Bcast:255.255.255.255 Masque:255.255.255.0
adr inet6: fe80::200:b4ff:feba:9ad1/64 Scope:Lien
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:106 errors:0 dropped:0 overruns:0 frame:0
TX packets:140 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
RX bytes:11265 (11.0 KiB) TX bytes:19514 (19.0 KiB)
Interruption:10 Adresse de base:0x1040

lo Link encap:Boucle locale
inet adr:127.0.0.1 Masque:255.0.0.0
adr inet6: ::1/128 Scope:H
 

FSInetworks

Joined
Jun 13, 2007
Messages
7
Likes
0
Points
0
#5
I reinstalled elastix, setted a ip during the installation , setted a gateway , disable IPV6 only IPV4 and disable the firewall.
I have always the same problem which i don't have with TRIXBOX.
 

gabriel

Joined
Jun 9, 2007
Messages
31
Likes
0
Points
0
#6
Can you please check if you have install mod_ssl on your computer? Try netstat -ntpl and see if you have port 443 TCP there if not you can do yum install mod_ssl and after that you do : service httpd restart.

Gabriel
 

FSInetworks

Joined
Jun 13, 2007
Messages
7
Likes
0
Points
0
#7
Gabriel thanks for you reply, but it is not resolved my problem.

The screen displays by putty connection

login as: root
root@192.168.1.200's password:
Last login: Sat Jun 16 09:32:57 2007 from 192.168.1.7

Welcome to Elastix
-------------------------------------------------

For access to the Elastix web GUI use this URL
http://

[root@asterisk ~]#

---------------------------------------------------

a command netstat -ntpl displays

[root@asterisk ~]# netstat -ntpl
Connexions Internet actives (seulement serveurs)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 0.0.0.0:993 0.0.0.0:* LISTEN 2088/cyrus-master
tcp 0 0 0.0.0.0:995 0.0.0.0:* LISTEN 2088/cyrus-master
tcp 0 0 0.0.0.0:902 0.0.0.0:* LISTEN 1568/rpc.statd
tcp 0 0 0.0.0.0:3306 0.0.0.0:* LISTEN 1948/mysqld
tcp 0 0 0.0.0.0:5038 0.0.0.0:* LISTEN 2228/asterisk
tcp 0 0 0.0.0.0:110 0.0.0.0:* LISTEN 2088/cyrus-master
tcp 0 0 0.0.0.0:4559 0.0.0.0:* LISTEN 2329/hfaxd
tcp 0 0 0.0.0.0:143 0.0.0.0:* LISTEN 2088/cyrus-master
tcp 0 0 0.0.0.0:111 0.0.0.0:* LISTEN 1543/portmap
tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN 2190/httpd
tcp 0 0 0.0.0.0:2000 0.0.0.0:* LISTEN 2088/cyrus-master
tcp 0 0 0.0.0.0:21 0.0.0.0:* LISTEN 1845/vsftpd
tcp 0 0 0.0.0.0:25 0.0.0.0:* LISTEN 2172/master
tcp 0 0 0.0.0.0:4445 0.0.0.0:* LISTEN 2524/perl
tcp 0 0 :::993 :::* LISTEN 2088/cyrus-master
tcp 0 0 :::9090 :::* LISTEN 2535/java
tcp 0 0 :::995 :::* LISTEN 2088/cyrus-master
tcp 0 0 :::110 :::* LISTEN 2088/cyrus-master
tcp 0 0 :::143 :::* LISTEN 2088/cyrus-master
tcp 0 0 :::2000 :::* LISTEN 2088/cyrus-master
tcp 0 0 :::22 :::* LISTEN 1794/sshd
tcp 0 0 :::443 :::* LISTEN 2190/httpd
[root@asterisk ~]#

I have port 443 TCP but i can do yum install mod_ssl
The server has installed 359 new packages.

After

[root@asterisk ~]# netstat -ntpl
Connexions Internet actives (seulement serveurs)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 0.0.0.0:993 0.0.0.0:* LISTEN 2091/cyrus-master
tcp 0 0 0.0.0.0:995 0.0.0.0:* LISTEN 2091/cyrus-master
tcp 0 0 0.0.0.0:905 0.0.0.0:* LISTEN 1571/rpc.statd
tcp 0 0 0.0.0.0:3306 0.0.0.0:* LISTEN 1951/mysqld
tcp 0 0 0.0.0.0:5038 0.0.0.0:* LISTEN 2229/asterisk
tcp 0 0 0.0.0.0:110 0.0.0.0:* LISTEN 2091/cyrus-master
tcp 0 0 0.0.0.0:4559 0.0.0.0:* LISTEN 2334/hfaxd
tcp 0 0 0.0.0.0:143 0.0.0.0:* LISTEN 2091/cyrus-master
tcp 0 0 0.0.0.0:111 0.0.0.0:* LISTEN 1546/portmap
tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN 2193/httpd
tcp 0 0 0.0.0.0:2000 0.0.0.0:* LISTEN 2091/cyrus-master
tcp 0 0 0.0.0.0:21 0.0.0.0:* LISTEN 1848/vsftpd
tcp 0 0 0.0.0.0:25 0.0.0.0:* LISTEN 2175/master
tcp 0 0 0.0.0.0:4445 0.0.0.0:* LISTEN 2527/perl
tcp 0 0 :::993 :::* LISTEN 2091/cyrus-master
tcp 0 0 :::9090 :::* LISTEN 2538/java
tcp 0 0 :::995 :::* LISTEN 2091/cyrus-master
tcp 0 0 :::110 :::* LISTEN 2091/cyrus-master
tcp 0 0 :::143 :::* LISTEN 2091/cyrus-master
tcp 0 0 :::2000 :::* LISTEN 2091/cyrus-master
tcp 0 0 :::22 :::* LISTEN 1797/sshd
tcp 0 0 :::443 :::* LISTEN 2193/httpd
[root@asterisk ~]#


I changed my Switch by a Hub. the problem is the same.

Fabien.
 

gabriel

Joined
Jun 9, 2007
Messages
31
Likes
0
Points
0
#8
Can you please do iptables -A INPUT -j LOG
after that you do tail -f /var/log/messages

and see if you have a firewall issue.

Also can you please do ifconfig eth0 and see if you get some errors there

See if the errors is 0
RX packets:435393504 errors:0 dropped:0 overruns:2 frame:0

also do httpd restart and see what you get

Gabriel
 

FSInetworks

Joined
Jun 13, 2007
Messages
7
Likes
0
Points
0
#9
The results are :

Welcome to Elastix
-------------------------------------------------

For access to the Elastix web GUI use this URL
http://

[root@asterisk ~]# tail -f /var/log/messages
Jun 17 09:32:27 asterisk avahi-daemon[2420]: Network interface enumeration compl eted.
Jun 17 09:32:27 asterisk avahi-daemon[2420]: Registering new address record for fe80::200:b4ff:feba:9ad1 on eth0.
Jun 17 09:32:27 asterisk avahi-daemon[2420]: Registering new address record for 192.168.1.200 on eth0.
Jun 17 09:32:27 asterisk avahi-daemon[2420]: Registering HINFO record with value s 'I686'/'LINUX'.
Jun 17 09:32:28 asterisk avahi-daemon[2420]: Server startup complete. Host name is asterisk.local. Local service cookie is 3622580616.
Jun 17 09:32:29 asterisk avahi-daemon[2420]: Service "SFTP File Transfer on aste risk" (/services/sftp-ssh.service) successfully established.
Jun 17 09:34:59 asterisk ntpd[1847]: synchronized to 193.225.14.161, stratum 2
Jun 17 09:34:59 asterisk ntpd[1847]: time reset -0.517344 s
Jun 17 09:34:59 asterisk ntpd[1847]: kernel time sync enabled 0001
Jun 17 09:38:24 asterisk ntpd[1847]: synchronized to 192.87.106.2, stratum 1



[root@asterisk ~]#
[root@asterisk ~]# iptables -A INPUT -j LOG
[root@asterisk ~]# tail -f /var/log/messages
Jun 17 09:57:32 asterisk kernel: IN=eth0 OUT= MAC=00:00:b4:ba:9a:d1:00:03:0d:0f:81:6f:08:00 SRC=192.168.1.6 DST=192.168.1.200 LEN=40 TOS=0x00 PREC=0x00 TTL=128 ID=22301 DF PROTO=TCP SPT=3644 DPT=22 WINDOW=65223 RES=0x00 ACK URGP=0
Jun 17 09:57:32 asterisk kernel: IN=eth0 OUT= MAC=00:00:b4:ba:9a:d1:00:03:0d:0f:81:6f:08:00 SRC=192.168.1.6 DST=192.168.1.200 LEN=92 TOS=0x00 PREC=0x00 TTL=128 ID=22302 DF PROTO=TCP SPT=3644 DPT=22 WINDOW=65223 RES=0x00 ACK PSH URGP=0
Jun 17 09:57:32 asterisk kernel: IN=eth0 OUT= MAC=00:00:b4:ba:9a:d1:00:03:0d:0f:81:6f:08:00 SRC=192.168.1.6 DST=192.168.1.200 LEN=92 TOS=0x00 PREC=0x00 TTL=128 ID=22303 DF PROTO=TCP SPT=3644 DPT=22 WINDOW=65171 RES=0x00 ACK PSH URGP=0
Jun 17 09:57:33 asterisk kernel: IN=eth0 OUT= MAC=00:00:b4:ba:9a:d1:00:03:0d:0f:81:6f:08:00 SRC=192.168.1.6 DST=192.168.1.200 LEN=92 TOS=0x00 PREC=0x00 TTL=128 ID=22304 DF PROTO=TCP SPT=3644 DPT=22 WINDOW=65119 RES=0x00 ACK PSH URGP=0

[root@asterisk ~]#
[root@asterisk ~]# ifconfig eth0
eth0 Link encap:Ethernet HWaddr 00:00:B4:BA:9A:D1
inet adr:192.168.1.200 Bcast:192.168.1.255 Masque:255.255.255.0
adr inet6: fe80::200:b4ff:feba:9ad1/64 Scope:Lien
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:238 errors:0 dropped:0 overruns:0 frame:0
TX packets:288 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
RX bytes:21755 (21.2 KiB) TX bytes:39796 (38.8 KiB)
Interruption:10 Adresse de base:0x1040

[root@asterisk ~]# httpd -k restart
httpd: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
[root@asterisk ~]#

I think the problem is on the level of the file of configuration of Apache.

I test that.

Fabien.
 

lek

Guest
#10
This is not a big issue. If you want to change the welcome message, please edit the file /etc/motd
 

gabriel

Joined
Jun 9, 2007
Messages
31
Likes
0
Points
0
#11
I am sorry you still have problems. Can you please check if you have under /etc/hosts

127.0.0.1 localhost.localdomain localhost

and try to start httpd service

service httpd restart

Gabriel
 

eboza

Joined
Mar 27, 2007
Messages
45
Likes
0
Points
0
#12
Hi FSInetworks,

When install Elastix, are you using any additional option?

If you are using, by example, "linux ide=nodma", try with "elastix ide=nodma". Thats only for versions before 0.8-4

- Edwin Boza
 

FSInetworks

Joined
Jun 13, 2007
Messages
7
Likes
0
Points
0
#13
I made the modifications but without results.

I replaced the files of httpd.conf and /etc/hosts by those of trixbox, without results.

On the other hand the problem is solved with the last version 0.8.4

Thank you with all for your assistance.

On the other hand A2billing is an old version.

Does there exist a version vmware?
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,915
Messages
130,920
Members
17,595
Latest member
feparra121
Top