No Sound on internal calls & out outgoing calls

Discussion in 'General' started by elastixphil, Apr 8, 2009.

  1. elastixphil

    Joined:
    Apr 8, 2009
    Messages:
    3
    Likes Received:
    0
    Hi
    I just installed Elastix 1.5 and can't get any sound on internal calls or outgoing calls.

    I have also setup a incoming truck when someone calls in there is sound both ways.

    Any help which points me in the right direction would be greatly appreciated.

    Thanks

    Phil
     
  2. elkabong

    Joined:
    Apr 1, 2008
    Messages:
    17
    Likes Received:
    0
    Is the Elastix box on a private LAN behind a NAT router or on a public IP?

    Have you made any changes to codecs?

    Can you check that both users are using the same codecs?

    For testing it would be good to set your phones/devices to use ulaw/alaw to eliminate any possible codec mismatching problems.

    regards,

    Errol
     
  3. elastixphil

    Joined:
    Apr 8, 2009
    Messages:
    3
    Likes Received:
    0
    Is the Elastix box on a private LAN behind a NAT router or on a public IP?

    Yes the box is behind a NAT router. Ports opened 5060, 10000 to 20000 UDP

    Have you made any changes to codecs?

    No

    Can you check that both users are using the same codecs?

    Yes the codecs are the same ulaw/alaw

    So far

    Calls to 1 internal phone from an external phone. No sound
    Calls to truck which links to the internal phone. Sound both ways.
    Calls to 2 external phones. No sound
     
  4. elkabong

    Joined:
    Apr 1, 2008
    Messages:
    17
    Likes Received:
    0
    Can you do this:

    Login to the Elastix box via ssh and goto the Asterisk CLI with the command:

    asterisk -rvvvvvvvvvvvv

    and issue the command 'logger rotate'

    CLI> logger rotate

    1. Register the phones

    2. Make a 30 second call

    3. Attach the log file called 'full' here from /var/log/asterisk/ and let me have a look.

    Do you mean calls between 2 external extensions?
     
  5. elastixphil

    Joined:
    Apr 8, 2009
    Messages:
    3
    Likes Received:
    0
    Yes thats 2 external phones.

    They just tested 2 phones on site (internal) and they worked fine
     
  6. elkabong

    Joined:
    Apr 1, 2008
    Messages:
    17
    Likes Received:
    0
    elastixphil wrote:

    Yes thats 2 external phones.

    They just tested 2 phones on site (internal) and they worked fine[/quote]

    On your firewall can you confirm that these ports are opened for both incoming and outgoing?

    5060 tcp&udp
    10000 - 20000 udp
     
  7. vlad

    Joined:
    Nov 15, 2007
    Messages:
    86
    Likes Received:
    0
    Check it the Elastix Firewall, disabled all rules with:

    /etc/init.d/iptables stop
     

Share This Page