No sangoma setup guide - Sangoma site obsolete

Discussion in 'Gateways' started by arrow1, Jan 4, 2011.

  1. arrow1

    Joined:
    Nov 21, 2010
    Messages:
    89
    Likes Received:
    0
    I have noticed that Sangoma site has very obsolete guides, rpm-s, etc for Elastix.
    Is that because they prefer Trix o side. I don't mind hardware, once installed properly
    very stable, and Sangoma tech are very polite and if they can they help.

    Can't complain at all for Sangoma; however there is no clear setup guide with step by step installation.

    I am trying to install A101 T1 one port card with Elastix 1.6 - "12" stable.

    1. First thing what I did is:

    yum update that shows 310 Mb updates ready for that version
     
  2. arrow1

    Joined:
    Nov 21, 2010
    Messages:
    89
    Likes Received:
    0
    well just encountered first problem:

    set_rtc_mmss:can't update from 59 to 0


    seems ntpdate -u time.nist.gov resolved that problem
     
  3. fmvillares

    Joined:
    Sep 8, 2007
    Messages:
    1,785
    Likes Received:
    0
    Re: Re:No sangoma setup guide - Sangoma site obsolete

    well im one of the sangoma guys here in lat america and working closely with shaunt moises and doug villim....first of all if you cant compile software by hand you can not use an open source pbx because you dont how to fix the 90% of the trivial problems...
    using sangoma drivers has 2 parts...
    1 download and compile digium dahdi driver for the kernel you have in your system...and is applicable to elastix centos trixbox debian etc....
    2 download wanpipe driver from sangoma site...and execute ./Setup dahdi...and voila follow the instructions...

    in the wanpipe tgz and dahdi tarball there are easy step by step readmes also....and sangoma has one ot the best wikis in the market...
     
  4. arrow1

    Joined:
    Nov 21, 2010
    Messages:
    89
    Likes Received:
    0
    [root@elastix wanpipe-3.5.11.7]# wanrouter start

    Starting WAN Router...
    Loading WAN drivers: wanpipe done.
    Starting up device: wanpipe1


    wanconfig: Interface w1g1 setup failed
    : ioctl(ROUTER_IFNEW,w1g1) failed:
    : 22 - Invalid argument

    Wanpipe drivers could not setup network interface
    Please check /var/log/wanrouter and
    /var/log/messages for errors

    Configuring interfaces: w1g1 w1g1: unknown interface: No such device

    done.
    Waiting for Dahdi /dev/dahdi .................................

    Error: Dahdi device failed to come up
    Possible Cause: UDEV not installed!


    [root@elastix wanpipe-3.5.11.7]#
    [root@elastix wanpipe-3.5.11.7]#
    [root@elastix wanpipe-3.5.11.7]# wanrouter hwprobe

    -------------------------------
    | Wanpipe Hardware Probe Info |
    -------------------------------
    1 . AFT-A101u : SLOT=1 : BUS=5 : IRQ=169 : CPU=A : PORT=PRI : V=24

    Card Cnt: A101-2=1

    [root@elastix wanpipe-3.5.11.7]#
     
  5. arrow1

    Joined:
    Nov 21, 2010
    Messages:
    89
    Likes Received:
    0
    I have downloaded fallowing files:

    dahdi-linux-2.2.0.2.tar.gz
    wanpipe-3.5.11.7.tgz

    untared and compiled .....

    wanconfig: Interface w1g1 setup failed
    : ioctl(ROUTER_IFNEW,w1g1) failed:
    : 22 - Invalid argument

    this is the only problem at this time
     
  6. fmvillares

    Joined:
    Sep 8, 2007
    Messages:
    1,785
    Likes Received:
    0
    aha ...so??? you are using ancient old drivers that has tremendous amount of problems in elastix because wancfg_dahdi its broken...download new ones compile and you will see
     
  7. fmvillares

    Joined:
    Sep 8, 2007
    Messages:
    1,785
    Likes Received:
    0
    why did you download those drivers from 1 year ago...
    the latest and correct ones are 2.3.0.1 in dahdi (2.4 has echo issues) and 3.5.18
    and the correct kernel in centos 5.5 is 2.6.18.194.26.1
     
  8. arrow1

    Joined:
    Nov 21, 2010
    Messages:
    89
    Likes Received:
    0
    OK will be downloading latest Elastix 32 bits stable from Elastix site and download the newest dirvers pointed by fmvillares.

    Thank You fmvillares. I will reply once I download and install Elastix 32 bit latest stable ISO.


    The side question If I had Elastix 2.0.3 should I also download the same driver version?

    Sorry for that question but it clarify my doubts.

    Thank You
     
  9. fmvillares

    Joined:
    Sep 8, 2007
    Messages:
    1,785
    Likes Received:
    0
    Re: Re:No sangoma setup guide - Sangoma site obsolete

    i did not say that you download a new elastix.....i only said that you have to download and compile new drivers ...only 20 megs ....2 files only.........not the entire elastix distro...please read correctly...
     
  10. arrow1

    Joined:
    Nov 21, 2010
    Messages:
    89
    Likes Received:
    0
    Thank you for reply. Downloading the newest distro from palosanto web has its purpose.

    It is only 20 minutes whole process of downloading and installing on the server with additional 10 minutes of 325MB of updates not a big deal.

    Regarding question "why did you download those drivers from 1 year ago..." - they were installed by Sangoma tech and the distro was from 2009. I am starting from new distro Elastix 1.6 stable downloaded on 01/04/2011 and updated on 05 with 325 MB of updates.
    This should be also guide for a people who are new to Elastix and have Sangoma A101 that is still I believe very popular. If not meybe it is time for a new card. Sometimes it is better to start over than fix and figure it out what was messed or broke over 1 year.

    Regards,

    John
     
  11. arrow1

    Joined:
    Nov 21, 2010
    Messages:
    89
    Likes Received:
    0
    Installing Elastix with the latest ISO, then updating with yum updates (about 325M.

    Next using default drivers that comes with Elastix 1.6.2-27 (dahdi and wanpipe)
    casues KERNEL PANIC !!!!!!!!!!! Can't simply shuthdown and reboot. Unloading wanpipe during startup is the only way to operate Elastix 1.6

    This is very old problem with "kernel panic" and some Sangoma card. My card A101u belongs to them, and since long time that issue has not been resolved by Palosanto. Morover,
    Elastix 2.0.3 has the same problem. I don't understand why Palosanto does not updates letest Sangoma drivers into their repos so the life would be much easier.

    Summaring: Default Samgoma drivers that comes with Elastix 1.6.2-27 cased kernel panic with Sangoma A101u T1 board.

    Next step is downloading drivers from ftp:Sangoma and Dahdi from Elastix.org

    wanpipe-3.5.18.tgz and dahdi-2.3.0.1-3.src.rpm
     
  12. MST

    MST

    Joined:
    Sep 25, 2009
    Messages:
    317
    Likes Received:
    0
    Yeap If I am not wrong wanpipe-3.5.14 comes default with Elastix repo and caused kernel panic ......

    I had the same problem with my board and the only solution was updating wanpipe and dahdi to the newest ones or just older (STABLE, as they were tested) New does not mean tested or checked ..... :) it might comes that new has more bugs and issues than really old good working drivers .... just my 2 cents

    Cheers,

    MST
     
  13. fmvillares

    Joined:
    Sep 8, 2007
    Messages:
    1,785
    Likes Received:
    0
    Re: Re:No sangoma setup guide - Sangoma site obsolete

    1.6 is the same has the same old drivers from almost a year ago and remember asterisk 1.4 is at 4 months to the end of life and support...try 2.0 fully upgraded...has 3.5,17 latest precompilled rpm drivers working...but again i prefer to compile my own crap always
     

Share This Page