no route to destination

Discussion in 'General' started by tempworld, Nov 28, 2007.

  1. tempworld

    Joined:
    Nov 28, 2007
    Messages:
    4
    Likes Received:
    0
    Hi,

    I've installed Elastix on a LAN box with IP address "192.168.1.200", and added a VOIP trunk and an extension (107). However, I can't register from any softphone I've tried. For example, Zoiper returns the following error:

    13:10:59 Registering user '107@192.168.1.200'
    13:11:00 Failed registration for '107@192.168.1.200' with cause 'no route to destination'

    Does anyone know if there's something I'm doing wrong?
    Thanks for any help given.

    Regards,
    tw
     
  2. DaveD

    Joined:
    Nov 12, 2007
    Messages:
    597
    Likes Received:
    0
    Firewall would be a good guess as to your problem
     
  3. tempworld

    Joined:
    Nov 28, 2007
    Messages:
    4
    Likes Received:
    0
    Thanks for your reply.
    I initially thought it might have something with firewall configuration, but running "lokkit" everything shows up disabled and running "iptables -L" also shows that nothing is being blocked. Also, I'm only accessing the Elastix box with LAN computers, so I'm a bit clueless here. I'm not a Linux expert, so there must be anything that I'm missing.
    Any other possibilities?
     
  4. DaveD

    Joined:
    Nov 12, 2007
    Messages:
    597
    Likes Received:
    0
    If your using windows pc's for the soft phones check windows firewall
     
  5. tempworld

    Joined:
    Nov 28, 2007
    Messages:
    4
    Likes Received:
    0
    Thanks for that Dave. Unfortunately, even with firewall disabled on the client PCs the error is still the same. We also have a 3CX PBX installation on our LAN and every client can connect to it.
    Are there any other options?
    Thanks.
     
  6. Eham

    Joined:
    Nov 16, 2007
    Messages:
    42
    Likes Received:
    0
    Can you ping 192.168.1.200 from the Windows PC? Can you ping the Windows PC from the Elastix box? Are you sure both the Elastix box and your PC live within the same network/subnet mask?

    Try turning IPTABLES off with:

    service iptables stop

    Also try using a different Softphone. I use XLite just fine!
     
  7. tempworld

    Joined:
    Nov 28, 2007
    Messages:
    4
    Likes Received:
    0
    Thank you for your reply Eham.

    Everything is pinging right and they are on the same network. I disabled the IPTABLES service with no luck.
    So after installing X-Lite I tried to see if I was configuring it right and I came by this tutorial:

    http://www.asterisktutorials.com/videos ... intro.html

    I was doing everything right, except for the fact that on the extension configuration in FreePBX, NAT was set to "no" whereas it should be "never".
    Now everything works!

    Thanks for all the help given.
     

Share This Page