no puedo actualizar mi version 1.0-15?

Discussion in 'Elastix 2.x' started by asneider, May 5, 2009.

  1. asneider

    Joined:
    Feb 7, 2009
    Messages:
    160
    Likes Received:
    0
    buenos dias amigos tengo instalada la version 1.0-15 con la opcion yum -y update y tampoco con yum groupupdate "Elastix Core" me da un error y no se logra actualizar como puedo hacer??????
     
  2. jcastellanos

    Joined:
    Feb 10, 2009
    Messages:
    2,404
    Likes Received:
    0
    que error te arroja?
     
  3. asneider

    Joined:
    Feb 7, 2009
    Messages:
    160
    Likes Received:
    0
    a ver el error que me sale es el siguiente :


    [root@elastix /]# yum groupupdate "Elastix Core"
    Loading "installonlyn" plugin
    Setting up Group Process
    Setting up repositories
    Could not retrieve mirrorlist http://mirrorlist.centos.org/?release=5 ... po=contrib error was
    [Errno 4] IOError: <urlopen error (-3, 'Temporary failure in name resolution')>
    Error: Cannot find a valid baseurl for repo: contrib
    [root@elastix /]#


    y si intento actualizaaar todo desde yum -y update me sale el mismo error a que se debe eso?
     
  4. jcastellanos

    Joined:
    Feb 10, 2009
    Messages:
    2,404
    Likes Received:
    0
    en el modulo de actualizacion del elastix, en el apartado de repositorios, cuales tienes seleccionados?
     
  5. asneider

    Joined:
    Feb 7, 2009
    Messages:
    160
    Likes Received:
    0
    amigo tengo un problema sabes que la clave por defecto de elastix es admin palosanto yo de gracioso le cambie la clave de administrador y la deje telenet y asneider y ahora no puedo entrar al elastix me deja entrar es por el entorno web pero de freepbx no de elastix dime como lo puedo arreglar es que no se desde que parte de freepbx ver los repositorios a los cuales tengo agregados gracias por tu ayuda
     
  6. jcastellanos

    Joined:
    Feb 10, 2009
    Messages:
    2,404
    Likes Received:
    0
    si admin admin no te funciona, intenta con el usuario y contraseña root (usuario "root" pass (el que pusiste cuando instalaste)
     
  7. asneider

    Joined:
    Feb 7, 2009
    Messages:
    160
    Likes Received:
    0
    no amigo probe todo eso y nada de nada no se que hacer
     
  8. jcastellanos

    Joined:
    Feb 10, 2009
    Messages:
    2,404
    Likes Received:
    0
    bueno, en donde le has movido????? tocaste algun archivo del elastix? si no dunciona con admin, admin, no root y pass?? derias entrar asi.

    saludos
     
  9. asneider

    Joined:
    Feb 7, 2009
    Messages:
    160
    Likes Received:
    0
    aver lo que paso fue lo siguiente en el modulo de elastix hay una parte donde tu creas los usuarios con id y pass ok el que viene por defecto es admin palosanto pero yo lo cambie a telenet y el pass es asneider pero no se por que no me deja entrar
     
  10. jgutierrez

    Joined:
    Feb 28, 2008
    Messages:
    5,737
    Likes Received:
    0
    Te recomiendo que hagas una instalación limpia, ya que han habido grandes cambios desde la versión 1.0 hasta la 1.3 y la 1.5 (kernel, freepbx, estructura de las tablas, entre otras).

    Para que no tengas problemas, haz una instalación limpia.
    Ahora que si quieres bajarte la configuración de tus extensiones, no lo hagas con el backup/restore, ya que cuando lo intentes subir en la versión nueva del elastix, habrán varios casos de incompatibilidad (debido a los cambios que te comenté).

    No me recuerdo si en esa versión ya existe el extension batch, si es así, te podrías bajar la configuración y el listado de tus extensiones. En el caso que no lo tengas, te recomendaría que que te bajes la info de la base de datos, y luego la prepares en un csv y la subas a través del extension batch del nuevo Elastix
     
  11. asneider

    Joined:
    Feb 7, 2009
    Messages:
    160
    Likes Received:
    0
    ok entonces nesecito saber que version me sirve para tener extenciones sip, iax, e1, t1, conexion entre servidores asterisk (elastix), extenciones remotas a traves de la vpn, fax, que no tenga problema con discos sata y todo el resto de jugentes que trae esta central


    me podrias ayudar con tu experiencia a decidirme por una version que no tenga tanto problema

    a por cierto tengo una tarjeta ax100p lal cual la usamos para pruebas
     
  12. ramoncio

    Joined:
    May 12, 2010
    Messages:
    1,663
    Likes Received:
    0
    Cualquier versión vale para eso. Usa la última y tendrás mejor soporte para hardware y más funcionalidades extras.

    Para cambiar la password de admin tienes que ejecutar esta línea en la consola de línux (gracias a Dicko, yo lo hacía editando /var/www/db/acl.db con un programa externo y era mucho más lento):

    Code:
    /usr/bin/sqlite3 /var/www/db/acl.db "UPDATE acl_user SET md5_password = '`echo -n newpassword|md5sum|cut -d ' ' -f 1`' WHERE name = 'admin'"
    
    cambiando newpassword por la contraseña que quieras. Ojo, es todo en 1 línea.
     
  13. jcastellanos

    Joined:
    Feb 10, 2009
    Messages:
    2,404
    Likes Received:
    0
    que buen detalle ramoncio, gracias,a muchos nos va a ser util :)
     

Share This Page