No more choppy sound in VMWARE!

Joined
Apr 30, 2008
Messages
2
Points
0
I use Elastix 1.0 (VMWare Image) image and have choppy sound.
(AVR etc...) My way to relolve this problem:

Code:
cd /usr/src
wget http://dev.centos.org/~tru/kernel-vm/5/RPMS/i386/kernel-vm-2.6.18-53.1.4.el5.i686.rpm
wget http://dev.centos.org/~tru/kernel-vm/5/RPMS/i386/kernel-vm-devel-2.6.18-53.1.4.el5.i686.rpm
rpm -ivh kernel-vm*.rpm
Reboot, select kernel-2.6.18-53.1.4.el5vm from the Grub menu.

Code:
cd /usr/src
wget http://downloads.digium.com/pub/zaptel/zaptel-1.4.10.tar.gz
tar zxvf zaptel-1.4.10.tar.gz
cd zaptel-1.4.10
make & make install
No more choppy sound!<br><br>Post edited by: vlad_, at: 2008/04/30 14:20
 
Joined
Oct 24, 2007
Messages
25
Points
0
Hello vlad_

after I compiled the zaptel module and loaded it, I got this error:
Loading zaptel framework: [ OK ]
Waiting for zap to come online...OK
Loading zaptel hardware modules: ztdummy.
Running ztcfg: ioctl(ZT_LOADZONE) failed: Invalid argument
Notice: Configuration file is /etc/zaptel.conf
line 13: Unable to register tone zone 'us'
ZT_DEFAULTZONE failed: Invalid argument (22)
I made some research on the Internet in regard this problem and I found this thread
http://lists.digium.com/pipermail/asterisk-dev/2004-December/008231.html
. Did you get this error and how you resolved it? Thanks in advanced! Rikolen<br><br>Post edited by: rikolen, at: 2008/05/07 16:34
 
Joined
Oct 24, 2007
Messages
25
Points
0
Sorry! I loaded the wrong kernel, now
Loading zaptel framework: [ OK ]
Waiting for zap to come online...OK
Loading zaptel hardware modules: ztdummy.
Running ztcfg: [ OK ]
[root@elastix zaptel-1.4.10]# uname -r
2.6.18-53.1.4.el5vm
and everything is working perfectly.
 
Joined
Apr 30, 2008
Messages
2
Points
0
Hello!
I make vmware image (Elastix 1.0-17 + vm kernel + zaptel-1.4.10.1)

EDonkey link -
ed2k://|file|elastix_Elastix 1.0-17_vmvare_nano.rar|590757099|00000000000000000000000000000000|/<br><br>Post edited by: vlad_, at: 2008/06/16 10:12
 
Joined
Aug 2, 2008
Messages
7
Points
0
:( i give up, after 12 hours i cant find an working solution to get elestix work correctly with vm ware server on an windows2003 sbs. every thing works fine, even MOH but when i get the voicemail i keep ketting the choppy sound :( have tried different vm ware version, changed all setting and the options in this post and more.

so please if someone has an good and working solution please help me...... i installed it on an new windows 2003sbs fromm dell, amd dual 2,3 with 4 gb memory and 750 gb diskspace in 2 drives. vm ware has 1 gig memory for only the elastix server and 8 gb harddisk space. why does it still not work coorectly :(

thnx

ps is the elastix vmware version 1.1 but trixbox has the same problem but i want elastix!)
 
Joined
May 12, 2010
Messages
1,663
Points
0
Microsoft has the solution!
I know it's hard to believe, but now it works ok.

Have a look here:

http://support.microsoft.com/kb/918461

You need to add

acpi=off noapic nosmp nolapic clock=pit

at the end of the line in /boot/grub/menu.lst where the kernel loads.
I have tried it in a couple of machines and now the sound is ok.
 
Joined
Jun 22, 2008
Messages
17
Points
0
Did you try the new kernel like they recommend? I thought the elastix kernel was tweaked by the elastix crew. Is it safe to switch the kernels ?
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,987
Messages
131,100
Members
17,716
Latest member
Orbit114
Top