No ingoing and call reports

telecomtechnician

Joined
Jan 8, 2008
Messages
422
Likes
0
Points
16
#1
Hi there, I have done a few tests with agents (receiving calls) but I do not see the reports,only 00:00:00. How can I configure that?

Waiting for your comments

David Medina
 

voipc

Joined
Nov 21, 2008
Messages
5
Likes
0
Points
0
#2
Same here with me. I wonder if it has something to do with the location of the database /var/www/db/campaign.db which is commented in /opt/elastix/dialer/dialerd.conf?

If this is the database where all records are kept, how can it be activated, because it is not available in /var/www/db/

Thanks,
Steve
 

voipc

Joined
Nov 21, 2008
Messages
5
Likes
0
Points
0
#3
Ok, I guess I was too soon with my post. I actually see my reports now...

And I saw that everything is saved in the mysql database call_center on localhost with asterisk/asterisk as login.

Steve
 

telecomtechnician

Joined
Jan 8, 2008
Messages
422
Likes
0
Points
16
#4
Hi Steve

Can you explain a little more what you did? how did you login, what you changed

Thanks

David Medina
 

voipc

Joined
Nov 21, 2008
Messages
5
Likes
0
Points
0
#5
I did not change anything. Because I tested around midnight, I think I filtered on the next day. So I just saw that the report were there on the previous day...

You can check if you have records in the mysql tables as follows:

mysql -u asterisk -pasterisk call_center

and then:

select * from call_entry;

for the list of inbound calls.

Regards,
Steve
 

telecomtechnician

Joined
Jan 8, 2008
Messages
422
Likes
0
Points
16
#6
hi again

Did the asterisk/asterisk login you did, was through the configuration menu on the call center module in the elastix web interfase or through the linux console?
 

voipc

Joined
Nov 21, 2008
Messages
5
Likes
0
Points
0
#7
Through the linux console that was. You should see your agent call record details then.

Steve
 

telecomtechnician

Joined
Jan 8, 2008
Messages
422
Likes
0
Points
16
#8
Hi Steve
When you access to the configuration menu on the call center module in the elastix web interfase, what login/password you put in the box that are on the left? or you leave it in blank?. By the way I did the consult on the mysql database and appears nothing:
select * from call_entry;
Empty set (0.00 sec)
 

voipc

Joined
Nov 21, 2008
Messages
5
Likes
0
Points
0
#9
Hi David,

For me that was:

login: admin
pass: elastix456

You can see your details in /etc/amportal.conf under AMPMGRUSER and AMPMGRPASS

(it's probably a good idea to change these default values ;)

Steve
 

telecomtechnician

Joined
Jan 8, 2008
Messages
422
Likes
0
Points
16
#10
Hi Steve,

I logged in how you mentioned and everything went fine.

Thank you

David Medina
 

telecomtechnician

Joined
Jan 8, 2008
Messages
422
Likes
0
Points
16
#11
I missed something

Hi Steve

I am not seeing the reports from the call center module again. I updated everything on my IPPBX through yum update.

Can you or anybody explain in much more detail, how to make the reports come alive?

Waiting for your comments
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,915
Messages
130,920
Members
17,594
Latest member
knethardsolutions
Top