No incoming calls German ISDN Elastix 2

Discussion in 'Gateways' started by hansdinges, Sep 2, 2010.

  1. hansdinges

    Joined:
    Oct 31, 2009
    Messages:
    5
    Likes Received:
    0
    hello,

    i made a fresh install of a Elastix 2 Box. I have two HFC ISDN cards installed.

    pci:0000:00:08.0 zaphfc+ 1397:2bd0 HFC-S ISDN BRI card
    pci:0000:00:09.0 zaphfc+ 1397:2bd0 HFC-S ISDN BRI card


    outgoing calls work perfect with different trunks and outbound routes.
    But asterisk -vvvr does not write any line if a call comes in and no extension is ringing.

    any ideas?

    tank you very much...
     
  2. james.zhu

    Joined:
    Feb 13, 2008
    Messages:
    99
    Likes Received:
    0
    please check the incoming routing and prefix.
     
  3. hansdinges

    Joined:
    Oct 31, 2009
    Messages:
    5
    Likes Received:
    0
    yes, i have a inbound route set to:

    Edit Incoming Route
    Description: MyRoute
    DID Number: xxxxxxxx (one of the multiple subscriber number)

    Options:
    CID name prefix: <blank> (do i need that?)


    Set Destination:
    Extensions: 409 (a grandstream BT which works outgoing)

    I have a second ELASTIX 1.6 which uses misdn and works fine (in and out)
    is it right that ELASTIX 2.0 uses DAHDI? Is there something special to configure? special type of signalling or context?

    thanks
     
  4. tstav

    Joined:
    Nov 13, 2009
    Messages:
    19
    Likes Received:
    0
    Problem solved
    If you probably have a plain ISDN line, like myself, that is a point-to-multipoint configuration then,
    you have to edit /etc/dahdi/genconf_parameters and add the ptmp parameter to the signaling style

    bri_sig_style bri_ptmp

    Also you have to add the same parameter to the /etc/asterisk/dahdi_channels.conf

    signalling = bri_cpe_ptmp

    Tassos
     
  5. hansdinges

    Joined:
    Oct 31, 2009
    Messages:
    5
    Likes Received:
    0
    Thank you very much!
    That’s it!!
     
  6. deggial

    Joined:
    Oct 5, 2010
    Messages:
    5
    Likes Received:
    0
    Hello,
    would you like to please help me configuring my elastix system so that i could make outbound and inbound calls?

    We have an ISDN line from German Telekom, a FritzBox 7170 router, and Elastix server with an ISDN Card with HFC-S and 3 Client PC's connected to the router with softphones installed on them.

    I could have configure them so that they could call each other internally, however I couldn't bring them neither to do outbound nor inbound calls :((

    I don't know where am I doing wrong but I think it is with the Trunk settings and Outbound and Inbound Routes.

    As I understand you are also in Germany and you know it with German conditions, could you please give me a few tipps?

    Thank you very much,
    With my best regards,
    Yordanov.
     
  7. hansdinges

    Joined:
    Oct 31, 2009
    Messages:
    5
    Likes Received:
    0
    hallo,
    can you post them here?
    "Trunk settings and Outbound and Inbound Routes"
     
  8. deggial

    Joined:
    Oct 5, 2010
    Messages:
    5
    Likes Received:
    0
    Hallo,
    Trunk settings are:

    Code:
    ZAP Trunk (DAHDI Compatibility Mode)
    Trunk Description: ZAP Channel g0
    Outbound Caller ID: "Twin Brain" <0211 758467-00>
    CID Options: Allow Any CID
    Maximum Channels:
    Dial Rules:
    (empty)
    Zap Identifier (trunk name): 1
    
    Outbound Rules:
    Code:
    Route Name: Disa
    Dial Patterns: 9|NXXX.
    Trunk Sequence: 0 ZAP/1
    I haven't yet done the Inbound Rules.
     
  9. deggial

    Joined:
    Oct 5, 2010
    Messages:
    5
    Likes Received:
    0

Share This Page