No CID, DID Match (Elastix 1.6)

Discussion in 'General' started by jag_lin, Feb 18, 2010.

  1. jag_lin

    Joined:
    Feb 18, 2010
    Messages:
    1
    Likes Received:
    0
    Hi All,

    I am running Elastix 1.6 on my machine.

    Here is a brief description of my hardware:

    1 X OpenVox A800P Card

    Modules & Configuration:

    3 X FXO Modules ( Connected to PSTN Lines)
    5 X FXS Modules ( Connected to POTS Phone Extensions)

    Essentially 3 PSTN lines will be aggregated to 2 Ring groups & 1 Extension will be setup for my office.

    I have been following installation instructions from elastix without tears.
    I have so far as part of testing, created the following:

    2 Trunks for 2 of the PSTN lines.
    2 Extensions for testing to my POTS phones.

    Outbound routes for each of the extensions have also be created.

    Everything works great, i can call out on the appropriate trunk and all, however i encountered problems when i tried calling in. On the asterisk console, i get a no "CID or DID Match" when a call comes in, i am very sure i specified the correct DID on my incoming route but yet it still indicates a DID mis-match.

    So i tested by setting up a catch-all inbound route and it works great.
    However this is not going to work with what i have in mind, so i looked through my configurations and changed the context from 'from-pstn' to 'from-zaptel' in :
    chan_dahdi.conf & dahdi-channels.conf, but it still did'nt work ( even with restarting the server as well as services)

    Really hoping someone here can get me going in the right direction, i have redone the installation twice and it is still the same.

    Thanks!
     

Share This Page