Newbie questions

Discussion in 'General' started by Marko, Aug 27, 2008.

  1. Marko

    Aug 26, 2008
    Likes Received:

    Firstly let me thank you all for creating and supporting this great software.

    I am new to VoIP and I want to learn as much as I can.

    Relevant information
    I have 2 extensions set up (internaly all works great):
    - softphone (ZOIPER)
    - hardphone (belcin model: BCIP-300)
    I am from Slovenia (Europe - EU) - code +386.
    I am using ISO instalation (Elastix 1.1-8).

    I understand how to set up outbound routes but I am having trouble setting up trunks.

    In the outbound routes setup I entered "9" as a dial pattern. If I understand correctly, now I must enter number "9" before entering any other number after. This tells this route to be used and its selected trunk.
    The problem is that after I enter a number i wish to dial (with 9 before), i dont get any connection, no sound. Just silence and a text on the phone saying connecting.
    Is there a log I can see to know what is wrong?

    In the trunk setup screen I setup:
    - outbound caler id
    - trunk name
    - peer details (can sbd tell me what types can i write except the "peer")
    - user context
    - register string (is there a comma(".") at the end of a string or not?)

    I also closed my firewall on router so I could see if any outbound routes would be made, but there is no action. It seems like the PBX doesnt know I wish to make external call over my SIP account.

    Thanks for you help!
  2. busster8

    Apr 13, 2008
    Likes Received:
    the dial 9 is related to outbound routes, not trunks. Your sip provider might always need 10 digits, so you might insert the local area code. Some providers need a "+" sign infront. This is where you insert or remove digits. Is your sip trunk registered? Before you start worrying about dial patterns, make sure your trunks are registered. From Asterisk CLI, type sip show peers. Think FOP will also show if the trunks are registered.

Share This Page