Newbee IVR issue

rhwebhosting

Joined
Nov 4, 2008
Messages
8
Likes
0
Points
0
#1
ok I installed Elastix 1.3-2, after reading the tutorials, managed to get Avantfax working, have my trunks working, its all good, but I get off my lazy ... to setup the IVR, and for a test i simply use press 1 for accounting press 2 for billing. In the IVR i set 1 to go to ext 1000 and 2 to go to 1001. I dial in, and the menu comes up fine, when I press 1 or 2, the recording keeps going and does not recognize my input. Anyone can point me in the right direction on what im missing?
 

danardf

Joined
Dec 3, 2007
Messages
8,069
Likes
10
Points
88
#2
Warning to the DTMF mode into your trunk (RFC2833 or other) or maybe your codec, or RTP port?
 

nachogomez

Joined
Sep 11, 2008
Messages
65
Likes
0
Points
0
#3
As danardf said, maybe you are using DTMF inband and you are using a codec different from ulaw or alaw (maybe gsm or some compressed audio codec).

Are you checking this IVR from a SIP/IAX phone or a analog phone???
 

rhwebhosting

Joined
Nov 4, 2008
Messages
8
Likes
0
Points
0
#4
its coming through the sip trunk, its using ulaw/alaw
I am a total newb what is DTMF
 

nachogomez

Joined
Sep 11, 2008
Messages
65
Likes
0
Points
0
#5
DTMF (Dual Tone MultiFrecuency) is the way the system sends the audio through your call. If you use dtmfmode=inband it will send the tones in form of audio. If you are using any compressed audio codec like gsm or g729, then this tones get distorted and your system doesn't understand it.

In your trunk setup set dtmfmode=rfc2833 in both peer and user settings and try again, if this not resolve your problem try with dtmfmode=info and let us know what happen.

See this link for further reading http://www.voip-info.org/wiki-Asterisk+sip+dtmfmode
 

aacm

Joined
Sep 22, 2008
Messages
16
Likes
0
Points
0
#6
The DTMF are the tones of the phone, there are different kinds of protocols to send the tones from your phone (hard or soft phone) to the system, some times are different and the system do not recognize those and do nothing.
 

rhwebhosting

Joined
Nov 4, 2008
Messages
8
Likes
0
Points
0
#7
dtmfmode=rfc2833
is what its set at as it is, frustrating lol, I had everything working under adminsparadise, but was convinced to try elastix. It looks like a great system, generally easy to setup, the IVR is now the only thing that has me miffed atm
 

rhwebhosting

Joined
Nov 4, 2008
Messages
8
Likes
0
Points
0
#8
now is where it is getting odd, from a sip extention the IVR works fine, but when i call from an outside pstn it doesnt work
 

danardf

Joined
Dec 3, 2007
Messages
8,069
Likes
10
Points
88
#9
What's your trunk parameter?
 

rhwebhosting

Joined
Nov 4, 2008
Messages
8
Likes
0
Points
0
#10
here is what i have entered into it, i dont know where to pull a full cut and paste from

trunk name: colo

host=166.70.xxx.xxx
canreinvite=no
type=peer
username=username
secret=xxxxxx

USER Context: username

user details

type=peer
insecure=5060
context=from-pstn
canreinvite=no
secret=xxxxxxxx

registration string: username:secret@166.70.xxx.xxx/username

my incoming sip # is from IPKall
set as sip
ip: machine IP
proxy: machine IP
 

danardf

Joined
Dec 3, 2007
Messages
8,069
Likes
10
Points
88
#11
Try to add some bold information:

trunk name: colo

host=166.70.xxx.xxx
canreinvite=no
type=peer
username=username
secret=xxxxxx
insecure=very
disallow=all
allow=alaw
allow=ulaw
dtmfmode=rfc2833


USER Context: username

user details

type=peer
insecure=very
context=from-pstn
canreinvite=no
secret=xxxxxxxx
Use the good codec (alaw, ulaw or other).
 

rhwebhosting

Joined
Nov 4, 2008
Messages
8
Likes
0
Points
0
#12
still no dice, but i also now realize when i set an inbound route, it doesnt work with anything except any DID/any CID
 

danardf

Joined
Dec 3, 2007
Messages
8,069
Likes
10
Points
88
#13
You use a FXO adaptator ou a SIP Operator?

Change your dtmfmode rfc2833 by info for try.

else, try to put this configuration:

trunk name: colo

host=166.70.xxx.xxx
context=from-pstn
canreinvite=no
type=peer
username=username
secret=xxxxxx
insecure=very
disallow=all
allow=alaw
allow=ulaw
dtmfmode=info


Don't setting.:

USER Context: blank
user details
blank


If you put a context into outbound , you can receive the incoming call.
 

rhwebhosting

Joined
Nov 4, 2008
Messages
8
Likes
0
Points
0
#14
I tried that, the calls come in fine, its just when i set an inbound route, it doesnt work, only works when set for any did/ any cid
and the IVR doesnt recognize the keytones
 

nachogomez

Joined
Sep 11, 2008
Messages
65
Likes
0
Points
0
#15
Since you are using ulaw/alaw maybe the option you need to try for DTMF is "dtmfmode=inband". Check this an let us know if it works...

Nacho
 

nachogomez

Joined
Sep 11, 2008
Messages
65
Likes
0
Points
0
#16

rhwebhosting

Joined
Nov 4, 2008
Messages
8
Likes
0
Points
0
#17
well i figured out the inbound issue its not sending a callid only the ip, i fixed the settings at ipkall and now the inbound routing works.
however it still doesnt recognize the numbers in the IVR
tried with no success
dtmfmode=info
dtmfmode=inband
 

lowno

Joined
May 28, 2008
Messages
9
Likes
0
Points
0
#18
Wow, I have the same problems with inbound DTMF tones one my IVR. It's crazy because I have the same version of elastix on identical hardware, the same SIP carrier and one works perfect and the other doesn't work at all. It's also the same internet provider. CRAZY. I'm very discouraged by this.

On Sunday I am going to just replace the hardware and see if that fixes the problem.
 

danardf

Joined
Dec 3, 2007
Messages
8,069
Likes
10
Points
88
#19
I have tried the IVR, one more time and it's good for me. :huh:

Ask to your operator where the problem come from!
What DTMF mode you can used.
 

lowno

Joined
May 28, 2008
Messages
9
Likes
0
Points
0
#20
To follow up with everyone. I found out what my problem was. It was the rate center the DID was at. I provisioned a different DID and it worked perfectly.
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,902
Messages
130,887
Members
17,567
Latest member
achilont13
Top