new elastix 1.6 problem

sarados

Joined
Feb 11, 2007
Messages
18
Likes
0
Points
0
#1
Hi all
I have installed 1.6 stable with two zaphfc single port carts and everything seems to work fine . I am using Odicha's work and everything seems to work fine . The only problem is that one telephne connection every ten-fifteen doesnot behave correctly . I dial a number and nothing happens . I wait for more than 30 seconds . I close the phone , i redial the same number and i am connected OK. For 19-15 calls everything is working fine , incoming outgoing calls everything is ok . The same problem happens sometimes with incoming calls : there is a call after IVR we hear the phone ringing , we pickup and nothing happens . We cant hear the other side and the other side doesnot hear us . I dont now how to debug this problem . any help ?
 

ramoncio

Joined
May 12, 2010
Messages
1,663
Likes
0
Points
0
#2
Have a look at the logs in /var/log/asterisk/full. grep for ERROR or error.
You can enable debug of a span # with 'pri intense debug span #' from an asterisk console.
Have a look in asterisk-es-rsp mailing list, there was a bug in dahdi that had problems with certain numbers/providers, but I think they already comminted the patch into the svn. Ask in the list.
 

sarados

Joined
Feb 11, 2007
Messages
18
Likes
0
Points
0
#3
Hi Ramoncio
As i dont speak spanish is it possible to be more specific about the date or article in asterisk-es . I am trying to follow but google translation from spanish to english does not help . is there any possibility that this problem can be from kernel version . I had a similar installation with older kernel and the problem was almost non existent . One call per 100 had a problem for the outgoing and almost never for the incoming .
Thanks
 

sarados

Joined
Feb 11, 2007
Messages
18
Likes
0
Points
0
#4
I found this issue that details something similar to my problem .

https://issues.asterisk.org/view.php?id=14031

At the end of the list Odicha proposes something that probably solves the issue , but i cannot understand if there is a solution included inside elastix 1.6 .
 

sarados

Joined
Feb 11, 2007
Messages
18
Likes
0
Points
0
#5
I think i found the solution .

http://groups.google.es/group/asterisk- ... 0a18a51651

But somebody has to verify , because i dont speak spanish as to be sure 100% , and somebody has to check version of odicha work inside elastix . Sorry my linux is not enough to change just this .
 

ramoncio

Joined
May 12, 2010
Messages
1,663
Likes
0
Points
0
#6
Yes, that might be your problem, there is a bug with the zaphfc driver in some versions of the svn.
He says he will commit his patch this weekend, if possible.
After that, you will need to download asterisk-es-rsp from their svn, compile, and install over your current Elastix installation. I can help you on that.
I'll also talk to Alex, so he can upgrade Elastix's packages ASAP.
I will keep you informed here.
 

sarados

Joined
Feb 11, 2007
Messages
18
Likes
0
Points
0
#7
Hi Ramoncio
judjing from the dates of messages of the last thread i ve found and posted , i dont now the version of Odicha work that has been intergrated inside Elastix . Is it possible to to indicate a solution or something to do for solving this problem . I dont know how to make the latest Odicha SVN inside Elastix 1.6

Thanks in advance
 

sarados

Joined
Feb 11, 2007
Messages
18
Likes
0
Points
0
#8
Sorry , i didnt show your responce on time . Is it possible to indicate what to download from Odicha work, and how to integrate . I thing that a detail howto can help to intergrate better their work for chan_sebi too . Both works are in evolution so small problems can be more easilly solved
Thanks again
 

rafael

Joined
May 14, 2007
Messages
1,454
Likes
1
Points
0
#9
I'll also talk to Alex, so he can upgrade Elastix's packages ASAP.
ramoncio, did you create a ticket in http://bugs.elastix.org ? this is the best way to go so that Alex or someone else in the devel team fix the issue
 

sarados

Joined
Feb 11, 2007
Messages
18
Likes
0
Points
0
#10
I have created a new ticket No 0000187 . I hope ive done it correctly and that it is clear
 

Amphibian

Joined
Sep 8, 2009
Messages
1,128
Likes
2
Points
38
#11
I too am having simular prob since I did a clean installed to the latest stable 1.6.xx 32 version. The only dif is that I use sip with softphones.

About every fourth to fifth call does not complete. I looked at logs and it shows sending it to voip provider and then seems to hang. On incoming calls it seem to be about every tenth call does not make it thru. I can see it enter, shows extension then just "hangs".

If I reboot server then we start over till the next hang.

Any suggestion would be helpful.
 

sarados

Joined
Feb 11, 2007
Messages
18
Likes
0
Points
0
#12
Hi , it has only to do with an error from Odicha's work after revision 127 . check the sites mentioned above at the end of the spanish text . I dont know wich version elastix is using for 1.6 . Ramonchio any news about this issue , did odicha found the error , elastix developers have a sugestion , maybe a detailed howto to intergrate sources from Odicha to elastix without breaking elastix asterisk instllation with the SRPMS .
thanks
 

ramoncio

Joined
May 12, 2010
Messages
1,663
Likes
0
Points
0
#13
Amphibian said:
I too am having simular prob since I did a clean installed to the latest stable 1.6.xx 32 version. The only dif is that I use sip with softphones.

About every fourth to fifth call does not complete. I looked at logs and it shows sending it to voip provider and then seems to hang. On incoming calls it seem to be about every tenth call does not make it thru. I can see it enter, shows extension then just "hangs".

If I reboot server then we start over till the next hang.

Any suggestion would be helpful.
Amphibian, but are you using a zaphfc card? This is what this thread is about, not sip issues.


sarados said:
Hi , it has only to do with an error from Odicha's work after revision 127 . check the sites mentioned above at the end of the spanish text . I dont know wich version elastix is using for 1.6 . Ramoncio any news about this issue , did odicha found the error , elastix developers have a sugestion , maybe a detailed howto to intergrate sources from Odicha to elastix without breaking elastix asterisk instllation with the SRPMS .
sarados, I've been reading more carefully the thread in asterisk-es-rsp, and that problem looks to be different. They can't call or receive calls at all, not like your system.

Could you capture full asterisk logs and 'pri intense debug span x' and search for the errors?
Or post them here, so we can have a look at them.

I don't know which revision of Odicha's svn has been used in Elastix, maybe Alex, Rafael or Bruno can help you to find that out.
 

sarados

Joined
Feb 11, 2007
Messages
18
Likes
0
Points
0
#14
Hi the problem has two different symptoms .
A . incoming call , we hear ringing to the group , we see the calling number , we peak up the phone (one from theringing group ) and we hear nothing . The calling party continues to hear the calling tone ( we checked the last sometimes by calling back the other party and asking for details.
B . sometimes we call an existing number that we now that it is working , we hear nothing . if we continuously try to call the same number five six times the same happens . We do nothing than wait may be 5 minutes, we try again calling the same number and everything works fine .

As you can understand the error is not constant . So it is very difficult to grab the debugging for this problematic call . Logs from the pri span as long we watched them there is nothing different from the normal calls . We will continue to check the problem and post here everything we can find .
A good help for us could be to now the elastix version of odicha's work and a howto for intergrating odicha work with elastix using the SRPM .
Thanks Ramoncio for the help, we are working only with ISDN and this issue is a problem .
 

ramoncio

Joined
May 12, 2010
Messages
1,663
Likes
0
Points
0
#15
What you can do is to enable debug for a whole day and tell them to take note of the exact times when the errors happen. Then you can search the logs for those times and see what you can find there.
 

Amphibian

Joined
Sep 8, 2009
Messages
1,128
Likes
2
Points
38
#16
Sorry, I guess I didn't read it right.
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,915
Messages
130,920
Members
17,595
Latest member
feparra121
Top