Need Help with Voicemails Online

Discussion in 'General' started by Jeff.H, Feb 28, 2010.

  1. Jeff.H

    Joined:
    Feb 27, 2010
    Messages:
    3
    Likes Received:
    0
    Hi, I am a recent Switchvox convert and have played with trixbox, AsteriskNOW, PBX in a Flash and a few others.... so far I seem to like Elastix the best but I have one last thing that is driving me crazy.

    I read EWT and found where I had to edit the proper file to change the URL that is sent in email notifications but when I edit it to use my own host name it says that the page cannot be found.

    http://jeffh.homeip.net/recordings/index.php is what was in the etc/asterisk/vm-email.inc file other than putting my host name, its the same.

    I have even put just the local IP in place of the FQDN and tried to access it from a machine on the same physical subnet, same thing, no good.

    I only have two extensions set up right now for testing and so far everything else is working.

    Thanks!

    Jeff
     
  2. nedicz

    Joined:
    Jul 5, 2009
    Messages:
    9
    Likes Received:
    0
    Hi Jeff

    Have you changed following:
    Page 113, EWT
    "To overcome this, I have to edit the /etc/postfix/main.cf file to include the following;
    relayhost = mail.optusnet.com.au
     
  3. Jeff.H

    Joined:
    Feb 27, 2010
    Messages:
    3
    Likes Received:
    0
    Hi, Thanks for the reply, but I have no problem with the emails actually getting sent. This is what it looks like by default right after install.....

    Jeff Desk,

    There is a new voicemail in mailbox 300:

    From: "House Line" <200>
    Length: 0:04 seconds
    Date: Saturday, February 27, 2010 at 03:12:07 PM

    Dial *98 to access your voicemail by phone.
    Visit http://AMPWEBADDRESS/recordings/index.php to check your voicemail with a web browser.


    And this is what the look like after I modified the etc/asterisk/vm-email.inc file

    House Line,

    There is a new voicemail in mailbox 200:

    From: "Jeff Desk" <300>
    Length: 0:04 seconds
    Date: Saturday, February 27, 2010 at 06:16:20 PM

    Dial *98 to access your voicemail by phone.
    Visit http://jeffh.homeip.net/recordings/index.php to check your voicemail with a web browser.

    The problem I am having is that the link itself is comes back with The requested URL /recordings/index.php was not found on this server. Either the link is not pointing to the right place, or I possibly need to make some other config change to enable where its pointing to.

    The EWT PDF that I have shows page 113 as talking about filtering incoming calls and the URL it does give on page 122 shows Visit http://pbx.familyhealth.com:8080/cgi- bin/vmail.cgi?action=login&mailbox=201. If I try that URL substituting my own server with or without port 8080 I still get the same error above.
     
  4. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    You might want to edit (and read) /etc/amportal.conf, and the proper setup of /var/www/html/recordings (other posts here)
     
  5. Jeff.H

    Joined:
    Feb 27, 2010
    Messages:
    3
    Likes Received:
    0
    OK I got it working, seems the _asterisk dir was missing.

    Now one more question. Is there a way to have it send to more than one email address? For example I have one ext (200) that is a Grandstream HT502 ATA for our wireless base station and 4 handsets. This is what we use for our general house line and I would like it to be able to email both me and my wife when someone leaves a voicemail as well as include the WAV file. The pager option is nice, but it does not include the WAV file.
     
  6. jm68896

    Joined:
    Mar 10, 2010
    Messages:
    1
    Likes Received:
    0
    Hello Jeff.H - I have the same identical problem you had encountered where the link in the email (modified with the correct IP) results in "The webpage cannot be found". Can you provide details on how you fixed? At this point, I'm not sure whether /recordings/index.php or /cgi-bin/vmail.cgi?action=login&mailbox=3301 is the correct link. Thanks.
     

Share This Page