Need help setting up trunk with new provider

JohnyBeGood

Joined
May 18, 2008
Messages
134
Likes
0
Points
0
#1
Hi,

So I got DID (inbound only) and I tried to follow their guide http://xrl.us/ovstp
I think I've entered everythig right up to the point on the very bottom where it says "Please, make sure you have defined extensions within a context [from-didww] in extensions.conf,"
I'm not sure where to enter it. I've tried calling my new DID and I can see in CLI that calls comes in.
I've setup inbound route to go to Phonebook directory
" -- Playing 'pbdirectory/welcome-to-phonebook' (escape_digits=) (sample_offset 0)
pbdirectory: start loop
pbdirectory: loop = 0
-- <SIP/204.11.194.38-b760e558> Playing 'pbdirectory/first-three-letters-entry' (language 'en')
"
but on my end all what I hear is ringing like no one picked up.
If I setup URI forward instead of "Custom Mapping" all calls go thru first time.

Here's the screenshot of my trunk setup.


 

nachogomez

Joined
Sep 11, 2008
Messages
65
Likes
0
Points
0
#2
I think the settings that shows on the link http://xrl.us/ovstp are for outgoing calls, not incoming calls, since you are defining peers here (type=peer) not users. Try changing type=peer for type=user and see what happen.

Although this web site said that this configs are for incoming I'm pretty sure that this is for outgoing calls in deed.
 

JohnyBeGood

Joined
May 18, 2008
Messages
134
Likes
0
Points
0
#3
Thanks for the reply!

Actually, this is inbound only, international DID that forwards all calls that come to my Elastix box.

I haven't changed anything else beside entering all of those trunk information (two to be exact, not all for the US) I had back and forth emails with the DID provider and I proved them that using their DID test page calls are working just fine http://www.didww.com/service_did.php
I'm convinced that issue was on their end.
 

Members online

Forum statistics

Threads
30,951
Messages
130,979
Members
17,653
Latest member
najwa
Top