Need help for installing usb nic drivers

Discussion in 'General' started by fareedf, Sep 28, 2008.

  1. fareedf

    Joined:
    Sep 28, 2008
    Messages:
    1
    Likes Received:
    0
    I installed Elastix 1.2 on a laptop with usb nic (Moschip mcs7830) but I don't know how to install the nic drivers, I have downloaded the drivers and extracted but don't know what to do next. here is info from usb nic. lsusb -> Bus 001 Device 002: ID 9710:7830 MosChip Semiconductor and extracted files are: Makefile, mcs7830.c, mcs7830.h, mosinstall, mosuninstall, readme and couple release notes.


    I was able to use Saleh instruction for an on-board Realtech nic for another person with a bit of modification but the last command runs to snag, here is his instruction

    # tar vjxf r8101-1.009.00.tar.bz2
    # cd r8101-1.009.00
    # make clean modules (as root or with sudo)
    # make install
    # depmod -a
    # insmod ./src/r8101.ko

    You can check whether the driver is loaded by using following commands.

    # lsmod | grep r8101
    # ifconfig -a


    after # make install
    I received error message:

    mcs7830: unknown symbol generic_mii_ioctl
    insmod: error inserting
    '/lib/modules/2.6.18-53.1.19.e15/kernel/drivers/usb/serial/moschip/mcs7830.ko': -1 Unknown symbol in module

    when I run lsmod | grep mcs7830 here is the result
    mcs7830 23056 0
    mii 9409 1

    and when I ran ifconfig -a now I see usb0 Link encap:Ethernet HW 00:13:......
    but no ip address.
     

Share This Page