Nat problem

mirbaha

Joined
Sep 20, 2010
Messages
2
Likes
0
Points
0
#1
Dear friends,

im a ip telephony provider and i provide ip telephony service i use free x-lite for my users but i have too many problem with users behind the NAT its one way communication for them, any one can help or any suggestion?
 

ahmershuja

Joined
Jan 15, 2010
Messages
26
Likes
0
Points
0
#2
I had same problem with my remote extension, its Linksys PAP2T ATA, call was receiving with good quality sound, but cannot dial or hear the ring from that extension.

how i fixed that:
open those port range into the router and redirect to that computer which is xlite is installed...

SIP 5060 - 5061
RTP 10000 - 20000

and you will be ok
good luck
 

andyshawn

Joined
Apr 3, 2009
Messages
113
Likes
0
Points
0
#3
You can also use an iax softphone and have your clients connect this way. IAX only use one UDP port (4569).
This protocol works better with NAT, hence you will have less of those one way audio problems. There are a couple of free iax softphones available, so you can try them out and see if this helps.
 

andyshawn

Joined
Apr 3, 2009
Messages
113
Likes
0
Points
0
#4
If none of these options resolved your problem, then provide a more detail description of how your server is setup? It is connected directly to the internet or behind a NAT device? Is it behind a firewall? How many of your users are experiencing the one way audio problem? Is the one way audio intermittent or does it happen on every call?
 

trymes

Joined
Aug 19, 2009
Messages
228
Likes
0
Points
0
#5
If your server is behind NAT, you need to configure the server's NAT settings. Once that has been done, you shouldn't really have to worry about NAT unless you have multiple clients/user/extensions behind the same NAT device.
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,902
Messages
130,887
Members
17,565
Latest member
omarmenichetti
Top