MWI on IP650

Discussion in 'IP Phones' started by galaxy, Jan 4, 2011.

  1. galaxy

    Joined:
    Jun 22, 2010
    Messages:
    42
    Likes Received:
    0
    OK, I've been banging my head for days now. I've tried searching and trying all the suggestions I could find. Magically, MWI started working on one of my phones, so I decided to get this working on all the phones.

    There's 2 people with voicemail, one of which has 2 mailboxes on two of the extensions on one of the phones. So I would like to get the message light working when there is mail in either of the mailboxes on one phone, and when there's mail in one of the extensions on the other phone.

    In the sip.cfg I've set the user_preferences so that up.oneTouchVoiceMail="0" (and I tried "1"), and up.mwiVisible="0" (and also tried "1").

    For each of the phones, I've changed the per-phone config to include:

    <msg msg.bypassInstantMessage="1">
    <mwi
    msg.mwi.1.subscribe="2101" msg.mwi.1.callBackMode="contact" msg.mwi.1.callBack="*97"
    msg.mwi.2.subscribe="" msg.mwi.2.callBackMode="disabled" msg.mwi.2.callBack=""
    msg.mwi.3.subscribe="2103" msg.mwi.3.callBackMode="contact" msg.mwi.3.callBack="*97"
    msg.mwi.4.subscribe="" msg.mwi.4.callBackMode="disabled" msg.mwi.4.callBack=""
    msg.mwi.5.subscribe="" msg.mwi.5.callBackMode="disabled" msg.mwi.5.callBack=""
    msg.mwi.6.subscribe="" msg.mwi.6.callBackMode="disabled" msg.mwi.6.callBack="" />
    </msg>

    and the other has:

    <msg msg.bypassInstantMessage="1">
    <mwi
    msg.mwi.1.subscribe="2111" msg.mwi.1.callBackMode="contact" msg.mwi.1.callBack="*97"
    msg.mwi.2.subscribe="" msg.mwi.2.callBackMode="disabled" msg.mwi.2.callBack=""
    msg.mwi.3.subscribe="" msg.mwi.3.callBackMode="disabled" msg.mwi.3.callBack=""
    msg.mwi.4.subscribe="" msg.mwi.4.callBackMode="disabled" msg.mwi.4.callBack=""
    msg.mwi.5.subscribe="" msg.mwi.5.callBackMode="disabled" msg.mwi.5.callBack=""
    msg.mwi.6.subscribe="" msg.mwi.6.callBackMode="disabled" msg.mwi.6.callBack="" />
    </msg>


    I've also tried msg.bypassInstantMessage="0" for both.

    For the first phone (with 2 mailbox extensions on it), I can go to the Messages menu and see the correct number of urgent/new/old message counts on the first extension, but the other extension shoes all zeroes. For the second phone, it shows all zeroes for the message counts.

    I've also tried adding "@default" to the subscribe value, which doesn't seem to make a difference.

    I'm using Elastix 1.6.2-7 (asterisk 1.4.33.1).
    The phones are Polycom IP650 with Bootblock 2.7.0 BootROM 4.1.2.0037.

    Do I need to upgrade Elastix (and/or asterisk)?
     
  2. fmvillares

    Joined:
    Sep 8, 2007
    Messages:
    1,785
    Likes Received:
    0
    first of all your firmwares are old as hell in the polycom...but thats not critical...you need to download the manuals and understand all the xml options in the polycom repository files to accomplish the goal ...if you read the xml manuals you will see the simplicity...
     
  3. galaxy

    Joined:
    Jun 22, 2010
    Messages:
    42
    Likes Received:
    0
    Yes, I have the manuals and have read them. I've done a lot of customizations in the files on the tftp server and have things working great for almost a year. It seems the MWI should be pretty easy according to the manuals. Its just not working as documented, which is why I posted to begin with. I really try to avoid asking questions on things that should be this simple.

    But this is why I posted to the forums. I've tried the obvious, and I've tried other combinations. I had used the bootrom software downloaded with one of the "combined" SIP packages, but will try updating it to the latest.
     
  4. galaxy

    Joined:
    Jun 22, 2010
    Messages:
    42
    Likes Received:
    0
    Updated to BootROM 4.3.0.0246 but didn't help. I found that since I have some Polycom 601's, that when I installed the old SIP bundle (3.1.6) it downgraded all the bootrom code too.

    I guess I need to try updating elastix & asterisk. I've read that other folks had problems with asterisk 1.4 and MWI.
     
  5. fmvillares

    Joined:
    Sep 8, 2007
    Messages:
    1,785
    Likes Received:
    0
    ok lets try this...do you have a line saying extension@default in extensions config? if you restart your asterisk box the vm light suddenly goes on?
     
  6. galaxy

    Joined:
    Jun 22, 2010
    Messages:
    42
    Likes Received:
    0
    Nope, nothing like 2101@default.
    Are you talking about the "mailbox" attribute?
    It appears all the mailboxes are of the form: extension@device in sip_additional.conf
    The VM context is "default" (which is what I see in voicemail.conf).

    Note that on one phone (which has 4 extensions on it, 2 of which have mailboxes), the MWI light works properly only for the first extension, and restarting asterisk will get the light going on if that mailbox has a new message (but not the other mailbox on the 3rd extension).
     
  7. fmvillares

    Joined:
    Sep 8, 2007
    Messages:
    1,785
    Likes Received:
    0
    you need to have xxx@default in every line...do you have upgraded elastix asterisk module because are several bugs involving voicemail and mwi since that old ages..asterisk is right now on 1.4.39 ...and i have none of that problems in any of my systems
     
  8. galaxy

    Joined:
    Jun 22, 2010
    Messages:
    42
    Likes Received:
    0
    that's what I suspected. I'm on asterisk 1.4.33.
    I'll do an upgrade and pray it doesn't break...
     
  9. galaxy

    Joined:
    Jun 22, 2010
    Messages:
    42
    Likes Received:
    0
    can you recommend what I should back up before doing a yum update?
     
  10. fmvillares

    Joined:
    Sep 8, 2007
    Messages:
    1,785
    Likes Received:
    0
    you need to always do a backup previous to any upgrade...as a failsafe...not because its unsafe
     
  11. galaxy

    Joined:
    Jun 22, 2010
    Messages:
    42
    Likes Received:
    0
    Did the upgrade, no joy...
    Lost my trunks on FOP, but finally found the fix again...

    I'm on asterisk 1.4.36 now, latest bootrom, latest SIP, elastix 1.6.2-27.

    Really strange...

    I do see my XML changes are taking place. When I enable one or more msg.mwi entries and reboot the phone, they appear on the list when you press the Messages button. And when you select one, it does the callback function (i.e. *97). But it doesn't look like its subscribing. In the "subscribe" parameter I'm putting the extension number in there. I've tried adding and then removed the "@default" and "@device", but still doesn't seem to subscribe (at least on one of the phones, and on the second extension of the other phone).

    I'd like to find where I should be finding the extension@default lines...
     
  12. galaxy

    Joined:
    Jun 22, 2010
    Messages:
    42
    Likes Received:
    0
    Got it...

    I went through sip_additional.conf and replaced all the:

    mailbox=ext@device

    with

    mailbox-ext@default

    and it magically started working for everything as expected.
    Not sure where the @device came in, but has to do with an earlier version of elastix I suppose.
     
  13. fmvillares

    Joined:
    Sep 8, 2007
    Messages:
    1,785
    Likes Received:
    0
    freepbx and elastix backup...but in that ages also elastix 1.6 has backup problemms too...and if you cant make a manual backup or you dont know how to backup try it in test environment first to learn
     
  14. astinjack

    Joined:
    Apr 15, 2011
    Messages:
    1
    Likes Received:
    0
    Hi All ,
    Actually i am searching information about Polycom IP 650P product of VoIP . so can i get any information about this product from here.
     
  15. jgutierrez

    Joined:
    Feb 28, 2008
    Messages:
    5,737
    Likes Received:
    0
    I will suggest taht you go to polycom web site, there you will be able to get as much infomration as you need. And if you have any particualr question polycom with elastix you may ask it here.

    lmgtfy.com/?q=polycom+650
     

Share This Page