music on hold is killing asterisk

Discussion in 'General' started by striderec, Dec 13, 2009.

  1. striderec

    Joined:
    Nov 25, 2008
    Messages:
    105
    Likes Received:
    0
    Greetings,

    Yesterday, I tried to create a new music on hold category called "christmas" (for the well known reasons) and i uploaded 6 mp3s that the system converted to WAV files to be used for that purpose.

    When I tried to apply the configuration, I noticed that it took longer than the usual. Finally, I got a blank screen in my browser, like if something failed. After a minute or something, I could refresh the screen but I saw the configurations were not applied. I tried the same process a couple of times more and same results.

    Finally, I went to the CLI to debug a possible problem and there's when I noticed that when FreePBX/Elastix tries to apply the new changes, the musiconhold process KILLS asterisk and leaves. Of course asterisk restarts normally but the Elastix and FreePBX shows that the configurations were not applied. In fact, the FreePBX GUI shows these two critical errors:

    # Critical Error retrieve_conf failed, config not applied
    Reload failed because retrieve_conf encountered an error: 1
    Added 3 hours, 36 minutes ago
    (freepbx.RCONFFAIL)
    # Critical Error Failed to get engine_info

    The output of the CLI is the following:

    == Parsing '/etc/asterisk/features_featuremap_custom.conf': Found
    -- Added extension '70' priority 1 to parkedcalls
    -- Reloading module 'res_odbc.so' (ODBC Resource)
    == Parsing '/etc/asterisk/res_odbc.conf': Found
    -- Reloading module 'res_musiconhold.so' (Music On Hold Resource)
    == Parsing '/etc/asterisk/musiconhold.conf': Found
    == Parsing '/etc/asterisk/musiconhold_custom.conf': Found
    == Parsing '/etc/asterisk/musiconhold_additional.conf': Found
    Beginning asterisk shutdown....
    Executing last minute cleanups
    == Destroying musiconhold processes
    masterpbx*CLI>
    Disconnected from Asterisk server
    /usr/sbin/safe_asterisk: line 125: 6032 Killed nice -n $PRIORI
    TY ${ASTSBINDIR}/asterisk -f ${CLIARGS} ${ASTARGS} >&/dev/${TTY} < /dev/${TTY}
    Asterisk ended with exit status 137
    Asterisk exited on signal EXITSTATUS-128.
    [root@masterpbx ~]# Automatically restarting Asterisk.

    Is there anyone who could help me with this? All I wanted is add a new category for Christmas Season and I ended up with some Christmas nightmare, hahahaha.

    By the way, the versions of my box are:

    CentOS: 5.4
    Elastix: 1.5.2-2.3
    FreePBX: 2.5.2.2
    Asterisk: 1.4.26.1
    mpg123: 1.10.0 (I use this for streaming audio categories. This was working well before the creation of the new music on hold category)

    Thank you all for your help before hand

    - Paul
     

Share This Page