MPlayer always working

mostafa33

Joined
May 25, 2010
Messages
121
Likes
0
Points
16
#1
i created a steaming MOH , and played it using Mplayer
but the problem is the stream is always working on the elastix machine, i wants to play it in the music on hold only.

how can i stop it??
 

fmvillares

Joined
Sep 8, 2007
Messages
1,785
Likes
0
Points
0
#2
if it streaming need to be running always ni back...imagine the scenario when a client enter the system and the buffer needs t be populated every time with for example 8 secs that is 8 secs of silence every time people call ....
 

mostafa33

Joined
May 25, 2010
Messages
121
Likes
0
Points
16
#3
i didn't mean the buffering process of the software, the problem is the elastix system always send the MOH on the speakers of the machine, which is strange as the MOH is targets the holding users in a queue for example ,i wants to stop this sound (may the Mplayer running the buffering process in background)
 

fmvillares

Joined
Sep 8, 2007
Messages
1,785
Likes
0
Points
0
#4
Re: Re:MPlayer always working

do u have aplied all the acnges? mplayer is called bia /usr/bin commands in correct music category? music category is selected in destinations?? example queue conferences etc?
 

mostafa33

Joined
May 25, 2010
Messages
121
Likes
0
Points
16
#5
Re: Re:MPlayer always working

i use the following command in the MOH to play my stream:

/usr/local/bin/mplayer http://208.43.81.168:8613
 

fmvillares

Joined
Sep 8, 2007
Messages
1,785
Likes
0
Points
0
#6
Re: Re:MPlayer always working

ohh yeah and the conversions to be reproduced in the elastix box??? aka mono 8000hz etc...
 

mostafa33

Joined
May 25, 2010
Messages
121
Likes
0
Points
16
#7
Re: Re:MPlayer always working

not understanding you, do u think the command needs a certain option?
 

fmvillares

Joined
Sep 8, 2007
Messages
1,785
Likes
0
Points
0
#8
Re: Re:MPlayer always working

as far as i know always....this is a correct line using mpg123
application=/usr/local/bin/mpg123 -q -r 8000 -f 8192 -s --mono http://213.186.41.160:8000/

..join the new list asterisk-biz-hands-on in google groups where all the gurus here are going after dickos
 

mostafa33

Joined
May 25, 2010
Messages
121
Likes
0
Points
16
#9
Re: Re:MPlayer always working

fmvillares said:
as far as i know always....this is a correct line using mpg123
application=/usr/local/bin/mpg123 -q -r 8000 -f 8192 -s --mono http://213.186.41.160:8000/

..join the new list asterisk-biz-hands-on in google groups where all the gurus here are going after dickos
the problem in mpg123 that it can't play all streams (like mms),
 

fmvillares

Joined
Sep 8, 2007
Messages
1,785
Likes
0
Points
0
#10
Re: Re:MPlayer always working

well then u have to manage how to convert the stream into any stream that asterisk can read correctly
 

fmvillares

Joined
Sep 8, 2007
Messages
1,785
Likes
0
Points
0
#11

mostafa33

Joined
May 25, 2010
Messages
121
Likes
0
Points
16
#12
Re: Re:MPlayer always working

fmvillares said:
well then u have to manage how to convert the stream into any stream that asterisk can read correctly
there is a software can convert the stream type??
 

fmvillares

Joined
Sep 8, 2007
Messages
1,785
Likes
0
Points
0
#13
Re: Re:MPlayer always working

read the post in voip info.....
 

mostafa33

Joined
May 25, 2010
Messages
121
Likes
0
Points
16
#14
i tried the script that run the mms stream in the voip-info post, but there is no voice

here the script, it needs any update?

#!/bin/bash
if -n "`ls /tmp/mayakpipe`" ; then
rm /tmp/mayakpipe
fi
PIPE="/tmp/mayakpipe"
mkfifo $PIPE
cat $PIPE &
sleep 3
mplayer -cache 8192 -cache-min 4 mms://stream.rfn.ru/mayak -really-quiet -quiet -ao pcm:fast -af resample=8000,channels=1,format=mulaw -ao pcm:file=$PIPE
rm $PIPE
 

mostafa33

Joined
May 25, 2010
Messages
121
Likes
0
Points
16
#15
i tried the script that run the mms stream in the voip-info post, but there is no voice

here the script, it needs any update?

#!/bin/bash
if -n "`ls /tmp/mayakpipe`" ; then
rm /tmp/mayakpipe
fi
PIPE="/tmp/mayakpipe"
mkfifo $PIPE
cat $PIPE &
sleep 3
mplayer -cache 8192 -cache-min 4 mms://stream.rfn.ru/mayak -really-quiet -quiet -ao pcm:fast -af resample=8000,channels=1,format=mulaw -ao pcm:file=$PIPE
rm $PIPE
 

jgutierrez

Joined
Feb 28, 2008
Messages
5,737
Likes
0
Points
0

mostafa33

Joined
May 25, 2010
Messages
121
Likes
0
Points
16
#17
no sound also
steps i have done:
1)create stream MOH
2)add the following lines in musiconhold_custom.conf
[uptemposmoothjazz]
mode=custom
dir=/var/lib/asterisk/mohmp3/uptemposmoothjazz
application = /yy/rr.sh
3)create the following script (rr.sh) in the path /yy
#!/bin/bash
if [ -n "`ls /tmp/asterisk-moh-pipe.*`" ]; then
rm /tmp/asterisk-moh-pipe.*
fi
PIPE="/tmp/asterisk-moh-pipe"
mknod $PIPE p

mplayer mms://radio.onlinehorizons.net/QuranKar

em -really-quiet -quiet -shuffle -ao pcm -format 0x2000 -channels 1 -af resample=8000 -ao pcm:file=$PIPE | cat $PIPE
rm $PIPE
4)add the MOH "uptemposmoothjazz" in a queue, but no sound, please help
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,901
Messages
130,885
Members
17,561
Latest member
marouen
Top