MOH Doesn't work!

Discussion in 'General' started by davidlu766, Oct 10, 2009.

  1. davidlu766

    Joined:
    Oct 10, 2009
    Messages:
    7
    Likes Received:
    0
    Hi,

    I have deleted all of the music on hold that came with Elastix and uploaded a music on hold file. So right now there should only be one music on hold, but when a caller id on hold, they can hear all four music when on hold. Even when I deleted them from FreePBX first and deleting it from the hard drive, IT'S STILL THERE!

    Please help
     
  2. ramoncio

    Joined:
    May 12, 2010
    Messages:
    1,663
    Likes Received:
    0
    Try with:

    Code:
    #delete mohmp3 folder
    rm -rf /var/lib/asterisk/mohmp3
    #create folder again
    mkdir /var/lib/asterisk/mohmp3
    #move there your new custom folder with mp3
    mv mycustommusiconholdfolder /var/lib/asterisk/mohmp3/
    #set right permissions
    chown -R asterisk.asterisk /var/lib/asterisk/mohmp3
    #restart asterisk to reload new moh folder
    amportal restart
    
     
  3. davidlu766

    Joined:
    Oct 10, 2009
    Messages:
    7
    Likes Received:
    0
    It works, thanks.
     
  4. ramoncio

    Joined:
    May 12, 2010
    Messages:
    1,663
    Likes Received:
    0
    I'm glad it worked!
     
  5. davidlu766

    Joined:
    Oct 10, 2009
    Messages:
    7
    Likes Received:
    0
    Hi,

    Do you know if there's anyway to continuously play the MOH? So that my callers that are on hold can hear the same thing and not starting from the beginning...?
     
  6. jasona

    Joined:
    Oct 8, 2009
    Messages:
    8
    Likes Received:
    0
    I'd also like to say thinks, I was fighting trying to get MOH working with an mp3, this did the trick for me!

    Jason
     

Share This Page