MOH Doesn't work!

davidlu766

Joined
Oct 10, 2009
Messages
7
Likes
0
Points
0
#1
Hi,

I have deleted all of the music on hold that came with Elastix and uploaded a music on hold file. So right now there should only be one music on hold, but when a caller id on hold, they can hear all four music when on hold. Even when I deleted them from FreePBX first and deleting it from the hard drive, IT'S STILL THERE!

Please help
 

ramoncio

Joined
May 12, 2010
Messages
1,663
Likes
0
Points
0
#2
Try with:

Code:
#delete mohmp3 folder
rm -rf /var/lib/asterisk/mohmp3
#create folder again
mkdir /var/lib/asterisk/mohmp3
#move there your new custom folder with mp3
mv mycustommusiconholdfolder /var/lib/asterisk/mohmp3/
#set right permissions
chown -R asterisk.asterisk /var/lib/asterisk/mohmp3
#restart asterisk to reload new moh folder
amportal restart
 

davidlu766

Joined
Oct 10, 2009
Messages
7
Likes
0
Points
0
#3
It works, thanks.
 

ramoncio

Joined
May 12, 2010
Messages
1,663
Likes
0
Points
0
#4
I'm glad it worked!
 

davidlu766

Joined
Oct 10, 2009
Messages
7
Likes
0
Points
0
#5
Hi,

Do you know if there's anyway to continuously play the MOH? So that my callers that are on hold can hear the same thing and not starting from the beginning...?
 

jasona

Joined
Oct 8, 2009
Messages
8
Likes
0
Points
0
#6
I'd also like to say thinks, I was fighting trying to get MOH working with an mp3, this did the trick for me!

Jason
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,915
Messages
130,920
Members
17,595
Latest member
feparra121
Top