mISDN NT config problem

Discussion in 'General' started by HBK, Sep 2, 2009.

  1. HBK

    HBK

    Joined:
    Sep 2, 2009
    Messages:
    3
    Likes Received:
    0
    Hi,

    I am struggling to get plain Cologne chip cards to run in NT mode, runs
    nice in TE mode despite the error message:


    misdnportinfo
    Port 1: TE-mode BRI S/T interface line (for phone lines)
    -> Protocol: DSS1 (Euro ISDN)
    -> Layer 4 protocol 0x04000001 is detected, but not allowed for TE lib.
    -> childcnt: 2
    * Port NOT useable for PBX (maybe there is already a PBX running?)
    --------
    Port 2: TE-mode BRI S/T interface line (for phone lines)
    -> Protocol: DSS1 (Euro ISDN)
    -> Layer 4 protocol 0x04000001 is detected, but not allowed for TE lib.
    -> childcnt: 2
    * Port NOT useable for PBX (maybe there is already a PBX running?)
    --------
    Port 3: NT-mode BRI S/T interface port (for phones)
    -> Layer 2 protocol 0x02000002 is detected, but not allowed for NT lib.
    * Port NOT useable for PBX (maybe there is already a PBX running?)
    --------
    Port 4: NT-mode BRI S/T interface port (for phones)
    -> Layer 2 protocol 0x02000002 is detected, but not allowed for NT lib.
    * Port NOT useable for PBX (maybe there is already a PBX running?)
    --------

    I do:

    etc/misdn-init.conf

    card=1,hfcpci
    card=2,hfcpci
    card=3,hfcpci
    card=4,hfcpci

    te_ptmp=1,2
    nt_ptp=3,4

    ---

    etc/misdn.conf

    <mISDNconf>
    <module poll="128" debug="0" timer="no">hfcmulti</module>
    <module debug="0" options="0">mISDN_dsp</module>
    <devnode user="asterisk" group="asterisk" mode="660">mISDN</devnode>
    <card type="hfcpci">
    <port mode="te" link="ptmp">1</port>
    </card>
    <card type="hfcpci">
    <port mode="te" link="ptmp">1</port>
    </card>
    <card type="hfcpci" dtmf="yes" crystalclock="yes">
    <port mode="nt" link="ptp">1</port>
    </card>
    <card type="hfcpci" dtmf="yes" crystalclock="yes">
    <port mode="nt" link="ptp">1</port>
    </card>
    </mISDNconf>

    --

    etc/asterisk/misdn.conf

    ;Tried with both config's no change

    misdn_init=/etc/misdn-init.conf
    ;misdn_init=/etc/mISDN.conf


    [trunks]
    ports=1,2
    context=from-trunk
    msns=*

    [NTports]
    context=from-internal
    ports=3,4
    msns=*

    -------------------------------------------------------
    I am using Elastix 1.5 not updated

    Any tips?
    Where can I find documentation?

    Thank you!
    HB
     
  2. HBK

    HBK

    Joined:
    Sep 2, 2009
    Messages:
    3
    Likes Received:
    0
    Works nicely now, I presume th eold ISDN phones and cables had been to long on the shelf. Some contact cleaner and all worked nicely!

    And ... I just ignored the error messages for now at least!
    HB
     

Share This Page