mISDN and how to keep it up!?

Discussion in 'General' started by MadDogMike, Oct 22, 2007.

  1. MadDogMike

    Joined:
    Oct 22, 2007
    Messages:
    10
    Likes Received:
    0
    Hi All,

    Firstly, just a great word of thanks for such an easy to install and easy to learn distro!

    I've been battling for months now to get my HFC isdn card to work, and now it finally does.

    1 slight problem though.

    after mISDN start from root I find I must CLI > load chan_misdn.so which loads the mISDN driver into Asterisk.

    Where do we set up that mISDN start gets done at boot and load chan_misdn.so as a module in Asterisk?

    I have tried a load => chan_misdn.so in /etc/astersik/modules.conf at front end of file
    and chan_misdn.so=yes in [general] but it get's lost somehow if the pbx is restarted and these commands need to be manually run at the CLI.

    Any help will finally get me some sleep.

    Thanks to all!!

    B)
     
  2. mbit

    Joined:
    Jul 4, 2007
    Messages:
    466
    Likes Received:
    0
    Check your /etc/rc.d/rc.local and make sure the MISDN drivers are loading before asterisk loads on boot.
     
  3. MadDogMike

    Joined:
    Oct 22, 2007
    Messages:
    10
    Likes Received:
    0
    mbit, you be da man!!

    Thanks for the help, now I can finally get some shut eye....

    :silly:

    mDm
     
  4. virusbcn

    Joined:
    Sep 12, 2008
    Messages:
    99
    Likes Received:
    0
    Hello, in all of my Elastix 1.3 installs i have the same problem, all of them have a Digium B410P, and all of them not start misdn, i have to open a putty and make an "misdn-init start" and "amportal restart"
    I make the change that mbit tells, but no changes, when i restart Elastix the misdn is not start and not make calls until i have "misdn-init start & amportal restart"
    This is my /etc/rc.d/rc.local :

    #!/bin/sh
    #
    # This script will be executed *after* all the other init scripts.
    # You can put your own initialization stuff in here if you don't
    # want to do the full Sys V style init stuff.

    touch /var/lock/subsys/local
    /usr/local/sbin/motd.sh > /etc/motd
    /sbin/fxotune -s
    /usr/sbin/misdn-init start
    /usr/sbin/amportal start_fop

    Please, anybody can help me ???

    Thanks and best regards
     
  5. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    Try

    /sbin/fxotune -s

    /usr/sbin/amportal stop
    /usr/sbin/misdn-init start
    /usr/sbin/amportal start

    instead, (for a quick, albeit inelegant, fix)
     
  6. virusbcn

    Joined:
    Sep 12, 2008
    Messages:
    99
    Likes Received:
    0
    A lot of thank you dicko, after write this post i thinking and thinking, and i test to put this:

    touch /var/lock/subsys/local
    /usr/local/sbin/motd.sh > /etc/motd
    /sbin/fxotune -s
    /usr/sbin/misdn-init start
    /usr/sbin/amportal start_fop
    /usr/sbin/amportal restart


    And it's working now after reboot :lol: :lol: :lol: , after 2 months thinking about error :blush:

    Sometimes until you writes the error, think, and make a post, you don't have an idea until you write the error :S

    Thankyou and i hope this answer helps other people ;)
     
  7. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    you can do that but it remains inelegant, your

    amportal start_fop

    is unnecessary as amportal restart will immediately stop fop and then restart it

    the correct way to do, which eliminate all that stuff in S99local, and set appropriate S and K links in the /etc/rc3.d/ directory (as already mentioned in this thread), chances are from the name of the script you are using that typing setup from the bash shell and then choosing "system services" will give you the option to "turn on" misdn and all your problems will go away, just like if you had "read the manual" two months ago. ;-)

    Good luck, glad it's working for you
     
  8. MadDogMike

    Joined:
    Oct 22, 2007
    Messages:
    10
    Likes Received:
    0
    Oh hell, I shulda read the manual all thoose years ago...

    Only way I could get mISDN to start was to install Webmin and then switch on mISDN under System => Bootup and Shutdown and setting mISDN to yes.

    Thanks for helping dicko

    MDM
     

Share This Page