meetme exit code "p"

witekprytek

Joined
Dec 19, 2007
Messages
145
Likes
0
Points
0
#1
I need to be able end meetme conference by pressing some code
In i have found in Meetme documentation that "p" key could be used for this

p(keys)

Allow user to exit the conference by pressing # (default) or any of the defined keys. If keys contain * this will override option s. The key used is set to channel variable MEETME_EXIT_KEY.

my cuscom extension look like this:
[record-custom]
exten => s,1,Answer
exten => s,2,Set(AMPUSER=${IF($["foo${AMPUSER}" = "foo"]?${CALLERID(number)}:${AMPUSER})})
""],Set,REALCALLERIDNUM=${CALLERID(number)})
exten => s,3,Set(MEETME_EXIT_KEY=555)
exten => s,4,Set(MEETME_RECORDINGFILE=${EXTEN:}-${STRFTIME(${EPOCH},,%Y%m%d-%H%M)}-${CALLERID(num)})
exten => s,5,MixMonitor(${MEETME_RECORDINGFILE}.wav)
exten => s,6,MeetMe(8${AMPUSER}|Aa1mqrxp)


when the user connect to the conference everything looks fine: I have "MEETME_EXIT_KEY=555"
but conference ends only when "#" is pressed

Could somebody help with that issue?

-- Executing [s@record-custom:1] Answer("SIP/10.233.111.133-b56643b0", "") in new stack
-- Executing [s@record-custom:2] Set("SIP/10.233.111.133-b56643b0", "AMPUSER=149") in new stack
-- Executing [s@record-custom:3] Set("SIP/10.233.111.133-b56643b0", "MEETME_EXIT_KEY=555") in new stack
-- Executing [s@record-custom:4] Set("SIP/10.233.111.133-b56643b0", "MEETME_RECORDINGFILE=s-20100702-1831-149") in new stack
-- Executing [s@record-custom:5] MixMonitor("SIP/10.233.111.133-b56643b0", "s-20100702-1831-149.wav") in new stack
-- Executing [s@record-custom:6] MeetMe("SIP/10.233.111.133-b56643b0", "8149|Aa1mqrxp") in new stack
 

jgutierrez

Joined
Feb 28, 2008
Messages
5,737
Likes
0
Points
0
#2
Try the following:

[record-custom]
exten => s,1,Answer
exten => s,n,Set(AMPUSER=${IF($["foo${AMPUSER}" = "foo"]?${CALLERID(number)}:${AMPUSER})})
""],Set,REALCALLERIDNUM=${CALLERID(number)})
exten => s,n,Set(MEETME_RECORDINGFILE=${EXTEN:}-${STRFTIME(${EPOCH},,%Y%%d-%H%M)}-${CALLERID(num)})
exten => s,n,MixMonitor(${MEETME_RECORDINGFILE}.wav)
exten => s,n,MeetMe(8${AMPUSER}|Aa1mqrxp(555))

Dont forget to execute a module reload, and try again, if that doesn´t work, paste the CLI output
 

witekprytek

Joined
Dec 19, 2007
Messages
145
Likes
0
Points
0
#3
jgutierrez: does it not work for me.
I can finish the conference only by pressing "#"

But this is not what I want. I need an option to finish the conference using pin code.
 

jgutierrez

Joined
Feb 28, 2008
Messages
5,737
Likes
0
Points
0
#4
You havent pasted the CLI output, as it was requested on my previous post
 

witekprytek

Joined
Dec 19, 2007
Messages
145
Likes
0
Points
0
#5
when 555 is pressed during conference (or any other key unless "#")
cli shows nothing:

Executing [s@record-custom:1] Answer("SIP/888-b560aa50", "") in new stack
-- Executing [s@record-custom:2] Set("SIP/888-b560aa50", "AMPUSER=888") in new stack
-- Executing [s@record-custom:3] Set("SIP/888-b560aa50", "MEETME_EXIT_KEY=555") in new stack
-- Executing [s@record-custom:4] Set("SIP/888-b560aa50", "MEETME_RECORDINGFILE=s-20100704-0747-888") in new stack
-- Executing [s@record-custom:5] MixMonitor("SIP/888-b560aa50", "s-20100704-0747-888.wav") in new stack
-- Executing [s@record-custom:6] MeetMe("SIP/888-b560aa50", "8888|Aa1mqrxp(555)") in new stack
== Parsing '/etc/asterisk/meetme.conf': Found
== Parsing '/etc/asterisk/meetme_additional.confa': Found
-- Created MeetMe conference 1023 for conference '8888'
> Starting recording of MeetMe Conference 8888 into file s-20100704-0747-888.wav.
== Begin MixMonitor Recording SIP/888-b560aa50

when somebody press "#"

-- Executing [s@record-custom:7] Hangup("SIP/888-b560aa50", "") in new stack
== Spawn extension (record-custom, s, 7) exited non-zero on 'SIP/888-b560aa50'
== End MixMonitor Recording SIP/888-b560aa50
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,902
Messages
130,887
Members
17,565
Latest member
omarmenichetti
Top