lost password for web interface

Discussion in 'General' started by mahizzm, Mar 25, 2007.

  1. mahizzm

    mahizzm Guest

    Hi can someone tell me how I can retrieve the admin password for the Elastix webinterface. I can log in as root, but somehow the webinterface password is lost. Plse help!:(
  2. adminad

    Apr 29, 2010
    Likes Received:
    Mmm... very big mistake.

    Please, replace the file /var/www/db/acl.db for a new one.

    You can obtain a fresh acl.db file from your installation CD. Please mount the CD and extract this file from the elastix RPM.

    rpm2cpio - < /path_the_rpm/elastix-0.7-0.noarch.rpm | cpio -id ./var/www/db/acl.db

    The default user/password is admin/palosanto<br><br>Post edited by: admin, at: 2007/03/25 03:38
  3. mahizzm

    mahizzm Guest

    Thanx Edgar :) , don't know how it happened. Normally I use only few possible passwords if not, I write it down. But I learn by this to take extra more care with it. I will try to replace the acl.db and let you know the outcome.
  4. mahizzm

    mahizzm Guest

    After replacing acl.db with version from rpm, everything was back to normal again. Thanx again Edgar :) .
  5. punto_keanz

    Jul 15, 2012
    Likes Received:
    I tried this command but have mistake
    rpm2cpio - < /home/elastix-2.0.0-57.noarch.rpm | cpio -id ./var/www/db/acl.db
    [8] 26249
    bash: lt: command not found

    [7]+ Stopped rpm2cpio -
    bash: /home/elastix-2.0.0-57.noarch.rpm: cannot execute binary file
    cpio: premature end of archive

Share This Page